"No se puede mostrar Dynamics 365 Aplicación para Outlook porque el rol de usuario actual no tiene los permisos necesarios" se produce en Microsoft Dynamics 365 App for Outlook

Este artículo le ayuda a corregir un problema en el que no puede abrir Microsoft Dynamics 365 App for Outlook si el rol de seguridad de Dynamics 365 no tiene acceso al módulo de aplicación.

Se aplica a: Microsoft Dynamics CRM Online
Número de KB original: 4229661

Síntomas

Al abrir la aplicación microsoft Dynamics 365 para Outlook, verá el siguiente error:

Lo sentimos.
No se puede mostrar Dynamics 365 Aplicación para Outlook porque el rol de usuario actual no tiene los permisos necesarios. Póngase en contacto con el administrador para tener asignado el rol de seguridad necesario a la solución Dynamics 365 App for Outlook.

Si hace clic en Mostrar más, los detalles adicionales incluyen la siguiente información:

Error: No tiene permisos para recuperar appforOutlookModule id.
Seguimiento: Error: No tiene permisos para recuperar el identificador de AppforOutlookModule en new ...

Causa

Este error aparece si el rol de seguridad de Dynamics 365 no tiene acceso al módulo de aplicación que usa la aplicación de Dynamics 365 para Outlook.

Solución

Compruebe que el rol de seguridad de Dynamics 365 tenga acceso suficiente para cargar el módulo de aplicación que usa la aplicación de Dynamics 365 para Outlook.

  1. Compruebe que el rol de seguridad tiene acceso al módulo de aplicación Dynamics 365 App for Outlook:

    Proporcionar acceso al rol de seguridad

    Importante

    Los roles de seguridad personalizados no tienen acceso al módulo de aplicación de Dynamics 365 de forma predeterminada. Los pasos del artículo al que se hace referencia anteriormente son necesarios.

  2. Consulte la siguiente documentación para obtener los privilegios necesarios para usar la aplicación para Outlook:

    Se produce un error de privilegio al intentar usar Dynamics 365 App para Outlook

  3. Después de comprobar todos los privilegios necesarios, cierre y vuelva a abrir Outlook.