Síntoma
Este mensaje de error se muestra al intentar registrar un equipo mediante la aplicación en tiempo de ejecución de la máquina Power Automate:
"Se ha producido un error al registrar el equipo. Power Automate es posible que no se hayan instalado correctamente. Siga los pasos de las secciones de más información".
Causa
Este problema se debe a que la aplicación Power Automate para escritorio no se instala correctamente debido a una instalación o desinstalación anterior que puso el perfil de usuario "NT Service\UIFlowService" en un estado roto.
Solución
Para empezar, desinstale Power Automate para escritorio del equipo y asegúrese de que los archivos relacionados, ubicados en C:\Archivos de programa (x86)\Power Automate Desktop, se eliminan.
El perfil de usuario debe restablecerse manualmente.
-
Comprueba la configuración del perfil UIFlowService:
-
Abre el Editor del Registro y ve a la carpeta de claves: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-80-3017052307-2994996872-1615411526-3164924635-3391446484
Si existe una segunda clave con la extensión ".bak", puede eliminarla. -
Vaya a la ubicación de ProfileImagePath.
-
Compruebe que la carpeta "UIFlowService" está presente en ese directorio a través de Explorador de archivos. De forma predeterminada, se encuentra en %SystemRoot%\ServiceProfiles.
-
Modifique el valor de ProfileImagePath para que apunte a la carpeta UIFlowService existente. De forma predeterminada, debe ser %SystemRoot%\ServiceProfiles\UIFlowService.
-
-
Reinicia el equipo.
-
Vuelva a intentar instalar Power Automate para escritorio.