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Síntomas

Puede experimentar uno o varios de los siguientes problemas en Windows Small Business Server (SBS) 2011.

Cuando se instala Windows SBS 2011, recibirá uno o varios de los siguientes mensajes de error:

  • El programa de instalación: Aquí es la lista de los errores encontrados durante la instalación.

  • El programa de instalación: No se puede instalar Exchange Server 2010

  • ConfigureWSSOutgoingEmailTask: El correo electrónico entrante y saliente de Microsoft SharePoint Foundation no están configurados.

Después de instalar Windows SBS 2011, se producen los problemas siguientes:

  • Exchange Server 2010 se ejecuta en un modo de evaluación y requiere una clave de activación.

  • No puede crear nuevos usuarios en la consola de Windows SBS.

  • No puede aplicar funciones a los usuarios en la consola de Windows SBS.

  • No se puede completar el Asistente para "Conectarse a Internet" o el Asistente para la "Administración de direcciones de Internet".

Cuando se abre la Consola de administración de Exchange en un equipo que ejecuta Windows SBS 2011, recibirá el siguiente mensaje:

Los siguientes servidores de la organización que ejecute Exchange Server 2010 están sin licencia actualmente.

Nota: Este mensaje también muestra el nombre de equipo del equipo que ejecuta Windows SBS 2011 Standard.

Causa

Estos problemas pueden producirse si se cumple alguna de las condiciones siguientes:

  • Condición 1

    Durante la instalación de Windows SBS 2011, no se instaló Exchange Server 2010. Más adelante se instaló manualmente Exchange Server 2010.

  • Condición 2

    Exchange Server 2010 se desinstaló de Windows SBS 2011 y luego se volvió a instalar.

  • Condición 3

    Se completó una reparación de la instalación de Exchange Server 2010 en el servidor Windows SBS 2011.

Solución

Para resolver este problema si experimenta condición 1 o condición 2, siga los pasos descritos en la sección "problemas de secuencia de comandos de PowerShell para resolver de Exchange Server". A continuación, instale el hotfix que se describe en la sección "Información de la revisión".

Para resolver este problema si experimenta condición 3, instale la revisión que se describe en la sección "Información de la revisión".

Script de PowerShell para resolver los problemas de Exchange Server




Importante antes de realizar estos pasos, Exchange Server 2010 debe instalarse correctamente. Siga los pasos que se describen en este artículo si las siguientes funciones de Exchange Server 2010 están instaladas incorrectamente:

  • Buzón de correo

  • Hub/Transport

  • Entidades emisoras de certificados (servidor de acceso de cliente)

  • Administración de

Los pasos siguientes configuración Exchange Server 2010 a la configuración predeterminada una correcta instalación de Windows SBS 2011.

Nota: Si ha configurado manualmente la configuración en Exchange, la configuración se puede cambiar y hasta finalizar a los asistentes de Windows SBS correctos o hasta que se vuelve a configurar Exchange Server puede dejar de flujo de correo. Además, debe tener una topología de red compatibles de un único adaptador de red y de una subred de clase C.

Estos pasos realice los siguientes cambios:

  • Establece el nombre de la Base de datos de buzones de correo en el registro

  • Corrige la versión de función de herramientas de administración en el registro

  • Agrega un valor predeterminado del atributo de Active Directory msSBSEmailQuota para las funciones de Windows SBS de tres predeterminadas

  • Configura las funciones de seguridad correcta para administrar el servidor que está ejecutando Exchange Server

  • Agrega los permisos en el nivel de organización para dar acceso a la cuenta del sistema

  • Si no se han creado los grupos, crea los siguientes grupos:

    • SBSAdmins

    • ALLUSERS

    • Administrador de correo

    • FSRMReports

  • Establece la misma pertenencia y configuración para cada uno de estos grupos

  • Configura las opciones de transporte para los servidores internos y una dirección del administrador

  • El valor predeterminado, vuelve a enlazar el conector a la red interna, sin incluir la IP del enrutador interno de recepción

  • Elimina el cliente predeterminado del conector de recepción

  • Permite que el certificado de emisión propia de Windows SBS tiene CN = sitios

  • Quita el certificado autofirmado de Exchange Server

  • Configura la configuración de mensaje de correo electrónico saliente de Microsoft SharePoint

  • Agrega un registro de host de DNS para el servidor de Protocolo Simple de transferencia de correo (SMTP) de SharePoint

  • Agrega claves del registro varios para quitar los problemas de instalación

  • Activa el servidor de Exchange mediante la herramienta proporcionada

Para resolver estos problemas si Exchange Server 2010 se instaló manualmente después de instalar Windows SBS 2011, o si Exchange Server 2010 se volvió a instalar en el servidor Windows SBS 2011, siga estos pasos:

  1. Seleccione el comando Ejecutar como administrador para ejecutar el Shell de administración de Exchange en modo con privilegios elevados.

  2. En el Shell de administración de Exchange, ejecute los comandos siguientes en este orden:

    #SBS 2011 Std
    #Launch de Shell de administración de Exchange como administrador.
    #This script realiza las tareas que faltan después de una instalación de Exchange error durante una migración.

    # Ejecutar cada sección, separado por los comentarios de forma individual.

    Instalación de ##Exchange se debe completar con los parámetros adecuados antes de ejecutar esta secuencia de comandos.


    ## Configure nombre del buzón en el registro
    $mbx = get-MailboxDatabase-servidor $env: NOMBREDEEQUIPO
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Messaging"-el nombre "MailboxDatabaseName"-$mbx de valor. Nombre

    ## Add reg clave para herramientas de administración, esto es necesario debido a la forma en que se empaqueta SBSSetup.
    $Version = "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools" get-itemproperty
    Set-ItemProperty "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools"-el nombre "ConfiguredVersion"-valor $Version.UnpackedVersion

    ## Configure Exchange atributo en funciones de usuario. Esto podría fallar si faltan los Roles de usuario.
    Import-Module ActiveDirectory
    conjunto-aduser "Usuario estándar"-Agregar @{msSBSEmailQuota = 2097152}
    conjunto-aduser "WebWorkplaceTools"-Agregar @{msSBSEmailQuota = 2097152}
    conjunto-aduser "Red Admin"-Agregar @{msSBSEmailQuota = 2097152}

    ##ExchangeAdminPrep
    Agregar-RoleGroupMember-identidad "Administración de la organización"-miembro "$env: USERDOMAIN\Domain administradores" - BypassSecurityGroupManagerCheck
    Agregar-RoleGroupMember-identidad "Administración de organizaciones con permiso de vista"-miembro "$env: USERDOMAIN\$ env: COMPUTERNAME$" - BypassSecurityGroupManagerCheck
    $org = get-OrganizationConfig
    Agregar-adpermission-identidad $org DistinguishedName-- AccessRights de "SISTEMA" de usuario "GenericAll" - InheritanceType "Todo"

    ##CreateMailDisributionGroupsTask
    # Si los grupos existen ya puede recibir un error, que es aceptable, es simplemente un signo de que el programa de instalación de SBS se realizó varias veces y el origen que no nunca se restaura desde una copia de seguridad.

    Nuevo DistributionGroup - SamAccountName "sbsadmins"-Alias "sbsadmins"-nombre "Administradores de Windows SBS" - OrganizationalUnit $env: DOMINIODNSDELUSUARIO "Miempresa/grupos de distribución": escriba "Distribución" - ErrorAction SilentlyContinue

    Nuevo DistributionGroup - SamAccountName "allusers"-Alias "allusers"-nombre "Todos los usuarios" - OrganizationalUnit $env: DOMINIODNSDELUSUARIO "Miempresa/grupos de distribución": escriba "Distribución" - ErrorAction SilentlyContinue

    Habilitar-DistributionGroup-identidad "Todos los usuarios"-Alias "allusers" - WarningAction SilentlyContinue - ErrorAction SilentlyContinue

    Habilitar-DistributionGroup-identidad "Administradores de Windows SBS"-Alias "sbsadmins" - WarningAction SilentlyContinue - ErrorAction SilentlyContinue

    $False Set-DistributionGroup - RequireSenderAuthenticationEnabled-identidad "Administradores de Windows SBS" - ForceUpgrade

    Nuevo DistributionGroup - SamAccountName "postmaster"-Alias "postmaster"-nombre "Postmaster y abuso Reporting" - OrganizationalUnit $env: DOMINIODNSDELUSUARIO "Miempresa/grupos de distribución": escriba "Distribución" - WarningAction SilentlyContinue - ErrorAction SilentlyContinue

    Set-DistributionGroup-identidad "Postmaster y abuso Reporting" - RequireSenderAuthenticationEnabled $false - HiddenFromAddressListsEnabled $true - EmailAddresses "SMTP:postmaster@$env:USERDNSDOMAIN","SMTP:abuse@$env:USERDNSDOMAIN" - EmailAddressPolicyEnabled $false - ForceUpgrade - WarningAction SilentlyContinue - ErrorAction SilentlyContinue

    Agregar-DistributionGroupMember-Identity "Administrador de correo e informes de abuso"-miembro "Administradores SBS de Windows"

    Nuevo DistributionGroup - SamAccountName "fsrmreports"-Alias "fsrmreports"-nombre "Informes del Administrador de recursos de archivo Server" - OrganizationalUnit $env: DOMINIODNSDELUSUARIO "Miempresa/grupos de distribución": escriba "Distribución" - WarningAction SilentlyContinue - ErrorAction SilentlyContinue

    Set-DistributionGroup-identidad "Informes del Administrador de recursos de archivo Server" - HiddenFromAddressListsEnabled $true - ForceUpgrade
    Agregar-DistributionGroupMember-Identity "Informes de File Server Resource Manager"-miembro "Administradores SBS de Windows"

    ##ConfigureIntranetSMTPTask

    Set-TransportConfig - InternalSMTPServers 127.0.0.1
    Set-transportconfig - ExternalPostmasterAddress "postmaster@$env:USERDNSDOMAIN"

    Conector de recepción predeterminado de ##rebind
    # En esta sección se va a cambiar el valor predeterminado recibir conector para escuchar sólo en la subred interna (menos el enrutador), el flujo de correo puede detener en este momento.

    ¿$ip = (gwmi Win32_NetworkAdapterConfiguration |? { $_. Dirección IP - ne $null}).ipaddress.get(0)
    ¿$gateway = (gwmi Win32_NetworkAdapterConfiguration |? { $_. Dirección IP - ne $null}). DefaultIPGateway
    $gw="$gateway"
    $gwIp=$gw.split('.')
    $subnet=$gw.Remove($gw.LastIndexOf('.'))+".0"
    $range=$subnet+"-"+$gw.Remove($gw.LastIndexOf('.'))+"."+($gwIp.get(3)-1)+","+$gw.Remove($gw.LastIndexOf('.'))+"."+([int]$gwIp.get(3)+1)+"-"+$gw.Remove($gw.LastIndexOf('.'))+".255"

    $con = get-receiveconnector-identidad "Default $env: nombreDeEquipo"
    $ip+=":25"
    $con.Bindings=$ip
    Set-receiveconnector-identidad "Default $env: nombreDeEquipo"-enlaces $con. Enlaces

    $ipAdd = $range. Split(',')
    $con.remoteipranges = $ipAdd[0]
    $con.remoteipranges += $ipAdd[1]

    Set-receiveconnector-identidad "Default $env: nombreDeEquipo" RemoteIpRanges - $con.remoteipranges


    Conector de recepción de cliente predeterminado de ##delete
    # Si está en uso por ahora, debe omitir este paso o volver a crear el conector.
    quitar-receiveconnector-identidad "cliente $env: nombreDeEquipo"-confirmar: $false

    ##Remove el valor predeterminado de exchange cert y habilitar nuestro
    ¿Get-ExchangeCertificate |? {$_. Asunto - eq "CN = Sites"} | Enable-ExchangeCertificate-servicios SMTP-forzar: $true
    #remove
    ¿Get-ExchangeCertificate |? {$_. FriendlyName - eq "Microsoft Exchange"} | Remove-ExchangeCertificate

    ## New conector de recepción
    #Create interno conector de recepción para SharePoint, el Fax y el conector POP3

    New-receiveconnector-nombre "Sharepoint recepción de Fax de Windows SBS $env: nombreDeEquipo" RemoteIPRanges - 127.0.0.1-127.0.0.1-"BasicAuth" enlaces "127.0.0.1:25" - AuthMechanism - PermissionGroups como "Configuración, ExchangeUsers"-uso "Custom" - servidor "$env: NOMBREDEEQUIPO" ConnectionTimeout-"00.06:00:00"


    ##ConfigureWSSOutgoingEmailTask
    # Configura el enrutamiento de correo electrónico saliente de SharePoint para usar Exchange.
    # Éste podría no funcionar si SharePoint es no utilizando la configuración predeterminada o no funciona.

    Add-PsSnapin Microsoft.SharePoint.PowerShell
    $spWebApp=Get-SPWebApplication
    $mail="CompanyWebAdmin@"+$env:userdnsdomain
    $spWebApp.UpdateMailSettings("SharepointSMTPServer",$mail,$mail,65001)
    dnscmd $env: nombreDeEquipo /recordadd $env: DominioDNSDelUsuario SharepointSMTPServer A 127.0.0.1

    ## Add componentes de mensajería clave de reg
    $val = "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components\" get-itemproperty
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components"-nombre de "Mensajería" - valor $val.administration

    Problemas de pantalla de ##Fix
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup"-el nombre "DisplayIssues"-valor False

    Marca de agua de ##Tag secuencia de comandos
    $date=Get-Date
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup"-el nombre "RepairScript"-"ExchangeFailureCompleteSetup $date" de valor

  3. Agregar usuarios mediante la consola de Windows SBS.

  4. Complete el Asistente de "Administración de direcciones de Internet".

  5. Instale el paquete de hotfix relacionados con para activar el servidor de Exchange.

Vaya a la próxima sección para instalar el paquete de hotfix para activar el servidor de Exchange.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe estar ejecutando Windows Small Business Server 2011.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

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