Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Al ejecutar pruebas de IU codificadas en 2013 de Microsoft Visual Studio o el controlador de pruebas y el agente de prueba 2013, puede experimentar los problemas siguientes:

  • Problema 1:

    Al ejecutar pruebas de IU codificadas en 10 de Windows, no se pueden identificar los controles.

  • Problema 2:

    Extensiones de interfaz de usuario codificadas no funcionen después de actualizar a Visual Studio 2013 actualización 2 desde una versión anterior de Visual Studio de 2013.

Causa

Problema 1 se produce porque Windows 10, se produce una interrupción en una API que está consumiendo IU codificadas.

Problema 2 se produce porque codificadas extensibilidad de interfaz de usuario rediseñada en Visual Studio 2013 actualización 2. La implementación de UIAComWrapper tiene huecos en comparación con el Interop.UIAutomationClient que se usa anteriormente en relación con el registro de proveedor en el cliente.

Solución

Las actualizaciones están disponibles para su descarga desde Microsoft Download Center.

Centro de descarga de Microsoft

El siguiente archivo está disponible para su descarga desde el Centro de descarga de Microsoft:

Para Visual Studio 2013 actualización 5:

Configuraciones regionales

Rutas de acceso de archivo

Inglés

http://download.microsoft.com/download/8/A/F/8AF4BE40-E58C-40EA-9D25-3FFDB18B7BB2/VS12-KB3122551.exe



Agentes de prueba:

Configuraciones regionales

Rutas de acceso de archivo

Alemán

http://download.microsoft.com/download/8/8/C/88C64D41-8EF9-4F86-80EE-D36260303B2F/vstf_testagent.exe

Inglés

http://download.microsoft.com/download/8/0/8/8088975B-54A5-4E70-80BB-7F5E405796E4/vstf_testagent.exe

Español

http://download.microsoft.com/download/0/7/E/07E3E8F3-51C3-4B6E-B042-C73A3E1847A0/vstf_testagent.exe

Francés

http://download.microsoft.com/download/5/7/2/57288A11-ED87-4EC7-8AB0-0F8616743E7A/vstf_testagent.exe

Italiano

http://download.microsoft.com/download/6/0/1/601F5526-A4A2-4188-A80D-24DF27AF6614/vstf_testagent.exe

Japonés

http://download.microsoft.com/download/3/2/3/3237B8C1-52BA-4A42-9FEC-63237C4403B1/vstf_testagent.exe

Coreano

http://download.microsoft.com/download/B/3/E/B3E7137D-2FA6-41FB-A7C0-CAE7CC3B9332/vstf_testagent.exe

Ruso

http://download.microsoft.com/download/7/1/E/71EDE1F8-975D-43CA-AB47-F004F9AC19D5/vstf_testagent.exe

Chino (China)

http://download.microsoft.com/download/E/9/B/E9BC60F9-EDCF-4002-98CB-CC000A6472EA/vstf_testagent.exe

Chino - Taiwán

http://download.microsoft.com/download/8/2/D/82D04CCD-A975-4141-B2FA-3A057CCC3405/vstf_testagent.exe



Para el controlador de Team Test:

Configuraciones regionales

Ruta de acceso de archivo

Alemán

http://download.microsoft.com/download/1/2/5/1257A548-AF96-43B9-A536-2B7DFC5E581F/vstf_testcontroller.exe

Inglés

http://download.microsoft.com/download/0/9/A/09A17089-FF41-4474-B091-C1B666818FB0/vstf_testcontroller.exe

Español

http://download.microsoft.com/download/6/8/1/68114923-E0CA-4A35-8180-CC74AC6AE898/vstf_testcontroller.exe

Francés

http://download.microsoft.com/download/2/1/0/210FD878-10F4-492B-8096-05F67AD1F075/vstf_testcontroller.exe

Italiano

http://download.microsoft.com/download/C/9/D/C9DB3A96-6CF6-471E-9C2D-D70316BA0E88/vstf_testcontroller.exe

Japonés

http://download.microsoft.com/download/4/0/D/40DD2481-5941-43DF-B0D2-68B5997533AF/vstf_testcontroller.exe

Coreano

http://download.microsoft.com/download/E/1/7/E17CD77B-AC21-4400-88E7-A5EE9D0902E0/vstf_testcontroller.exe

Ruso

http://download.microsoft.com/download/5/7/5/575A7A82-B418-4B6A-8FB1-5642B908FDBE/vstf_testcontroller.exe

Chino (China)

http://download.microsoft.com/download/3/A/1/3A1CED3D-BC2F-4E90-97AA-154628A8DF7F/vstf_testcontroller.exe

Chino - Taiwán

http://download.microsoft.com/download/F/0/B/F0B82E41-79F6-4758-8DAB-F825C5B3A03E/vstf_testcontroller.exe


Para obtener más información acerca de cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:

119591 cómo obtener archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft analizó este archivo en busca de virus. Microsoft ha utilizado el software de detección de virus más reciente que estaba disponible en la fecha en que se publicó el archivo. El archivo se almacena en servidores seguros que ayudan a evitar cambios no autorizados en el archivo.



Requisitos previos

Esta revisión requiere Visual Studio 2013 actualización 5, 5 de actualización de agente de prueba o actualización de controladores de prueba 5.

Información de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.



Información de reemplazo

Esta revisión no sustituye cualquier revisión lanzada anteriormente.



¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×