La característica Fuera de office de Outlook no funciona correctamente en Microsoft 365

Síntomas

Al intentar usar la característica Fuera de office (OOF) en Outlook en Microsoft 365, experimenta los síntomas siguientes:

  • No se puede guardar el mensaje OOF.
  • Se envía un mensaje OOF antiguo o duplicado.
  • No se envía un mensaje OOF aunque habilite el mensaje de OOF.

Causa

Este problema se produce debido a uno de los siguientes motivos:

  • Causa 1: Hay un trabajo pendiente de eventos de asistente de buzón (solo Exchange 2010).
  • Causa 2: Las plantillas de reglas de OOF tienen un formato incorrecto o están dañadas.
  • Causa 3: Se supera la cuota de reglas de OOF y no se pueden crear nuevas reglas.
  • Causa 4: La configuración de Dominio remoto para el dominio predeterminado (o específico) no está establecida para permitir mensajes OOF.

Solución

Nota:

Cualquiera de las cuatro causas puede provocar un error en una respuesta de OOF. Por lo tanto, cada causa debe descartarse de uno en uno.

Advertencia

El uso de Microsoft Exchange Server Editor MAPI (MFCMapi) puede dañar Microsoft Exchange Server y los buzones de exchange server. Descargue MFCMAPI desde GitHub (desplácese hacia abajo y seleccione Versión más reciente).

Para resolver este problema, siga los pasos de la causa específica.

Solución 1

  1. Configure la característica OOF. Para ello, ejecute cualquiera de los siguientes cmdlets en Windows PowerShell, según corresponda:

    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

  2. Use MFCMapi para comprobar el PR_OOF_STATE valor. Para ello, siga estos pasos:

    1. En la ventana principal de MFCMapi, seleccione Sesión y, a continuación, seleccione Inicio de sesión y Mostrar tabla de almacén para abrir el buzón.

    2. Seleccione el perfil al que tiene acceso y desplácese hacia abajo en el panel inferior hasta que vea el PR_OOF_STATE valor. Este valor debe ser True si ha habilitado la característica OOF en Windows PowerShell o False si ha deshabilitado la característica OOF. Por ejemplo, si deshabilitó la característica OOF, tenga en cuenta la siguiente captura de pantalla:

      Captura de pantalla del valor de PR_OOF_STATE.

  3. Si el PR_OOF_STATE valor no es el resultado esperado, póngase en contacto con Soporte técnico de Microsoft para que comprueben los eventos en cola (solo Exchange 2010).

Solución 2

Nota:

Los síntomas en tu caso pueden diferir ligeramente de estos. Por ejemplo, el mensaje OOF no se puede enviar según lo esperado, aunque el mensaje OOF se puede establecer sin error. Sin embargo, estos pasos se seguirán aplicando.

Para resolver este problema, elimine las reglas de OOF y las plantillas de reglas de OOF del buzón. A continuación, vuelva a habilitar la característica OOF y pruebe el comportamiento. Para ello, siga estos pasos.

Nota:

No es necesario realizar una copia de seguridad del mensaje de OOF cuando siga estos pasos.

  1. En la ventana principal de MFCMapi, seleccione Sesión y, a continuación, seleccione Inicio de sesión y Mostrar tabla de almacén para abrir el buzón.

  2. Expanda el contenedor raíz y la parte superior del almacén de información.

  3. Elimine las reglas de OOF. Para ello, siga estos pasos:

    1. Haga clic con el botón derecho en Bandeja de entrada y, a continuación, seleccione Mostrar tabla de reglas.

      • Si la característica OOF está deshabilitada, se muestra una regla OOF en la tabla de reglas junto con el siguiente nombre de regla:
        MSFT: reglas de OOF de TDX

      • Si la característica OOF está habilitada, se enumeran dos reglas OOF diferentes en la tabla de reglas. Las reglas que se enumeran dependen de si la regla solo está habilitada internamente o tanto interna como externamente. Por ejemplo, considere la siguiente captura de pantalla:

        Captura de pantalla de los detalles del cuadro de diálogo Tabla de reglas.

      • Si las plantillas de OOF están dañadas o tienen un formato incorrecto, esas plantillas de OOF se enumeran en la tabla de reglas. Puede ver otras entradas si el usuario tiene otras reglas habilitadas.

    2. Haga clic con el botón derecho en las reglas de OOF y, a continuación, seleccione Eliminar.

      Nota:

      No elimine ninguna regla OOF excepto aquellas a las que se haga referencia.

    3. Cierre la ventana Tabla de reglas.

  4. Elimine las plantillas de OOF. Para ello, siga estos pasos:

    • Haga clic con el botón derecho en Bandeja de entrada y, a continuación, seleccione Abrir tabla de contenido asociada.
    • Desplácese hasta el lado derecho y expanda la columna Clase de mensaje .
    • Para ordenar los elementos, seleccione la columna Clase de mensaje .
    • Busque los elementos cuya clase message es cualquiera de los valores siguientes:
      • IPM. Note.Rules.ExternalOofTemplate.Microsoft
      • IPM. Note.Rules.OofTemplate.Microsoft

Por ejemplo, considere la siguiente captura de pantalla:

Captura de pantalla de las reglas de OOF que se pueden eliminar.

  • Haga clic con el botón derecho en los elementos que pertenecen a una de esas dos clases de mensaje y, a continuación, seleccione Eliminar mensaje.

    Nota:

    No elimine ningún elemento excepto a los a los que se hace referencia.

    Captura de pantalla de las reglas de OOF que se pueden eliminar.

  • En el cuadro de diálogo Eliminar elemento , seleccione Eliminación permanente pasando DELETE_HARD_DELETE (irrecuperable) en Estilo de eliminación y, a continuación, seleccione Aceptar.

    Seleccione la opción Eliminación permanente que pasa DELETE_HARD_DELETE (irrecuperable) en Estilo de eliminación.

  • Deshabilite y vuelva a habilitar la característica OOF mediante los siguientes comandos:

    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Disabled
    Set-MailboxAutoReplyConfiguration \<identity> -AutoReplyState Enabled

  • Compruebe si la característica OOF funciona según lo esperado y los síntomas ya no se producen.

Resolución 3

Si ya no se devuelve una respuesta de OOF, es probable que se supere la cuota de reglas. Por lo tanto, no se pueden crear las reglas OOF internas y externas. Para resolver este problema, siga estos pasos:

  1. Aumente la cuota de reglas. Para ello, siga los pasos descritos en el artículo siguiente:

    Un usuario no puede crear nuevas reglas en Outlook ni Outlook Web App

  2. Debido al almacenamiento en caché de la información de cuota en el Almacén de información, los valores de cuota actualizados pueden requerir hasta dos horas para surtir efecto.

  3. Repita la resolución 2.

Resolución 4

Si el valor AllowedOFFType del dominio remoto es None, los mensajes OOF no se activan externamente. Este valor debe establecerse en Externo para permitir OOF externos. De forma predeterminada, este valor se establece en Ninguno. Recuerde que, al buscar en dominios remotos, el valor predeterminado se reemplaza por entradas específicas. Por lo tanto, si el usuario envía a un @contoso.com usuario y hay una Contoso.com entrada en la configuración de dominio remoto, se usa el valor AllowedOOFType para esa entrada específica. Si no hay ninguna entrada para Contoso.com, se usa el dominio remoto predeterminado (*).

Get-RemoteDomain | select Name,AllowedOOFType