La característica Fuera de la oficina de Outlook no funciona correctamente en Office 36

Síntomas

Cuando intenta usar la característica Fuera de la oficina (OOF) en Outlook en Microsoft Office 365, experimenta los siguientes síntomas:

  • El mensaje de OOF no se puede guardar.

  • Se envía un mensaje de OOF antiguo o duplicado.

  • No se envía un mensaje de OOF aunque habilite el mensaje OOF.

Causa

Este problema se produce por uno de los siguientes motivos: 

  • Causa 1:hay un trabajo pendiente de los eventos del asistente para buzones (solo Exchange 2010).

  • Causa 2:las plantillas de reglas del OOF están malformadas o dañadas.

  • Causa 3:se ha superado la cuota de reglas del OOF y no se pueden crear nuevas reglas.

  • Causa 4:la configuración de Dominio remoto para el dominio predeterminado (o específico) no está configurada para permitir mensajes OOF.

Resolución

                Nota Cualquiera de las cuatro causas puede provocar un error en la respuesta de la OOF. Por lo tanto, cada causa debe descartarse de una en una.

AdvertenciaEl uso del Microsoft Exchange Server MAPI Editor (MFCMapi) puede dañar el Microsoft Exchange Server y los buzones del servidor Exchange. Descargue MFCMAPI desde github (desplácese hacia abajo y, a continuación, haga clic en Última versión).

Para resolver este problema, siga los pasos para la causa específica. 

Solución 1

  1. Configure la característica OOF. Para ello, ejecute cualquiera de los siguientes cmdlets Windows PowerShell, según corresponda:

    Set-MailboxAutoReplyConfiguration <identidad> -AutoReplyState Disabled

    Set-MailboxAutoReplyConfiguration <identidad> -AutoReplyState Enabled

  2. Use MFCMapi para comprobar el PR_OOF_STATE datos. Para ello, siga estos pasos:

    a.       En la ventana principal de MFCMapi, haga clic en Sesióny, a continuación, haga clic en Inicio de sesión y Mostrar tabla del almacén para abrir el buzón.

    b.      Haga clic en el perfil al que está accediendo y, a continuación, desplácese hacia abajo en el panel inferior hasta que vea el PR_OOF_STATE valor. Este valor debería ser True si habilitó la característica OOF en Windows PowerShell o False si deshabilitó la característica OOF. Por ejemplo, si deshabilitó la característica OOF, considere la siguiente captura de pantalla:

    texto alternativo

  3. Si el PR_OOF_STATE no es el resultado esperado, póngase en contacto con el soporte técnico de Microsoft para que compruebe si hay eventos en cola (solo Exchange 2010).

Solución 2

Nota: Los síntomas en su caso pueden diferir ligeramente de estos. Por ejemplo, el mensaje OOF no se puede enviar como se espera, aunque el mensaje de OOF se puede establecer sin error. Sin embargo, estos pasos seguirán a aplicarse.

Para resolver este problema, elimine las reglas del OOF y las plantillas de reglas de OOF del buzón. A continuación, vuelva a habilitar la característica OOF y pruebe el comportamiento. Para ello, siga estos pasos. 

Nota: No es necesario que haga una copia de seguridad del mensaje OOF cuando siga estos pasos.

  1. En la ventana principal de MFCMapi, haga clic en Sesióny, a continuación, haga clic en Inicio de sesión y Mostrar tabla del almacén para abrir el buzón.

  2. Expanda el contenedor raíz y la parte superior del almacén de información.

  3. Elimine las reglas del OOF. Para ello, siga estos pasos:
     

    1. Haga clic con el botón secundario en la Bandejade entrada y, a continuación, haga clic en Mostrar tabla reglas.
       

      • Si la característica OOF está deshabilitada, se muestra una regla OOF en la tabla de reglas junto con el siguiente nombre de regla: MSFT: Reglas del OOF TDX

      • Si la característica OOF está habilitada, se muestran dos reglas OOF diferentes en la tabla reglas. Las reglas que se muestran dependen de si la regla solo está habilitada internamente o tanto interna como externamente. Por ejemplo, considere la siguiente captura de pantalla:

        texto alternativo

      • Si las plantillas de OOF están dañadas o con formato malformado, esas plantillas de OOF se muestran en la tabla reglas. Puede ver otras entradas si el usuario tiene otras reglas habilitadas.

    2. Haga clic con el botón secundario en las reglas del OOF y, a continuación, haga clic en Eliminar.                 Nota No elimine ninguna regla del OOF excepto aquellas a las que se hace referencia.

    3. Cierre la ventana Tabla de reglas.

  4. Elimine las plantillas de OOF. Para ello, siga estos pasos:

    • Haga clic con el botón secundario en la Bandejade entrada y, a continuación, haga clic en Abrir tabla de contenido asociada.

    • Desplácese hacia la derecha y expanda la columna Clase de mensaje.

    • Para ordenar los elementos, haga clic en la columna Clase de mensaje.

    • Busque los elementos cuya clase de mensaje es uno de los siguientes valores:

      • IPM. Note.Rules.ExternalOofTemplate.Microsoft

      • IPM. Note.Rules.OofTemplate.Microsoft

Por ejemplo, considere la siguiente captura de pantalla:

  1. texto alternativo



    • Haga clic con el botón secundario en los elementos que pertenecen a una de esas dos clases de mensajes y, a continuación, haga clic en Eliminar mensaje. 

      Nota No elimine ningún elemento excepto aquellos a los que se hace referencia.

      texto alternativo

    • En el cuadro de diálogo Eliminar elemento, seleccione Eliminar permanentemente el paso DELETE_HARD_DELETE (no recuperable) en Estilo de eliminación y, a continuación, haga clic en Aceptar.
      texto alternativo

    • Deshabilite y vuelva a habilitar la característica OOF con los comandos siguientes:

      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Disabled
      Set-MailboxAutoReplyConfiguration <identity> -AutoReplyState Enabled

    • Compruebe si la característica OOF funciona según lo esperado y los síntomas ya no se producen.

Solución 3

Si ya no se devuelve una respuesta de OOF, es probable que se supere la cuota de reglas. Por lo tanto, no se pueden crear reglas de OOF internas y externas. Para resolver este problema, siga estos pasos:

  1. Aumente la cuota de reglas. Para ello, siga los pasos que se indican en el siguiente artículo de Microsoft Knowledge Base:

    1. 2622933 Un usuario no puede crear nuevas reglas en Outlook o Outlook Web App

  2. Debido al almacenamiento en caché de información de cuota en el Almacén de información, los valores de cuota actualizados pueden tardar hasta dos horas en tener efecto.

  3. Resolución de repetición 2.

Resolución 4

Si el valor AllowedOFFType del dominio remoto es Ninguno,los mensajes de OOF no se envían de forma externa. Este valor debe establecerse en Externo para permitir archivos OO externos. De forma predeterminada, este valor está establecido en Ninguno. Recuerde que al buscar en dominios remotos, el valor predeterminado se reemplaza por entradas específicas. Por lo tanto, si el usuario se envía a un usuario @contoso.com y hay una entrada Contoso.com en la configuración de dominio remoto, se usa el valor AllowedOOFType para esa entrada específica. Si no hay ninguna entrada para Contoso.com, se usa el dominio remoto predeterminado (*)


Get-RemoteDomain | seleccione Nombre,AllowedOOFType

Más información

Si el PR_OOF_STATE de datos no es el resultado esperado, consulte el siguiente artículo de Microsoft Knowledge Base:

2705649 Exchange: El mensaje OOF y el procesamiento RBA no funcionan como se espera en Exchange 2010

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