Síntomas
Usuarios conectan a clientes de Citrix ICA a un servidor de terminal basado en Windows Server 2008 que tiene instalado Citrix Presentation Server. Sin embargo, los clientes ICA pueden bloquearse durante el proceso de conexión.
Causa
Aumenta el tamaño de la clave pública que se utiliza para cifrar las licencias de acceso de cliente de Terminal Services (TS CAL) desde 512 bytes a 2.048 bytes. Terminal server no negocia con los clientes cuando se utiliza el nuevo tamaño de clave. Por lo tanto, se puede producir un error en el canal Virtual de Citrix para versiones anteriores de clientes ICA.
Solución
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
No hay requisitos previos.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Este hotfix no sustituye a otras revisiones.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Windows Server 2008, versiones de 32 bits
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Mstlsapi.dll |
6.0.6001.22162 |
84,992 |
18-Apr-2008 |
05:30 |
x86 |
Windows Server 2008, versiones basadas en Itanium
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Mstlsapi.dll |
6.0.6001.22162 |
232,960 |
18-Apr-2008 |
09:29 |
IA-64 |
Windows Server 2008, versiones de 64 bits
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Mstlsapi.dll |
6.0.6001.22162 |
139,264 |
18-Apr-2008 |
06:41 |
x64 |
Solución alternativa
Para evitar este problema, actualice los clientes de Citrix ICA a una versión que sea compatible con Windows Server 2008.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de MicrosoftLos productos de terceros que se indican en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.