Los usuarios de Exchange Online que utilizan Outlook para iOS y Android y acceso de dispositivo (ABQ) reglas inesperadamente se ponen en cuarentena

PROBLEMA

Exchange Online usuarios que utilizan Outlook para iOS y Android y que también utilizan las reglas de acceso de dispositivo (ABQ) encuentran que ha sido inesperadamente en cuarentena. Este problema se produce en la situación siguiente:

  • Propiedad del inquilino de l del DefaultAccessLeveque se configura mediante el Conjunto ActiveSyncOrganizationSettings se establece en un valor de cuarentena o bloque.

  • El Administrador de inquilinos había permitido previamente Outlook para iOS y Android estampando DeviceID en la propiedad ActiveSyncAllowedDeviceIDs del buzón.

  • Los dispositivos no están administrados por Microsoft Intune.

CAUSA

Un protocolo de servicios de fondo de cómo se tiene acceso a los datos del buzón Office 365 a través de Outlook para iOS y Android aplicaciones cambio DeviceID que la aplicación utiliza para conectarse a Exchange Online. Lae cantidad comportamiento es que el nuevo DeviceID se agregará automáticamente a la ActiveSyncAllowedDeviceID para el usuario. Pero en ciertas situaciones, se puede poner en cuarentena el dispositivo. En tal caso, siga los pasos descritos en la sección "Solución". Este problema no se espera que se produzcan repetidamente.

SOLUCIÓN

Póngase en contacto con el soporte técnico y pregunte al cliente representante de servicio para ayudar a desbloquear el dispositivo.

O bien, utilice uno de los métodos siguientes para desbloquear el dispositivo:

  • Utilice el centro de administración de Exchange para desbloquear los dispositivos individuales. Para ello, siga estos pasos:

    1. Iniciar sesión en el centro de administración de Exchange. Para obtener más información, consulte el Centro de administración de Exchange en Exchange Online.

    2. Haga clic en dispositivos móvilesy en Dispositivos en cuarentena, seleccione el botón Permitir para cada Outlook para iOS y dispositivos Android app que necesita ser desbloqueado.

  • Usar PowerShell remoto para desbloquear todos los dispositivos. Para ello, siga estos pasos:

    1. Conectarse a Exchange Online mediante PowerShell remoto. Para obtener más información, vea conectarse a Exchange Online PowerShell.

    2. Copie y pegue el código siguiente a la sesión remota de PowerShell:

      function FixUnblock
      {
      $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } 
      foreach($Mbx in $Mbxs)
      {
      write-host $Mbx.Id
      $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" 
      -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} 
      $CasDevice = Get-CasMailbox $Mbx.Id
      foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId }
      Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs
      }
      } 
    3. En la sesión remota de PowerShell, ejecute la función. Para ello, escriba FixUnblocky, a continuación, presione ENTRAR.

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