Síntomas
Tienes uno o varios de los siguientes síntomas:
-
Los usuarios no pueden recibir mensajes de correo electrónico ni conectarse a su buzón.
-
Microsoft Exchange Server deja de responder y parece estar inmovilizado.
-
El proceso noderunner consume demasiada memoria.
Causa
El proceso noderunner en Exchange Server puede consumir una cantidad excesiva de memoria al intentar indexar algunos elementos. Este comportamiento provoca varios problemas de rendimiento en el servidor.
Solución
Para corregir el problema, limite la cantidad de memoria que puede consumir el proceso noderunner. Siga estos pasos en cada servidor de Exchange:
-
Busque el archivo Noderunner.exe.config en la carpeta %ExchangeInstallPath%Bin\Search\Ceres\Runtime\1.0 .
-
Abra el archivo deNoderunner.exe.config y, a continuación, busque el nodo<nodo XML MemoryRunnerSettingsLimitMegabytes="0"/> .
-
Establezca el parámetro memoryLimitMegabytes en un valor que sea el 25 por ciento de la memoria del servidor instalada. Escriba el valor en megabytes. Si el problema persiste después de completar estos pasos, reduzca el valor memoryLimitMegabytes en un cinco por ciento y, a continuación, vuelva a probar.
Nota: Para un servidor que tiene instalado Exchange Server 2019 y 128 GB de memoria, establezca el parámetro memoryLimitMegabytes en un valor comprendido entre 10000 y 32000 (10-32 GB). El rendimiento de la búsqueda se verá afectado si establece el valor MemoryLimitMegabytes demasiado bajo.
-
Ejecute el siguiente comando de PowerShell para reiniciar el servicio controlador de host de búsqueda de Microsoft Exchange:Restart-Service HostControllerService
-
Ejecute el siguiente comando en una ventana de PowerShell o del símbolo del sistema para reiniciar IIS:IISReset /restart