Síntoma

Se crean colecciones que tienen habilitadas actualizaciones incrementales y el token de programación se crea mediante PowerShell cmdlet New-CMSchedule junto con los parámetros -DurationInterval y -DurationCount .

Por ejemplo, se utilizan los siguientes comandos de PowerShell para crear la colección:

$Schedule = New-CMSchedule -DayOfMonth 1 -DurationInterval Days -DurationCount 31
New-CMDeviceCollection -Name "TEST-2" -LimitingCollectionName "All Systems" -RefreshSchedule $Schedule -RefreshType Continuous

La colección tiene las siguientes marcas y token de programación:

Flags = 4, Planificación= 2C996A0007D00008

Cuando actualiza a la versión 1810 del Administrador de configuración, aparece un mensaje de error similar al siguiente:

*** [22018][245][Microsoft][SQL Server Native Client 11.0][SQL Server]Error al convertir el valor nvarchar 'D' a los tipos de datos int.

Nota Este problema no se produce si establece la programación de actualización en la consola del Administrador de configuración.

Causa

Este problema se produce porque el token de programación contiene un carácter no válido (D en el ejemplo). Por lo tanto, se produce un error en la comprobación previa a la actualización.

Solución

Para resolver este problema, siga estos pasos:

  1. Identifique las colecciones que pueden causar este problema ejecutando la siguiente consulta:

    select CollectionID, CollectionName, Flags, Schedule from Collections_G
    where (Flags & 0x07 = 0x1 or Flags & 0x07 = 0x04) AND 
    Schedule <> '' AND Schedule is not NULL AND 
    substring(ISNULL(Schedule, ''), 11, 1) not like '[0-9]'

  2. Cambie el token de programación de estas colecciones. Para cada colección: En la pestaña Reglas de membresía dentro del cuadro de diálogo de la colección Propiedades, desactive Usar actualizaciones incrementales para esta colección o cambie la programación de una actualización completa de la colección.

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×