Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Cuando intenta ejecutar uno de los escenarios de actualización en la pantalla mantenimiento de la base de datos (98.290.00) de Microsoft Dynamics SL, recibe uno de los siguientes mensajes de error:mensaje 1

Se ha producido una excepción no controlada en la aplicación. Si hace clic en continuar, la aplicación pasará por alto este error e intentará continuar. Si hace clic en salir, la aplicación se cerrará inmediatamente. Error al recuperar el generador de clases COM para el componente con CLSID [A440BD76-CFE-4D46-AB1F-15F238437A3D] debido al siguiente error: 80040154.

Mensaje 2

Error en tiempo de ejecución 429 ' componente Active X no se puede crear el objeto ' al recuperar el generador de clases COM para un componente con CLSID {10020200-E260-11CF-AE68-00AA004A34d}

Causa

uno. Este problema se produce porque el archivo SQLDMO. dll no está registrado en el equipo local.1. Este problema se produce porque el archivo CAPICOM. dll no está registrado en el equipo local.

Resolución

Use una o más de las siguientes soluciones, según corresponda a su situación.Solución 1 Registre manualmente el archivo SQLDMO. dll. Para ello, siga estos pasos:

  1. Busque el archivo SQLDMO. dll en el equipo local. De forma predeterminada, este archivo se encuentra en la carpeta C:\Archivos de Programa\microsoft SQL Server\MSSQL\80\Tools\Binn.

  2. Haga clic con el botón secundario en el archivo SQLDMO. dll y, después, haga clic en abrir con.

  3. En el cuadro de diálogo de Windows , haga clic en seleccionar el programa de una listay, a continuación, haga clic en Aceptar.

  4. En el cuadro de diálogo abrir con , haga clic en examinar.

  5. Busque y abra la siguiente carpeta: SystemDrive : \windows\system32.

  6. Haga doble clic en el archivo regsvr32. exe y, a continuación, haga clic en Aceptar.

  7. Cuando reciba el siguiente mensaje, haga clic en Aceptar :

    RegSvr32-DllRegisterServer en SQLDMO. dll tuvo éxito.

Nota Si no puede registrar el archivo SQLDMO. dll o no hay ningún archivo SQLDMO. dll en el directorio Binn, vaya a "solución 3". Solución 2

  1. Busque el archivo CAPICOM. dll en el equipo local. De forma predeterminada, este archivo se encuentra en la unidadDelSistema : \windows\system32.

  2. Haga clic con el botón secundario en el archivo CAPICOM. dll y, después, haga clic en abrir con.

  3. En el cuadro de diálogo de Windows , haga clic en seleccionar el programa de una listay, a continuación, haga clic en Aceptar.

  4. En el cuadro de diálogo abrir con , haga clic en examinar.

  5. Busque y abra la siguiente carpeta: SystemDrive : \windows\system32.

  6. Haga doble clic en el archivo regsvr32. exe y, a continuación, haga clic en Aceptar.

  7. Cuando reciba el siguiente mensaje, haga clic en Aceptar :

    RegSvr32-DllRegisterServer en CAPICOM. dll tuvo éxito.

Nota Si no puede registrar el archivo SQLDMO. dll o no hay ningún archivo SQLDMO. dll en el directorio, vaya a "solución 4". Solución 3 Si no puede registrar el archivo SQLDMO. dll o no hay ningún archivo SQLDMO. dll en el directorio Binn, esto puede indicar que el directorio Binn está incompleto. Si este es el caso, copie el directorio Binn de una estación de trabajo en funcionamiento y reemplace el directorio Binn de la estación de trabajo que recibe el error. A continuación, ejecute la solución 1. Si no hay ninguna otra estación de trabajo disponible desde la que pueda copiar el directorio Binn, póngase en contacto con el soporte técnico de Microsoft Dynamics SL para obtener ayuda con la recompilación del directorio Binn.Solución 4 Si no puede registrar el archivo CAPICOM. dll o el archivo no está, vaya al servidor o a otro equipo de trabajo que copie el archivo CAPICOM. dll de ese origen y péguelo en la estación de trabajo se produjo el error. A continuación, ejecute la solución 2. Si no hay otras estaciones de trabajo disponibles desde las que pueda copiar CAPICOM. dll, póngase en contacto con el soporte técnico de Microsoft Dynamics SL para obtener ayuda con la recuperación de su archivo CAPICOM. dll.Nota: Se aplican directivas de carga normal si se inicia un caso de soporte técnico.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×