Se produce el error "Problema al agregar a Outlook" al implementar Microsoft Dynamics 365 App para Outlook

En este artículo se proporciona una resolución del problema de error al agregar a Outlook que puede producirse al implementar Microsoft Dynamics 365 App para Outlook.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4528578

Síntomas

Al implementar la aplicación para Outlook desde Microsoft Dynamics CE, verá un error en rojo delante del problema de buzón de los usuarios al agregar a Outlook. Si selecciona ver más detalles, verá el mensaje Operación de origen de datos no válida.

Si va a Administrar complementos desde el buzón de un usuario, verá el siguiente error:

No se pudo encontrar el objeto de directorio virtual de acceso de cliente con InternalURl marcado para ECP, servicio.

Nota:

Para que un complemento de Office se implemente en el buzón de un usuario en Microsoft Exchange Server, AppsForOfficeEnabled debe ser true. Puede usar el siguiente comando para comprobar los valores de configuración a través del Shell de administración de Exchange (EMS).
Get-OrganizationConfig | Format-List AppsForOfficeEnabled

Causa

Esto se debe a la búsqueda de detección desde el Centro de Administración de Exchange (EAC). Siempre que se realice la búsqueda de detección por primera vez mediante EAC en Exchange Server 2013, comprobará las siguientes 6 direcciones URL internas en segundo plano y la almacenará en caché localmente.

  • Dirección URL encontrada: https://e15-cas.contoso.com/owa
  • Dirección URL encontrada: https://e15-cas.contoso.com/ecp
  • Dirección URL encontrada: https://e15-cas.contoso.com/EWS/Exchange.asmx
  • Dirección URL encontrada: https://e15-cas.contoso.com/Microsoft-Server-ActiveSync
  • Dirección URL encontrada: https://e15-cas.contoso.com/OAB
  • Dirección URL encontrada: https://e15-cas.contoso.com/mapi

[GlobalServiceUrls.DiscoverUrlsIfNeeded] Encontró correctamente todos los VDir necesarios

Solución

Asegúrese de que todos los directorios virtuales necesarios están presentes y que las direcciones URL internas se publican en esos directorios virtuales.

Para obtener más información sobre cómo configurar directorios virtuales de Exchange, vea Configurar el flujo de correo y el acceso de cliente en servidores Exchange Paso 4: Configurar direcciones URL externas.