Síntoma

En Power Automate Desktop, los usuarios no pueden:

  1. Inicie sesión Power Automate Desktop con el mensaje de error "Error durante el inicio de sesión: error al iniciar sesión".

  2. Cree nuevos flujos de escritorio con el mensaje de error "No se le permite crear flujos en este entorno. Cambie al entorno predeterminado o a uno de sus propios entornos, donde tenga permisos de creador".

  3. Edite flujos de escritorio con el mensaje de error "Flow error de inicialización".

  4. Guardar flujos de escritorio con el mensaje de error "Error durante el ahorro de flujo: Flow no se pudo guardar".

  5. Ver los flujos de escritorio en la lista "Mis flujos" de la consola.

Comprobar el problema

Intente realizar la misma operación en el portal Power Automate en flow.microsoft.com cuando corresponda. Si funciona según lo esperado, el problema debe estar relacionado con la configuración de red local del equipo que hospeda Power Automate Desktop. 

Causa

El equipo que hospeda Power Automate Desktop puede conectarse a los dominios necesarios. Esto puede ocurrir porque los dominios están bloqueados en la red o porque está usando un servidor proxy que requiere autenticación.

Para este último, PAD no se puede autenticar con el servidor proxy, por lo que se produce un error en la comunicación. Tenga en cuenta que el servidor proxy debe usar la autenticación automática con la cuenta de Active Directory del usuario.

Solución

Causa #1: dominios bloqueados

Enlista los siguientes servicios a los que Power Automate se conecta. Asegúrese de que ninguno de estos servicios está bloqueado en su red:

Servicios necesarios

Se ejecuta la lista blanca de los siguientes servicios para habilitar la conexión desde el equipo local para los flujos de escritorio:

Servicios de flujos de escritorio necesarios para tiempo de ejecución

Causa #2: autenticación de proxy

Salga Power Automate Desktop del icono de la bandeja del sistema (haga clic con el botón derecho en el icono PAD de la bandeja del sistema y salga). 

Necesita derechos de administrador para realizar los siguientes cambios:

Vaya a Power Automate Desktop carpeta de instalación ('C:\Archivos de programa (x86)\Power Automate Desktop').

Haga una copia de seguridad de estos dos (2) archivos "PAD.Designer.exe.config" y "PAD.Console.Host.exe.config" para recuperarlos si se produce algún problema. 

Para ambos archivos, haga lo siguiente: 

Edite cada archivo con derechos de administrador y, al final del nodo xml raíz (<configuración>), agregue el siguiente nodo xml secundario: 

     <system.net>

          <defaultProxy enabled="true" useDefaultCredentials="true"> 

          </defaultProxy> 

     </system.net>

Guarde el archivo.

Inicie Power Automate escritorio.  

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×