Error "Tiempo de espera de conexión" en Microsoft Business Portal al abrir la página del Centro de proyectos

En este artículo se proporciona una solución para el problema que puede ver un error de tiempo de espera de conexión en el elemento web de Project Communicator de la página del Centro de proyectos.

Se aplica a: Microsoft Dynamics SL
Número de KB original: 897024

Síntomas

En Microsoft Business Solutions - Business Portal, al seleccionar Proyecto para abrir la página del Centro de proyectos, recibirá el siguiente mensaje de error en el elemento web de Project Communicator:

Error:

Conector:Tiempo de espera de conexión.
HRESULT=0x800A1527- Client:Se produjo un error imprevisto durante el procesamiento de esta solicitud.
HRESULT=0x800A1527: cliente: error al enviar el mensaje Soap o no se recibió ninguna respuesta reconocible
HRESULT=0x800A1527: error de cliente:No especificado.
HRESULT=0x800A1527

faultcode=Client

faultstring=Connector:Tiempo de espera de conexión.

faultactor=

detail=Connector:Tiempo de espera de conexión.
HRESULT=0x800A1527- Client:Se produjo un error imprevisto durante el procesamiento de esta solicitud.
HRESULT=0x800A1527: cliente: error al enviar el mensaje Soap o no se recibió ninguna respuesta reconocible
HRESULT=0x800A1527: error de cliente:No especificado.
HRESULT=0x800A1527

Causa

Este problema se produce porque el puerto del Protocolo de control de transmisión (TCP) que especificó para el sitio web de nivel superior en el Administrador de Microsoft Internet Information Services (IIS) contiene un valor que es diferente del valor especificado en el archivo ProjectService.wsdl.

Solución

Para resolver este problema, siga estos pasos:

  1. En el Administrador de Internet Information Services (IIS), busque el sitio web de nivel superior donde instaló Microsoft Business Portal. Para ello, siga estos pasos:

    1. Seleccione Inicio, herramientas administrativas y, a continuación, seleccione Administrador de Internet Information Services (IIS).

    2. En el cuadro de diálogo Administrador de Internet Information Services (IIS), expanda Server_name.

      Nota:

      En este artículo, Server_name representa el nombre del servidor donde instaló Microsoft Business Portal.

    3. Expanda Sitios web.

  2. Haga clic con el botón derecho en el sitio web de nivel superior y, a continuación, seleccione Propiedades.

  3. Seleccione la pestaña Sitio web , anote el valor en el cuadro Puerto TCP y, a continuación, seleccione Cancelar.

  4. Abra el archivo ProjectService.wsdl en el Bloc de notas.

    Nota:

    La ubicación predeterminada del archivo ProjectService.wsdl es Microsoft Business Solutions\Business Portal\Applications\PMA.

  5. Busque la siguiente línea cerca del final del archivo:

    <soap:address location="HTTP://Server_name:80/BusinessPortal/Applications/PMA/PCService.asmx" />

    Nota:

    En esta línea, Server_name representa el nombre del servidor donde instaló Microsoft Business Portal.

  6. Reemplace el número de puerto por el valor que anotó en el paso 3. La línea del paso 5 muestra el puerto 80.

  7. En el menú Archivo, seleccione Guardar.

Importante

El problema que se describe en la sección Síntomas no se aplica a Microsoft Dynamics SL 7.0.