Error interno de Microsoft Dynamics 365 al sincronizar citas, contactos y tareas

En este artículo se proporciona una solución a un error que se produce después de seleccionar Probar & Habilitar buzón en un registro de buzón en Dynamics 365.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4346733

Síntomas

Después de seleccionar Probar & Habilitar buzón en un registro de buzón en Dynamics 365, el resultado de la prueba Citas, contactos y tareas se muestra como Error y el siguiente mensaje aparece en la sección Alertas:

"Se produjo un error interno de Microsoft Dynamics 365 al sincronizar citas, contactos y tareas para el buzón [Nombre del buzón]. El buzón no se sincronice. Se ha notificado al propietario del perfil de servidor de correo electrónico asociado [Email nombre del perfil de servidor].
Email código de error del servidor: UserPrivilegeError"

Causa

Si ve este mensaje de error y el código de error del servidor Email se muestra como UserPrivilegeError, lo que indica que el usuario propietario de este buzón no tiene privilegios suficientes. Consulte Error de privilegios denegados al usar la sincronización de Server-Side para obtener una lista de los privilegios necesarios.

Importante

Compruebe que el propietario del registro de buzón es el mismo que el usuario. Ejemplo: si el buzón es un buzón de usuario para Paul Cannon, compruebe el valor Propietario dentro del registro de buzón para que Paul Cannon se muestre como Paul Cannon. Si es otro usuario, es posible que ese usuario no tenga acceso al buzón de este usuario.

Solución

Para resolver este problema, siga estos pasos:

  1. Como usuario con el rol Administrador del sistema, abra el registro de buzón en Dynamics 365.

    Nota:

    La alerta incluye un vínculo al registro de buzón de correo.

  2. Compruebe que el campo Propietario del formulario de buzón se rellena con el nombre del usuario. Si aparece algún otro usuario, cámbielo para que sea el mismo que este usuario.
  3. Seleccione el vínculo dentro del campo Propietario para abrir el registro de usuario del usuario propietario.
  4. Seleccione Administrar roles para ver qué roles de seguridad se asignan a este usuario.
  5. Vaya a Configuración, seleccione Seguridad y, a continuación, seleccione Roles de seguridad.
  6. Abra los roles que se encuentran en el paso 4. Consulte Error de privilegio denegado al usar la sincronización de Server-Side para obtener una lista de los privilegios necesarios y comprobar que el rol de seguridad del usuario contiene estos privilegios.
  7. Después de comprobar que el usuario es el propietario de su registro de buzón de correo y su rol de seguridad contiene los privilegios necesarios, vuelva a seleccionar el botón Probar & Habilitar buzón dentro de su registro de buzón. Si la prueba no resulta correcta, revise el mensaje que aparece en la sección Alertas.