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Síntomas

Imagine el siguiente escenario:

  • Utilizar una aplicación para abrir archivos ejecutables a través de la red desde un equipo cliente que ejecuta Windows 7 o Windows Server 2008 R2.

  • Esta aplicación también abre archivos más que permiten el bloqueo oportunista (bloqueo) a través de la red.

  • Otro proceso intenta acceder a un archivo compartido que la aplicación ya abierta a través de la red.

  • El servidor solicita que el equipo cliente interrumpir la operación de bloqueo.

En este escenario, equipo cliente no interrumpe el bloqueo operativo. Por lo tanto, el archivo compartido permanece abierto en el servidor y otros clientes no pueden utilizar ese archivo.

Causa

Este problema se produce porque el Administrador de memoria en el equipo cliente contiene objetos ejecutables y no cierra. Sin embargo, el servidor considera los objetos ejecutables a cerrar y vuelve a utilizar el identificador de archivo para el nuevo archivo de otro. Esto provoca una colisión de identificador de archivo. Por lo tanto, cuando se emite la solicitud de bloqueo operativo salto, el equipo cliente procesa el objeto ejecutable anterior en lugar del archivo nuevo.

Solución

Información de la revisión

La revisión para este problema se incluye en la actualización 2732673. Para resolver el problema, instale actualización 2732673 desde el siguiente artículo de Microsoft Knowledge Base:

2732673 mensaje de error "Error de escritura demorada" cuando los archivos .pst se almacenan en un servidor de archivos de red que está ejecutando Windows Server 2008 R2

Requisitos previos

Para aplicar esta revisión, debe ejecutar el Service Pack 1 (SP1) de Windows 7 o Windows Server 2008 R2 SP1.

Para obtener más información acerca de cómo obtener un service pack de Windows 7 o Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

976932 información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Para aplicar esta revisión, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

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