Error "No se puede enviar correo electrónico como el usuario seleccionado" al enviar un correo electrónico como otro usuario

Este artículo le ayuda a corregir un problema en el que recibe el error "No se puede enviar correo electrónico como el usuario seleccionado" al enviar un correo electrónico como otro usuario en Microsoft Dynamics CRM.

Se aplica a: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2011
Número de KB original: 3184980

Síntomas

Al intentar enviar un correo electrónico estableciendo el campo De a otro usuario en Microsoft Dynamics CRM, recibirá el siguiente mensaje de error:

"No se puede enviar correo electrónico como el usuario seleccionado. El usuario seleccionado no ha permitido esto o no tiene privilegios suficientes para hacerlo. Póngase en contacto con el administrador del sistema para obtener ayuda."

Causa

Este problema se produce si existe una de las condiciones siguientes:

  • Al rol de seguridad de Microsoft Dynamics CRM le falta el privilegio Enviar Email como Otro usuario.

    Nota:

    Si usa una regla de flujo de trabajo para enviar el correo electrónico, el propietario de la regla flujo de trabajo necesita este privilegio.

  • El usuario que intenta enviar como no ha habilitado la opción que permite a otros usuarios enviar un correo electrónico como ellos.

Solución

Para solucionar este problema, realice los pasos siguientes para comprobar que el rol de seguridad incluye el privilegio Enviar Email como otro usuario.

  1. Inicie sesión en Microsoft Dynamics CRM con un usuario que tenga el rol Administrador del sistema.

  2. Vaya a Configuración y, a continuación, seleccioneRoles de seguridad>.

  3. Abra el rol de seguridad asignado al usuario que recibe el mensaje de error.

  4. Seleccione la pestaña Administración de negocios .

  5. Compruebe que el usuario tiene el privilegio Enviar Email como Otro usuario.

    Nota:

    El privilegio Enviar Email como otro usuario tiene distintos niveles de profundidad. Un usuario necesita una profundidad suficiente en este privilegio para coincidir con el usuario al que intenta enviar como. Por ejemplo, si está intentando enviar como un usuario que se encuentra en una unidad de negocio diferente dentro de Dynamics CRM, tener acceso a nivel de unidad de negocio para este privilegio no sería suficiente, ya que solo le permitiría enviar como otros usuarios en la misma unidad de negocio.

  6. Seleccione Guardar.

También debe realizar los pasos siguientes para comprobar que el usuario que está intentando enviar como ha habilitado la opción que permite a otros usuarios enviar correos electrónicos como ellos.

  1. Inicie sesión en Microsoft Dynamics CRM como el usuario al que intenta enviar un correo electrónico.
  2. Seleccione el icono de engranaje en la esquina superior derecha y, a continuación, seleccione Opciones.
  3. Seleccione la pestaña Email.
  4. Compruebe que está seleccionada la opción Permitir que otros usuarios Microsoft Dynamics CRM envíen correo electrónico en su nombre.
  5. Seleccione Aceptar.

Más información

Al seleccionar el botón Descargar registro , la sección Mensaje muestra la siguiente información:

<El usuario del mensaje>no tiene privilegios de envío como.</Mensaje>