Síntomas

Al configurar el Microsoft Dynamics CRM 2011 o 2013 de CRM para el cliente de Outlook a una instancia de Microsoft Dynamics CRM Online, se produce un error de "Referencia a objeto no establecida como instancia de un objeto" después de escribir las credenciales, elegir su organización y haga clic en Aceptar:


Hay un problema de comunicación con el servidor de Microsoft Dynamics CRM. El servidor podría estar disponible. Inténtelo de nuevo más tarde. Si el problema persiste, póngase en contacto con el administrador del sistema.


Referencia a objeto no establecida a una instancia de un objeto.


en Microsoft.Crm.Passport.IdCrl.OnlineServicesFederationLogOnManager.GetBrowserClientAuthInfo (String redirectEndpoint, socios de la cadena, directiva de cadena, String & postData)


en Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()


en Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn (Uri del extremo, credencial credenciales, AuthUIMode uiMode, contexto IClientOrganizationContext, formulario parentWindow, Boolean retryOnError)


en Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.GetAuthProvider (Uri del extremo, credencial credenciales, AuthUIMode uiMode, Uri webEndPoint, contexto IClientOrganizationContext, formulario parentWindow)


en Microsoft.Crm.Application.Outlook.Config.ServerInfo.LoadUserId()


en Microsoft.Crm.Application.Outlook.Config.ServerInfo.Initialize (Uri discoveryUri, OrganizationDetail selectedOrg, displayName String, Boolean isPrimary)


en Microsoft.Crm.Application.Outlook.Config.ServerForm.LoadDataToServerInfo()


en b__2 Microsoft.Crm.Application.Outlook.Config.ServerForm. < InitializeBackgroundWorkers > (Object sender, DoWorkEventArgs e)


en System.ComponentModel.BackgroundWorker.OnDoWork (DoWorkEventArgs e)


en System.ComponentModel.BackgroundWorker.WorkerThreadStart (argumento de objeto)

Causa

Este problema se produce si está utilizando una versión del Ayudante de inicio de sesión de Microsoft Online Services no es compatible con Microsoft Dynamics CRM 2011 o 2013 de Microsoft Dynamics CRM. Al configurar Microsoft Dynamics CRM para el cliente de Outlook y se conecta a una instancia de Microsoft Dynamics CRM Online, las únicas versiones compatibles del Ayudante de inicio de sesión de Microsoft Online Services son 7.250.4259.0, 7.250.4287.0y 7.250.4303.0.

Solución

Para resolver este problema, realice los pasos siguientes:

1. Haga clic en Inicio, escriba appwiz.cply, a continuación, presione ENTRAR para abrir el elemento programas y características en el Panel de Control.

2. Desinstale al Ayudante de inicio de sesión de Microsoft Online Services si su versión no coincide con 7.250.4259.0, 7.250.4287.0o 7.250.4303.0.

3. Descargar y reinstalar la versión 7.250.4303.0 del Ayudante de inicio de sesión de Microsoft Online Services.

4. reinicie la estación de trabajo y configurar Microsoft Dynamics CRM para el cliente de Outlook comprobar que se ha resuelto el problema.

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×