Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Suponga que usa el cliente de Microsoft Dynamics CRM 2011 para Microsoft Office Outlook y que la redirección de carpetas está habilitada en el cliente. Cuando intenta realizar un seguimiento de un elemento o ejecutar la función sincronizar con CRM en esta situación, recibe un mensaje de error similar al siguiente:

[2011-09-07 11:11:08.517] Proceso: OUTLOOK | Organización: 00000000-0000-0000-0000-000000000000 | Subproceso: 24 | Categoría: excepción | Usuario: 00000000-0000-0000-0000-000000000000 | Nivel: error | CrmException.. ctorat CrmException.. ctor (mensaje de cadena, Exception innerException, Int32 errorCode, Boolean isFlowControlException) en CrmException.. ctor (mensaje de cadena, Exception innerException) en CrmSqlCeConnection. <Open>b__2 (SqlCeException ex) en ExceptionFilter. TryFilter (cuerpo de acción, predicado 1, acción ' 1 catchClause) en IdMappingTable. MarkAllItemsNotVisited () >excepción de CRM: mensaje: el archivo de base de datos SQL CE está siendo usado por otro proceso, ErrorCode:-2147220970, InnerException: se produce una infracción Es posible que un proceso diferente esté usando el archivo. [ \\<server>\C$\<user>\Microsoft\MSCRM\Client\OutlookSyncCache.sdf ].

Causa

Este problema se produce debido a una limitación en Microsoft SQL Server 2000 Windows CE Edition 3,5 (SQL Server CE 3,5). 

Resolución

NOTA: Después de aplicar el paquete acumulativo de actualizaciones 15 de Microsoft Dynamics CRM para Outlook, se actualizará automáticamente a SQL CE 4,0. Por lo tanto, la solución a continuación solo es necesaria para el paquete de continuación de actualizaciones 14 y versiones anteriores. Para ejecutar Microsoft Dynamics CRM 2011 cuando la carpeta datos de la aplicación se encuentra en un recurso compartido remoto, siga estos pasos:

  1. Instale SQL Server CE 4,0. Para ello, visite el siguiente sitio web de Microsoft:

    http://www.microsoft.com/download/en/details.aspx?id=17876Notas

    • Este paso requiere permisos elevados.

    • En SQL Server CE 4,0, los clientes de 64 bits no tienen que instalar la versión de 32 bits.

  2. Agregue el siguiente código XML en el elemento de configuración en el archivo CrmClient {14B13B7A-CA08-40bd-AC60-8C45367E807C}. config que se encuentra en la carpeta de Files\MSCRM\Client del programa:

    <runtime> <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">   <dependentAssembly>      <assemblyIdentity name="System.Data.SqlServerCe" publicKeyToken="89845dcd8080cc91" culture="neutral" />      <bindingRedirect oldVersion="3.5.1.0"      newVersion="4.0.0.0"/>   </dependentAssembly> </assemblyBinding></runtime>

    Notas

    • Este paso requiere permisos elevados.

    • Asegúrate de agregar este código antes de la etiqueta </Configuration>.

  3. Además, hay un segundo archivo de configuración que llama el Asistente para la configuración. El archivo se denomina Microsoft. CRM. Application. Outlook. ConfigWizard. exe. config y el archivo se encuentra en la carpeta C:\Archivos de Programa\microsoft Dynamics CRM\Client\ConfigWizard:

    <configuration>  <startup>    <supportedRuntime version="v4.0.30319" />  </startup>  <runtime>    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">      <probing privatePath="..\bin"/>      <dependentAssembly>        <assemblyIdentity name="System.Data.SqlServerCe"        publicKeyToken="89845dcd8080cc91"        culture="neutral" />        <bindingRedirect oldVersion="3.5.1.0"        newVersion="4.0.0.0"/>      </dependentAssembly>    </assemblyBinding>  </runtime>  <system.net>    <defaultProxy useDefaultCredentials="true" />  </system.net></configuration>
  4. Elimine todos los archivos SDF de las carpetas % LocalAppData% y % AppData% . Para obtener más información, vea la sección "lista de bases de datos en CRM".Nota Los archivos SDF creados en SQL Server CE 3,5 son incompatibles con SQL Server CE 4,0.

Advertencia

Después de actualizar de SQL Server CE 3,5 a SQL Server CE 4,0, es posible que experimente un descenso en el rendimiento la primera vez que ejecute Microsoft Dynamics CRM. Este comportamiento se produce porque Microsoft Dynamics CRM debe volver a crear todas las cachés. Algunas memorias caché se ven afectadas por el tamaño de la bandeja de entrada.

Pasos de verificación

Para comprobar que ha aplicado la resolución correctamente, siga estos pasos:

  1. Inicie Outlook después de realizar todos los pasos anteriores en la sección "resolución".

  2. Asegúrese de que el complemento Microsoft Dynamics CRM se inicia correctamente.

  3. Iniciar la herramienta Process Explorer. Para descargar Process Explorer, visite el siguiente sitio web de Microsoft:

    http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

  4. Busque el proceso Outlook. exe y, a continuación, haga doble clic en él.

  5. Seleccione la pestaña ensamblados .net y, a continuación, AppDomain: SharedDomain si aún no está expandido.

  6. Busque System. Data. SqlServerCe en la lista. Asegúrese de que la ruta de acceso contiene la siguiente versión de SQL Server CE: C:\windows\assembly\ GAC_MSIL \System.Data.SqlServerCe\4.0.Nota Si la ruta de acceso contiene SQL Server CE 3.5.1.0, el redireccionamiento de ensamblados no funcionará.

Lista de bases de datos en CRM

  • %LocalAppData%\Microsoft\MSCRM\Client

    • CrmCache. sdfNota este archivo contiene memorias caché de plataformas sin metadatos.

    • {GUID} [true | false]. sdfNota este archivo contiene el almacenamiento interno del almacén MAPI.

    Nota Es posible que haya varios archivos de este tipo para el uso sin conexión y en línea.

  • %AppData%\Microsoft\MSCRM\Client

    • EmailCache. sdfNota este archivo contiene asignaciones entre los elementos de CRM y MAPI.

    • OutlookSyncCache. sdf Nota este archivo contiene el estado interno de la sincronización.

Para poder usar el redireccionamiento de carpetas en Microsoft Dynamics CRM, debe usar rutas de Convención de nomenclatura universal (UNC).

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de MicrosoftPara obtener más información sobre la revisión del software de Microsoft Business Solutions CRM y la terminología del paquete de actualización, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

887283 Los estándares de nomenclatura de paquetes de actualización y corrección de software de Microsoft Business Solutions CRM

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×