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Symptoms

Consider the following scenario:

  • You have a computer that is running Windows Server 2008 R2 or Windows 7.

  • You start a backup operation that backs up some folders on the computer. One or more volumes store these folders. However, one of the volumes does not exist any longer.

In this scenario, the backup operation fails after you start the backup operation. Additionally, the Block Level Backup Engine Service (Wbengine.exe) stops.

Note The Wbengine.exe service is used by Windows Backup to run the backup and recovery operations.

Cause

This issue occurs because the Wbengine.exe service crashes when this service tries to access a folder on the volume that does not exist.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows 7. Additionally, you must have the Windows Server Backup Features installed.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes


Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Wbengine.exe

6.1.7600.20674

1,203,200

20-Mar-2010

07:41

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wbengine.exe

6.1.7600.20674

1,503,744

20-Mar-2010

07:57

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wbengine.exe

6.1.7600.20674

3,716,096

20-Mar-2010

06:34

IA-64

Workaround

To work around this issue, remove the folders that are stored on the missing volume from the backup settings before you start the backup operation.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about how to back up or transfer your data on a Windows-based computer, click the following article number to view the article in the Microsoft Knowledge Base:

971759 How to back up or transfer your data on a Windows-based computer

For more information about a backup operation, view the following Microsoft Tech website:

General information about a backup operationFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

Update.mum

File version

Not applicable

File size

1,652

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not applicable

File name

X86_820630d00b2edadabda5fc33f2df331d_31bf3856ad364e35_6.1.7600.20674_none_fb7e79f1b5c452ce.manifest

File version

Not applicable

File size

703

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not applicable

File name

X86_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.1.7600.20674_none_e44bbc547a29e31a.manifest

File version

Not applicable

File size

7,062

Date (UTC)

20-Mar-2010

Time (UTC)

08:22

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_4d1bc8d562e5fe918f8927b1d89b9f9b_31bf3856ad364e35_6.1.7600.20674_none_da9b106d6f8201a8.manifest

File version

Not applicable

File size

707

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not applicable

File name

Amd64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.1.7600.20674_none_406a57d832875450.manifest

File version

Not applicable

File size

7,068

Date (UTC)

20-Mar-2010

Time (UTC)

09:28

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

1,855

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_0a8b185e35939d0ee538da0206fd1f0f_31bf3856ad364e35_6.1.7600.20674_none_67766b07685ff3c9.manifest

File version

Not Applicable

File size

705

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not Applicable

File name

Ia64_microsoft-windows-blb-engine-main_31bf3856ad364e35_6.1.7600.20674_none_e44d604a7a27ec16.manifest

File version

Not Applicable

File size

7,065

Date (UTC)

20-Mar-2010

Time (UTC)

09:12

Platform

Not Applicable

File name

Update.mum

File version

Not Applicable

File size

1,434

Date (UTC)

20-Mar-2010

Time (UTC)

12:41

Platform

Not Applicable

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