Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Un equipo basado en Windows Server 2003 deja de responder cuando apaga el equipo en una sesión de consola remota. Este problema se produce al azar.

Nota: Puede establecer una sesión de consola remota mediante la herramienta conexión a Escritorio remoto (Mstsc.exe) junto con el modificador/Console .

Causa

En un proceso regular de apagado de Windows Server 2003, el sistema operativo tiene un período de tiempo de espera durante el cual el Administrador de control de servicios (SCM) cierra los servicios. Si el SCM no finaliza cerrando todos los servicios en el período de tiempo de espera, el sistema operativo continúa apagar sin necesidad de esperar. El tiempo de espera se especifica en la entrada de registro WaitToKillServiceTimeout. El período de tiempo de espera predeterminado dura 20 segundos.

Sin embargo, si apaga un equipo en una sesión de consola remota, el sistema operativo continúa apagar sin tener en cuenta el tiempo de espera. En este caso, el sistema operativo continúa apagar varios segundos después de que el SCM envía una notificación de cierre para el servicio. A continuación, el controlador NTFS comienza a apagar como parte del proceso de apagado del sistema. El controlador NTFS comienza a apagar antes de lo esperado cuando todavía está cerrando el servicio. El servicio puede tener acceso a los recursos de disco durante el proceso de apagado. Un interbloqueo es probable que se produzca entre la operación de apagado NTFS y el acceso al recurso de disco.

Solución

Importante: Esta revisión sustituye a una revisión anterior que se publicó con el mismo número de artículo de Microsoft Knowledge Base (930045). Si ya ha aplicado la revisión anterior, debe quitar la revisión anterior y, a continuación, instale la revisión actual. Para quitar la revisión anterior, utilice el elemento Agregar o quitar programas en Panel de Control.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows Server 2003 Service Pack 1 o Windows Server 2003 Service Pack 2 instalado en el equipo. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

889100 cómo obtener el service pack más reciente para Windows Server 2003

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.

Windows Server 2003 con Service Pack 1, versiones basadas en x86

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

246,272

14-Nov-2007

09:19

x86

Windows Server 2003 con Service Pack 2, versiones basadas en x86

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

246,272

14-Nov-2007

09:15

x86

Windows Server 2003 con Service Pack 1, versiones basadas en Itanium

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

698,368

14-Nov-2007

07:08

IA-64

Windows Server 2003 con Service Pack 2, versiones basadas en Itanium

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

698,880

14-Nov-2007

07:12

IA-64

Windows Server 2003, versiones basadas en x 64

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

365,056

14-Nov-2007

07:08

x64

Windows Server 2003 con Service Pack 2, versiones basadas en x64

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

365,056

14-Nov-2007

07:14

x64

Solución alternativa

Para evitar este problema, no reinicie el equipo basado en Windows Server 2003 en una sesión de consola remota. O bien, no apague el equipo basado en Windows Server 2003 en una sesión de consola remota.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×