Síntomas

Imagine el siguiente escenario:

  • Tiene un equipo que está ejecutando el Service Pack 1 (SP1) de Windows 7.

  • El equipo está ejecutando el servicio Búsqueda de Windows y tiene las interfaces de personalización de entrada habilitadas.

  • Eliminar un perfil de usuario en el equipo.

  • Reinicie el equipo o reinicie el servicio Búsqueda de Windows.

En este escenario, la carpeta de perfil de usuario se inesperadamente vuelve a crear en la siguiente ruta:

C:\Users\username\AppData\Local\Microsoft\InputPersonalization\TextHarvester\TextHarvester.datNota: El archivo TextHarvester.dat que se crea es parte del sistema de personalización de entrada que se adapta el modelo de idioma y el diccionario a un usuario determinado, basado en el uso del usuario. Esta información de uso principalmente se obtiene mediante el indizador de búsqueda.

Causa

Este problema se produce porque no se comprueba la presencia del perfil de usuario antes de crea el archivo Textharvester.dat.Nota: El archivo IPSPlugin.dll almacena en caché los datos recolectados de texto para cada usuario en el archivo TextHarvester.dat correspondiente.

Solución

Para resolver este problema, aplique la revisión que se describe en esta sección.Nota: Esta revisión no quita las carpetas de perfil de usuario volver a crear. Después de aplicar este hotfix, deberá eliminar manualmente las carpetas de perfil de usuario volver a crear. Se trata de una acción única.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar el Service Pack 1 de Windows 7.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye cualquier revisión lanzada anteriormente.

La versión en inglés (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.

Notas sobre la información de archivo de Windows 7Importante: Correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones en la página solicitud de revisión se enumeran en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece bajo "Windows 7/Windows Server 2008 R2" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.

  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn) y servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo como se muestra en la siguiente tabla.

    Versión

    Producto

    SR_Level

    Tipo de servicio

    6.1.760 1. 22 xxx

    Windows 7

    SP1

    LDR

  • Los archivos MANIFEST (.manifest) y los archivos MUM (.mum) que se instalan para cada entorno están enumerados por separado en la sección "información de archivo adicional para Windows 7". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.

Para todas las versiones basadas en x86 compatibles de Windows 7

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Ipsplugin.dll

6.1.7601.22374

82,944

02-Jul-2013

05:05

x86

Para todas las versiones basadas en x64 compatibles de Windows 7

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Ipsplugin.dll

6.1.7601.22374

94,720

02-Jul-2013

05:13

x64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Referencias

Vea la terminología que Microsoft utiliza para describir las actualizaciones de software.

Información adicional de archivos para Windows 7

Archivos adicionales para todas las versiones basadas en x86 compatibles de Windows 7

Nombre del archivo

X86_4c79f69732dbbe03b8fa887eea6f92ed_31bf3856ad364e35_6.1.7601.22374_none_4a17cd0cdfb0bf49.manifest

Versión del archivo

No aplicable

Tamaño de archivo

706

Fecha (UTC)

02-Jul-2013

Hora (UTC)

11:30

Plataforma

No aplicable

Nombre del archivo

X86_microsoft-windows-tabletpc-ipsplugin_31bf3856ad364e35_6.1.7601.22374_none_be927d00b6e5300c.manifest

Versión del archivo

No aplicable

Tamaño de archivo

5,990

Fecha (UTC)

02-Jul-2013

Hora (UTC)

05:51

Plataforma

No aplicable

Archivos adicionales para todas las versiones basadas en x64 compatibles de Windows 7

Nombre del archivo

Amd64_812fd90ced3a9d3ba5e169a35b240825_31bf3856ad364e35_6.1.7601.22374_none_6b007842e33d6c61.manifest

Versión del archivo

No aplicable

Tamaño de archivo

710

Fecha (UTC)

02-Jul-2013

Hora (UTC)

11:30

Plataforma

No aplicable

Nombre del archivo

Amd64_microsoft-windows-tabletpc-ipsplugin_31bf3856ad364e35_6.1.7601.22374_none_1ab118846f42a142.manifest

Versión del archivo

No aplicable

Tamaño de archivo

5,992

Fecha (UTC)

02-Jul-2013

Hora (UTC)

05:51

Plataforma

No aplicable

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