Utilizar un alias de campo en la consulta no funciona con algunas bases de datos de terceros

Se aplica: Microsoft Office Excel 2007

Síntomas


Cuando intenta utilizar Microsoft Query para devolver los datos de algunas bases de datos de terceros en Microsoft Excel, apóstrofos (') alrededor de los nombres de alias pueden causar que falle la consulta. El mensaje de error que recibirá depende el origen de datos que utiliza.

Causa


Este comportamiento es el resultado de un cambio de diseño en Microsoft Query. Apóstrofos son ahora automáticamente cuando utiliza alias para evitar errores causados por un alias que contiene espacios o palabras reservadas.

Solución


Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Excel 2003 y Excel 2007

No es necesario descargar nada para corregir este problema en Microsoft Office Excel 2003 o en Microsoft Office Excel 2007. Consulte la sección "Más información" de este artículo para obtener instrucciones acerca de cómo habilitar esta funcionalidad

Excel 2002

La versión de Excel 2002 global de este hotfix tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
Nombre del archivoTamaño de archivoFechaHora
Msqry32.msp2,100,76024-Sep-200201:29
Msqry32_admin.msp1,331,42424-Sep-200203:52
Después de instalar el hotfix, los archivos siguientes tendrán los atributos enumerados o posterior:
Nombre del archivoVersión del archivoTamaño de archivoFechaHora
Msqry32.exe10.0.4510.0739,91213-Sep-200203:52
Excel 2000

La versión global de Excel 2000 de esta revisión tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
Nombre del archivoTamaño de archivoFechaHora
Msqry32.msp1,166,69208-Nov-200213:41
Msqry32_admin.msp1,419,62808-Nov-200216:36
Después de instalar el hotfix, los archivos siguientes tendrán los atributos enumerados o posterior:
Nombre del archivoVersión del archivoTamaño de archivoFechaHora
Msqry32.exe9.0.0.69191,089,53619-Sep-200220:31
Después de instalar este hotfix, siga los pasos que se enumeran en la sección "Más información" de este artículo para establecer la clave de registro AllowAlias y activar el hotfix.

Nota: Después de instalar la revisión que se describe en este artículo y establecer la clave de registro AllowAlias, Microsoft Query se comportará como ocurría en Excel 97.


Solución alternativa


Microsoft proporciona ejemplos de programación únicamente con fines ilustrativos, sin ninguna garantía expresa o implícita. Esto incluye, pero no se limita, a las garantías implícitas de comerciabilidad o idoneidad para un propósito particular. Este artículo asume que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos.

Para evitar este problema, agregue comillas al alias desde dentro de Microsoft Query. Para ello, siga estos pasos:
  1. Haga doble clic en el nombre del campo en Microsoft Query.
  2. En el cuadro de diálogo Editar columna , escriba su alias de nombre de campo entre comillas.

    Por ejemplo, escriba
    "Fred" (con las comillas) y, a continuación, haga clic en
    OK.

    Después de haber devuelto los datos a Excel, puede utilizar Microsoft Visual fundamentos para aplicaciones (VBA) para modificar el SQL y quitar las comillas de un objeto QueryTable o de una tabla dinámica:
    ActiveSheet.Querytable(1).SQL = "new sql string"
    ActiveSheet.PivotTables(1).Pivotcache.Commandtext = "new sql string"

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se aplica a" de este artículo.

Más información


Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 cómo hacer copia de seguridad y restaurar el registro en Windows
Después de instalar este hotfix, siga estos pasos para establecer la clave de registro AllowAlias y para habilitar la revisión. Siga los pasos apropiados para su versión de Excel.

Excel 2010

No es necesario instalar la revisión. Para habilitar esta revisión, siga estos pasos:
  1. Cierre todos los programas de Office..
  2. Haga clic en Inicioy, a continuación, haga clic en Ejecutar.
  3. En el cuadro Abrir , escriba regedity, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic para seleccionar la siguiente subclave del registro: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\query\optionsdespués de seleccionar la subclave que se especifica en el paso 4, seleccione nuevo en el menú Edición y, a continuación, haga clic en Valor DWORD.
  5. Escriba AllowAliasy, a continuación, presione ENTRAR.
  6. Haga clic en AllowAliasy, a continuación, haga clic en Modificar.
  7. En el cuadro información del valor , escriba 2y, a continuación, haga clic en Aceptar.
  8. En el menú archivo , haga clic en Salir para salir del Editor del registro.

Excel 2007

No es necesario instalar la revisión. Para habilitar esta revisión, siga estos pasos:
  1. Cierre todos los programas de Office..
  2. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  3. En el cuadro Abrir, escriba regedit y, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic para seleccionar la subclave del registro siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\query\options
  5. Después de seleccionar la subclave que se especifica en el paso 4, seleccione nuevo en el menú Edición y, a continuación, haga clic en Valor DWORD.
  6. Escriba AllowAliasy, a continuación, presione ENTRAR.
  7. Haga clic en AllowAliasy, a continuación, haga clic en Modificar.
  8. En el cuadro información del valor , escriba 2y, a continuación, haga clic en Aceptar.
  9. En el menú Archivo, haga clic en Salir para salir del Editor del registro.
Excel 2003

No es necesario instalar la revisión. Para habilitar esta revisión, siga estos pasos:
  1. Cierre todos los programas de Office..
  2. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  3. En el cuadro Abrir, escriba regedit y, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic para seleccionar la subclave del registro siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\query\options
  5. Después de seleccionar la subclave que se especifica en el paso 4, seleccione nuevo en el menú Edición y, a continuación, haga clic en Valor DWORD.
  6. Escriba AllowAliasy, a continuación, presione ENTRAR.
  7. Haga clic en AllowAliasy, a continuación, haga clic en Modificar.
  8. En el cuadro información del valor , escriba 2y, a continuación, haga clic en Aceptar.
  9. En el menú Archivo, haga clic en Salir para salir del Editor del registro.
Excel 2002

Esta actualización se incluyó primero en Office XP Service Pack 3. Para obtener información adicional acerca del service pack más reciente para Office XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
307841 cómo obtener el Service Pack más reciente para Office XP
Para habilitar esta revisión, siga estos pasos:
  1. Cierre todos los programas de Office..
  2. Haga clic en Inicioy, a continuación, haga clic en
    Ejecutar.
  3. En el cuadro Abrir , escriba
    regedity, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic para seleccionar la subclave del registro siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\query\options
  5. Después de seleccionar la subclave que se especifica en el paso 4, seleccione nuevo en el menú Edición y, a continuación, haga clic en
    Valor DWORD.
  6. Escriba AllowAliasy, a continuación, presione ENTRAR.
  7. Haga clic en AllowAliasy, a continuación, haga clic en
    Modificar.
  8. En el cuadro información del valor , escriba
    2y, a continuación, haga clic en Aceptar.
  9. En el menú archivo , haga clic en
    Salir para salir del Editor del registro.
Excel 2000

Para habilitar esta revisión, siga estos pasos:
  1. Cierre todos los programas de Office..
  2. Haga clic en Inicioy, a continuación, haga clic en
    Ejecutar.
  3. En el cuadro Abrir , escriba
    regedity, a continuación, haga clic en Aceptar.
  4. Busque y, a continuación, haga clic para seleccionar la subclave del registro siguiente:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\query\options
  5. Después de seleccionar la subclave que se especifica en el paso 4, seleccione nuevo en el menú Edición y, a continuación, haga clic en
    Valor DWORD.
  6. Escriba AllowAliasy, a continuación, presione ENTRAR.
  7. Haga clic en AllowAliasy, a continuación, haga clic en
    Modificar.
  8. En el cuadro información del valor , escriba
    2y, a continuación, haga clic en Aceptar.
  9. En el menú archivo , haga clic en
    Salir para salir del Editor del registro.

Referencias


Si no tiene que usarlos con Microsoft Query, puede desactivar suavizado completamente.

Para obtener información adicional acerca de cómo desactivar el suavizado en Microsoft Query, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
259347 XL2000: Error Message: ORA-00923: de palabra clave no se encontró donde se esperaba