Informes de estado cliente de System Center configuración Manager 2007 R2 se produce un error cuando los clientes tienen varios registros de descubrimiento

Se aplica: Microsoft System Center Configuration Manager 2007 R3Microsoft System Center Configuration Manager 2007

Síntomas


Imagine el siguiente escenario:
  • Microsoft System Center Configuration Manager 2007 R2 y generación de informes de estado de cliente se instalan en una jerarquía de varios niveles.
  • Un cliente de SCCM 2007 R2 se asigna a un sitio de nivel 2 y envía un registro de datos de descubrimiento (DDR) de latido.
  • Este cliente de SCCM 2007 R2, a continuación, se asigna a un sitio de nivel 1 y envía un registro de datos de descubrimiento (DDR) de latido.
  • Ejecutar la herramienta de informe de estado de cliente y configúrelo para utilizar Ejecutar ahora.
En este escenario, los informes de estado de cliente se produce un error y recibe el siguiente mensaje de error cuando intenta actualizar la información de resumen:
Error no válido de SQL: la subconsulta ha devuelto más de 1 valor. Esto no está permitido cuando la subconsulta sigue =,! =, <, < =, >, > = o cuando se utiliza la subconsulta como una expresión.

Se terminó la instrucción.

No se pudieron sincronizar resumen de base de datos de cliente

Causa


El procedimiento CH_SyncClientSummary proceso de informes de estado de cliente almacenado se supone que se devuelve el valor de sólo un latido. Sin embargo, se devuelven dos valores de latido en este escenario. Por lo tanto, los informes de estado de cliente se produce un error con el mensaje de error.

Solución


Información de Service Pack

Para resolver este problema, obtenga el service pack más reciente para Microsoft System Center Configuration Manager 2007, disponible en este sitio web de Microsoft: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Para obtener una lista de problemas resueltos en este service pack, haga clic en el número de artículo siguiente en Microsoft Knowledgebase:
971348 lista de revisiones y actualizaciones contenidas en System Center Configuration Manager 2007 Service Pack 2

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener System Center Configuration Manager 2007 Service Pack 1 instalado para aplicar esta revisión.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora del Panel de Control.
System Center Configuration Manager 2007 R2
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Update.sqlNo aplicable4,50730-Nov-200821:10No aplicable

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft