Error "No se admite la referencia cultural" se produce cuando intenta configurar Microsoft Dynamics CRM para Microsoft Office Outlook

Se aplica a: Microsoft Dynamics CRM 2011Dynamics CRM 2013Microsoft Dynamics CRM 2013 Service Pack 1

Síntoma


Cuando intenta conectarse a Microsoft Dynamics CRM para Microsoft Office Outlook, recibirá el siguiente mensaje de error:

Hay un problema de comunicación con el servidor de Microsoft Dynamics CRM. El servidor podría estar disponible. Inténtelo de nuevo más tarde. Si el problema persiste, póngase en contacto con el administrador del sistema.

No se admite la referencia cultural.
Nombre de parámetro: referencia cultural
0 (0 x 0000) es un identificador de referencia cultural válido.
en Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
en Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
en Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure (IProgressEventHandler progressEventHandler)
en Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure (objeto stateInfo)

Causa


No se pudo establecer la configuración de idioma en el nivel de usuario en CRM debido a los privilegios de usuario insuficientes. Rol de seguridad del usuario que falte el privilegio de escritura para la entidad de configuración de usuario.

Solución


1. Inicie una sesión en la aplicación web de Microsoft Dynamics CRM como un usuario con el rol de administrador del sistema.

2. vaya a configuración > seguridad > Roles de seguridad.

NOTA: Si no utilizas 2015 o posterior de Microsoft Dynamics CRM, Roles de seguridad se encuentra bajo administración en lugar de seguridad.

3. Abra el rol que se asigna a este usuario.

4. Haga clic en la ficha Administración de empresas y otorgar el privilegio "escritura" para la entidad de Configuración de usuario . Acceso a nivel de usuario es el requisito mínimo.

5. Haga clic en Guardar.

6. intente conectarse de nuevo Microsoft Dynamics CRM para Microsoft Office Outlook.

Si aún se encuentra problemas de conexión de CRM para Outlook a su organización de CRM Online, una herramienta de diagnóstico está disponible para ayudar a diagnosticar el problema:

CRM para el diagnóstico de la configuración de Outlook

Más información


Si no está seguro de qué rol de seguridad se asigna al usuario, siga estos pasos:

1. vaya a configuración > seguridad > usuarios.

NOTA: Si no utilizas 2015 o posterior de Microsoft Dynamics CRM, los usuarios se encuentra bajo administración en lugar de seguridad.

2. Abra el registro de usuario que se enfrenta a este problema.

3. en la barra de comandos en el registro de usuario, haga clic en Administrar funciones.

4. Busque el rol de seguridad que tiene una marca de verificación junto a él. Utilice los pasos proporcionados en la sección resolución para conceder el privilegio de escritura para la entidad de Configuración de usuario .