PrivilegeDenied error se produce al utilizar la sincronización del servidor

Se aplica a: Dynamics CRM

Síntoma


Cuando se utiliza sincronización de servidor en Dynamics 365, recibirá el error siguiente tras hacer clic en Test & Habilitar buzón:
"Citas, contactos y tareas no se puede sincronizar el buzón < nombre de buzón > porque el usuario del buzón no tiene permisos suficientes en este buzón.
Código de Error del servidor de correo electrónico: Crm.80040220.PrivilegeDenied "

Causa


Este error aparece si el usuario asociado con el registro de buzón no tiene privilegios suficientes para utilizar la sincronización del servidor.

Solución


Modificar rol de seguridad del usuario para incluir el privilegio que faltan.  Al hacer clic en la sección de detalles, debe incluir el nombre del privilegio que faltan.  En el ejemplo siguiente, el usuario falta el privilegio de lectura para la entidad de perfil de servidor de correo electrónico.
 

T:331ActivityId: < GUID >> excepción: excepción no controlada: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: no se pudo actualizar el estado de sincronización: excepción no controlada: System.ServiceModel.FaultException'1 [[ Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version = 8.0.0.0, Culture = neutral, PublicKeyToken = 31bf3856ad364e35]]: Principal usuario (Id = < GUID >, tipo = 8) le falta el privilegio de prvReadEmailServerProfile (Id = Detalle de edebe6f6-cf2e-4520-b635-ae0615d41e34): f6afa1da-a317-4cfd-a3ea-cb062b28dbcf-2147220960 Principal usuario (Id = < GUID >, tipo = 8) le falta el privilegio de prvReadEmailServerProfile (Id = edebe6f6-cf2e-45...

Para obtener una lista de los privilegios que pueden ser necesarios para utilizar sincronización de servidor, consulte la sección más información.

Más información


La siguiente tabla enumera los privilegios necesarios para utilizar la sincronización del servidor y la ficha en un rol de seguridad donde se encuentra el privilegio. Un usuario con el rol de administrador del sistema puede localizar y modificar un rol de seguridad, vaya a configuración, seguridad, Roles de seguridad. Para ver qué funciones se asignan a un usuario específico, vaya a configuración, haga clic en seguridad, haga clic en usuarios, seleccione el registro de usuario específico y, a continuación, haga clic en Administrar funciones. 

Nombre de privilegio Entidad Ubicación (ficha) en el rol de seguridad
prvReadEmailServerProfile EmailServerProfile Administración del negocio
prvWriteMailbox Buzón de correo NegociosAdministración de
prvReadMailbox Buzón de correo NegociosAdministración de
prvReadOrganization Organización NegociosAdministración de
prvSyncToOutlook Outlook Administración de negocios--> privilegios de privacidad
prvReadActionCard ActionCard Registros principales
prvDeleteActivity Actividad Registros principales
prvAppendActivity Actividad Registros principales
prvWriteActivity Actividad Registros principales
prvCreateActivity Actividad Registros principales
prvReadActivity Actividad Registros principales
prvAppendToActivity Actividad Registros principales
prvReadConnection Conexión Registros principales
prvAssignContact Contacto Registros principales
prvReadContact Contacto Registros principales
prvWriteContact Contacto Registros principales
prvCreateContact Contacto Registros principales
prvDeleteContact Contacto Registros principales
prvReadUserQuery Vista guardada Registros principales
prvReadQueue Cola Registros principales
prvReadQuery Vista Personalización
prvReadIncident Caso Servicio
prvSearchAvailability   Administración de servicio--> privilegios diversos
prvOverrideCreatedOnCreatedBy   Administración de servicio--> privilegios diversos