El estado de un transportista no se actualiza a cerrado y la pantalla visor de registro de la actualización del expedidor (40.460.00) no incluye una entrada para el identificador del transportista en la administración de pedidos de Microsoft Dynamics SL

Se aplica a: Dynamics SL 2011Microsoft Dynamics SL 2015

Síntomas


Después de completar o cancelar un transportista, el valor del cuadro Estado no se actualiza a cerrado en Microsoft Dynamics SL.  
Nota El cuadro de Estado aparece en la pestaña otra información de la pantalla transportistas (40.110.00) .  Además, la pantalla del visor de registro de la actualización del transportista (40.460.00) no incluye una entrada para el identificador del transportista. 

Causa


Causa 1
La configuración de la actualización del transportista retrasada es incorrecta. Vea la Solución 1
Causa 2
El valor de tiempo de espera para el administrador de procesos es demasiado pequeño. Ver la Solución 2
Causa 3 
El paso actualizar remitente de la pestaña pasos en la pantalla tipos de pedidos (40.200.00) se ha configurado incorrectamente. Vea la Solución 3
Causa 4 
El tipo de pedido se cambió en la pestaña pasos en la pantalla tipos de pedidos (40.200.00) antes de que se cerraran los transportistas existentes. Vea la solución 4
Causa 5 
Se han agregado personalizaciones a la pantalla de transportistas (40.110.00) que interrumpieron el procesamiento de los registros de transportistas. Vea la Solución 5
Causa 6 
Cualquier causa distinta de la causa 1 a la causa 5.  En este caso, este problema se produce independientemente del tipo de pedido. Vea la solución 6 o la solución 7.

Resolución


Solución 1
Compruebe que la configuración para retrasar la actualización del remitente no sea demasiado grande. Para ello, siga estos pasos:
  1. En el menú módulo , haga clic en Administración de pedidos.
  2. En el panel Administración de pedidos , haga clic en configuración de administración de pedidos en configuración.
  3. En la pestaña otros , asegúrese de que el valor de la casilla actualización del transportistas (minutos) del retraso no es demasiado grande. Nota: Si el valor de la actualización del transportistas (minutos) se establece en 30, el expedidor no se cerrará hasta 30 minutos después de completar el registro de transportistas.
Solución 2
Aumentar el tiempo de espera para el proceso del administrador de procesos. Para ello, siga estos pasos:
  1. En el menú módulo , haga clic en Administración de pedidos.
  2. En el panel Administración de pedidos , haga clic en configuración de administración de pedidos en configuración.  
  3. En la pestaña otros , escriba 15 en el cuadro tiempo de suspensión del administrador de procesos (segundos) si el valor del cuadro es menor de 15.
Solución 3
Corrija el estado del paso en el tipo de pedido. Para ello, siga estos pasos:
  1. En la lista módulos , haga clic en Administración de pedidos.
  2. En el panel Administración de pedidos , haga clic en tipos de pedidos en mantenimiento.
  3. En el cuadro tipo de orden , escriba el identificador de tipo de pedido que desee cambiar.
  4. En la pestaña pasos , haga clic en obligatorio en el paso Estado del remitente de la actualización.
  5. Haga clic en Guardar. Después, cierre la pantalla tipos de pedidos (40.200.00) .
Solución 4
Cancelar los transportistas y las órdenes de venta relacionadas. Para ello, siga estos pasos: 
  1. En la lista módulos , haga clic en Administración de pedidos.
  2. En el panel Administración de pedidos , haga clic en confirmación de envío en entrada.
  3. En el cuadro ID del transportista , escriba el identificador del transportista que desea cancelar.
  4. Haga clic para activar las casillas de verificación siguientes: 
    • Cancelar remitente 
    • Cancelar pedido 
  5. Haga clic en Finalizar. Después, cierre el Pantalla de confirmación de envío (40.117.00) .
Resolución 5
Quite las personalizaciones de la pantalla transportistas (40.110.00) . Para ello, siga estos pasos:
  1. Cierre todas las pantallas excepto la de los transportistas (40.110.00) .
  2. En el menú personalizar , haga clic en modo personalizar.
  3. En el menú personalizar , haga clic en quitar cambios para la pantalla.
  4. Haga clic en y, a continuación, en Aceptar.
  5. Cierre la pantalla transportistas (40.110.00) . A continuación, abra la pantalla.
Resolución 6
Cambie el orden de los transportistas a un pedido reconocido por el administrador de procesos. Para ello, siga estos pasos. 
Nota: Antes de seguir las instrucciones de este procedimiento, asegúrese de que tiene una copia de seguridad completa de la base de datos que puede restaurar si se produce un problema.
  1. En la pantalla Administrador de procesos (40.400.00) , haga clic en detener.
  2. Con el analizador de consultas de Microsoft SQL o Microsoft SQL Server Management Studio, ejecute la instrucción adecuada en la base de datos de la aplicación.
    • Microsoft SQL Server 7,0
    • Microsoft SQL Server 2000 o Microsoft SQL Server 2005 o Microsoft SQL Server 2008
  3. Copie los resultados de la instrucción en una ventana nueva. Excluya los encabezados de columna o las líneas de recuento de filas. A continuación, ejecute la nueva instrucción para reponer los transportistas que aparecen en la lista.Nota: La siguiente instrucción es un ejemplo de los resultados que se copiarán.
  4. En la pantalla Administrador de procesos (40.400.00) , haga clic en Inicio.
Resolución 7
Cancelar el remitente. Para ello, siga estos pasos:
  1. En la lista módulos , haga clic en Administración de pedidos.
  2. En el panel Administración de pedidos , haga clic en destinatarios en entrada.
  3. En la pestaña otra información , haga clic para activar la casilla cancelado y, a continuación, haga clic en Finalizar.