Se registra un mensaje "se detectó un error mientras se iniciaba el proceso para el grupo de aplicaciones 'CRMAppPool'" en el registro de aplicación después de configurar CRMAppPool para una cuenta de usuario de dominio en Microsoft Dynamics CRM

Se aplica a: Dynamics CRM 4.0

Síntomas


Al ejecutar el grupo de aplicaciones CRMAppPool después de configurar el grupo de aplicaciones para una cuenta de usuario de dominio en Microsoft Dynamics CRM, el mensaje siguiente se registra en el registro de aplicación:
Nota: En este mensaje de error, fecha y hora representan la fecha real y el tiempo real. Por ejemplo, estos valores podrían ser "2007-12-12" y "17:53:26.138".

Cuando se produce este problema, no se puede iniciar el grupo de aplicaciones CRMAppPool. Además, recibirá el siguiente mensaje de error:
Servicio no disponible.
Este problema se produce incluso si el usuario de la cuenta de dominio es un miembro del grupo administrador local.

Causa


El problema se produce porque los permisos o los derechos de usuario del usuario de cuenta de dominio no son suficientes.

Solución


Para resolver este problema, siga estos pasos:
  1. Incluya el usuario de la cuenta de dominio en los siguientes grupos de Active Directory:
    • El grupo usuarios de dominio de Active Directory
    • PrivUserGroup
    • SQLAccessGroup
    Para ello, siga estos pasos:
    1. Inicie sesión en un servidor como un usuario que tenga derechos de administrador de dominio o derechos para actualizar estos grupos.
    2. Haga clic derecho en el grupo Usuarios de dominio de Active Directory y, a continuación, haga clic en Propiedades.
    3. En el cuadro nombre de grupo , escriba el nombre del usuario que ejecuta el grupo de aplicaciones de CRM y, a continuación, haga clic en Aceptar dos veces.
    4. Repita los pasos b y c del grupo PrivUserGroup y del grupo SQLAccessGroup.
    Si tiene instalada más de una implementación de Microsoft Dynamics CRM, existen varios grupos en Active Directory. Para determinar los grupos que desea actualizar, siga estos pasos.

    Para Microsoft Dynamics CRM 3.0
    1. Ejecute la siguiente instrucción SQL contra la base de datos MSCRM:
      select organizationid from organizationbase
    2. Anote el GUID. Por ejemplo, el GUID puede ser C8AB1D52 9383 4164 B571 4C80D46674E3.
    3. Busque el grupo PrivUserGroup y el grupo SQLAccessGroup en Active Directory. El nombre de grupo contiene el GUID que anotó en el paso b.
    Para Microsoft Dynamics CRM 4.0
    1. Ejecute la siguiente instrucción SQL contra la base de datos MSCRM_config:
      select id, friendlyname from organization
    2. Anote el GUID. Por ejemplo, el GUID podría ser C8AB1D52-9383-4164-B571-4C80D46674E3 Nombre Org.
    3. Busque el grupo PrivUserGroup y el grupo SQLAccessGroup en Active Directory. El nombre de grupo contiene el GUID que anotó en el paso b.
  2. Incluya el usuario de la cuenta de dominio en los siguientes grupos en el servidor de Microsoft Dynamics CRM:
    • El grupo IIS_WPG local
    • El grupo CRM_WPG local
    Nota: El usuario de cuenta de dominio debe tener los siguientes derechos de usuario local:
    • El derecho de suplantar a un cliente tras la autenticación
    • El derecho iniciar sesión como un servicio
    Para ello, siga estos pasos:
    1. En el servidor de Microsoft Dynamics CRM, haga clic en Inicio, seleccione Herramientas administrativasy, a continuación, haga clic en Directiva de seguridad Local.
    2. Expanda Directivas localesy, a continuación, haga clic en Asignación de derechos de usuario.
    3. Haga clic en suplantar a un cliente tras la autenticacióny, a continuación, haga clic en Propiedades.
    4. Haga clic en Agregar usuario o grupo.


      Nota: Tendrá que hacer clic en ubicación , seleccione el dominio en vez del equipo local.
    5. En el cuadro nombre de grupo , escriba el nombre del usuario que ejecuta el grupo de aplicaciones de CRM y, a continuación, haga clic en Aceptar dos veces.
    6. Repita los pasos de 2c a 2e para el derecho iniciar sesión como un servicio .
  3. Configurar la cuenta de seguridad del grupo de aplicaciones CRMAppPool para usar un nombre principal de servicio (SPN). Para obtener más información acerca de cómo configurar los SPN, vea el siguiente documento de nombres principal (SPN) del servicio de configuración en el centro de recursos:Nota: Para Microsoft Dynamics CRM 4.0, no es necesario crear un SPN para la cuenta de dominio.
  4. Configurar la cuenta de usuario en el servidor de Microsoft Dynamics CRM que es de confianza para delegación 1. Para ello, siga estos pasos:
    1. En el controlador de dominio, abra usuarios y equipos de Active Directory Users.

      Nota: Si está disponible la delegación restringida, utilice un servidor que está ejecutando Windows Server 2003 para abrir Active Directory Users and Computers. De lo contrario, no verá las opciones para configurar la delegación restringida.
    2. Expanda el dominio y, a continuación, expanda usuarios.
    3. Haga clic en el nombre de usuario y, a continuación, haga clic en Propiedades.
    4. Siga los pasos del método apropiado que está utilizando.

      Delegación completa
      1. Haga clic en la ficha cuenta .
      2. En la sección Opciones de cuenta , desplácese hacia abajo y, a continuación, seleccione la cuenta es de confianza para la delegación.

        Nota: Esta opción no aparece si no se ha definido el SPN.
      IIS 6.0 y delegación restringida
      1. Haga clic en la ficha delegación .
      2. Haga clic en Confiar en esta cuenta para la delegación sólo a servicios especificados.
      3. Haga clic en utilizar sólo Kerberos.
      4. Haga clic en Agregar.
      5. Haga clic en usuarios o equipos, haga clic en Opciones avanzadas, haga clic en Buscar ahora, seleccione el servidor de Reporting Services y, a continuación, haga clic en Aceptar dos veces.
      6. Seleccione el servicio HTTP y, a continuación, haga clic en Aceptar.
  5. Reinicie el servidor.

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

909588 cómo configurar la autenticación Kerberos para Microsoft CRM 3.0 y Microsoft SQL Server Reporting Services