WD97: La imagen aparece como una "X" de color rojo en el documento

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Este artículo se refiere a productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Síntomas

Al abrir en Word 97 un documento que contiene gráficos, algunos de ellos aparecen en pantalla como una "X" (completa o parcial) de color rojo.

Causa

Este problema se da con mayor frecuencia en el caso de archivos de mapa de bits (.bmp) insertados o de gráficos que se hayan pegado. Tenga en cuenta, sin embargo, que este problema se puede dar también con otros formatos de gráficos.


Word usa una "X" de color rojo, u otro símbolo global (un círculo, cuadrado o triángulo), para representar cualquier gráfico o imagen que no se puede mostrar en pantalla. Word no puede mostrar en pantalla gráficos dañados y puede perder los datos de las imágenes cuando la memoria o los recursos del sistema son escasos.

Solución

En la mayoría de los casos se puede solucionar este problema actualizando Microsoft Word con la revisión Service Release 1 (SR-1).


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados al principio de este artículo. Si ha instalado la revisión SR-1 y sigue teniendo el problema de la "X" de color rojo, consulte la sección "Si ha instalado la revisión SR-1 y sigue viendo una 'X' de color rojo" dentro de este mismo artículo.


Una vez que haya instalado la revisión SR-1, tendrá que restaurar de forma manual los gráficos del documento. Tenga en cuenta que también puede usar este procedimiento para solucionar temporalmente el problema en el caso de que no pueda instalar la revisión SR-1.


Para restaurar de forma manual los gráficos en un documento, siga estos pasos:


  1. En el menú Herramientas, haga clic en Opciones y, a continuación, haga clic en la ficha Guardar.
  2. Desactive la casilla de verificación Permitir guardar rápidamente.
  3. En el menú Archivo, haga clic en Guardar como y guarde el documento con otro nombre. Restaure los gráficos de este nuevo documento y utilice, a partir de este momento, la versión nueva del documento.
  4. Use los siguientes métodos para determinar la causa del problema y restaurar los gráficos.
  1. Haga doble clic en Mi PC en el escritorio.
  2. Haga clic con el botón secundario del mouse (ratón) en el disco duro principal, por ejemplo el disco C.
  3. Haga clic en Propiedades. La cantidad de espacio disponible en el disco debe ser de unos 20 Megabytes (MB) o más.
  1. Elimine la "X" de color rojo que aparece en el documento.
  2. En el menú Insertar, seleccione Imagen, y haga clic en Desde el archivo.
  3. Haga clic para seleccionar el archivo gráfico original y, después, haga clic en Aceptar.
  1. Haga doble clic en la imagen para abrirla en el Editor de imágenes.
  2. En el menú Edición, haga clic en Seleccionar todo.
  3. En el menú Edición, haga clic en Copiar.
  4. En el menú Archivo, haga clic en Cerrar y volver al documento.
  5. En Word, haga clic en Pegar, en el menú Edición.

Método 1: Comprobar que hay suficiente espacio disponible en el disco duro principal

Siga estos pasos: No hay definida una cantidad específica de espacio mínimo disponible en el disco para poder ejecutar los programas de Office. Sin embargo, la mayoría de los equipos necesitan una cantidad mínima de espacio disponible en disco (normalmente unos 20 MB) para abrir, cerrar y guardar archivos e imprimir documentos.


Si el disco duro tiene menos de 20 MB de espacio disponible, es aconsejable que quite los archivos de datos, archivos temporales o programas que no utilice. Una vez que tenga disponibles 20 MB o más en el disco duro principal, puede reiniciar Windows y volver a abrir el archivo.


Método 2: Sustituir el gráfico por el archivo de origen que se usó inicialmente

Siga estos pasos:


Método 3: Abrir la imagen en el Editor de imágenes y pegarla después en el documento

Siga estos pasos:


Método 4: Actualizar los resultados del campo

Si el gráfico está vinculado, puede actualizar los resultados del campo. Por ejemplo, si al ver los códigos de los campos observa un campo similar a alguno de los siguientes


{IMPORT C:\\Clipart\\Imagen.pcx}
o bien

{INCLUDEPICTURE C:\\Clipart\\Imagen.pcx}
debe comprobar que hay un archivo Imagen.pcx en la carpeta Clipart. A continuación, seleccione el campo y presione F9 para actualizarlo.


Al actualizar el campo, el filtro de gráficos volverá a leer el archivo de origen de la imagen. Al hacerlo, se debería actualizar la pantalla con lo que la "X" de color rojo sería reemplazada por la imagen deseada.


SI HA INSTALADO LA REVISIÓN SR-1 Y AÚN SIGUE VIENDO UNA "X" DE COLOR ROJO

En algunos casos, se muestra la "X" de color rojo en el documento de forma intencionada. Puede aparecer una imagen de una "X" de color rojo cuando se da alguna de las condiciones siguientes:


  • Se trata de una imagen GIF o JPEG con opciones complejas de formato, como por ejemplo animaciones, sonidos o secuencias de presentación progresiva.


    o bien
  • No existe el directorio especificado como directorio temporal en Windows.


    o bien
  • La imagen o alguna otra parte del documento han sufrido algún daño.


    o bien
  • No hay suficiente espacio disponible en el disco duro.
Para determinar si es el gráfico el que ocasiona los problemas de presentación de la imagen en el documento, use los siguientes métodos.


Tenga en cuenta que los documentos que se hayan creado con una versión de Microsoft Word 97 para Windows anterior a la revisión SR-1 seguirán mostrando las "X" de color rojo hasta que se reparen los gráficos. Es decir, los gráficos dañados no se corrigen automáticamente al instalar la revisión SR-1. En este caso, use los métodos y pasos indicados en la sección de "Resolución" de este artículo para recuperar los gráficos que se hayan perdido.


Método 1: Si se trata de una imagen GIF o JPEG

Muchas imágenes JPEG o GIF que se descargan de Internet contienen opciones de formato complejas, por ejemplo animaciones, sonidos o secuencias de presentación progresiva. Word no utiliza esas opciones. Para modificar el gráfico, de forma que incluya sólo los elementos que usa Word, utilice un programa de edición de gráficos para guardar la imagen en un formato más sencillo:


  • En el caso de un gráfico GIF, reduzca la complejidad al nivel CIS GIF 87 ó 87A, en lugar de GIF 89A.
  • En el caso de un gráfico JPEG, guárdelo en formato "simple" o "línea de base", sin la opción de secuencia de presentación progresiva.
Para obtener más información acerca de estos formatos de gráficos, consulte la documentación del programa de edición de gráficos y la sección de "Más información" de este artículo.


Método 2: Comprobar que el directorio Temp que se utiliza es válido

Compruebe que las líneas SET TEMP y SET TMP del archivo Autoexec.bat hacen referencia a carpetas válidas. Para comprobar las líneas SET TEMP y SET TMP del archivo Autoexec.bat, siga estos pasos:



  1. Haga clic en Inicio y, después, en Ejecutar.
  2. En el cuadro Ejecutar, escriba sysedit y, a continuación, haga clic en Aceptar.


    Este comando abre el Editor de configuración del sistema.
  3. Haga clic para seleccionar la ventana Autoexec.bat.
  4. En el archivo Autoexec.bat, busque una línea que comience por SET TEMP o SET TMP. Si existe alguna de esas líneas, después del signo igual (=) debe aparecer un directorio válido. Anote el directorio al que se hace referencia.


    NOTA: Si el archivo Autoexec.bat no contiene ninguna línea que comience por alguno de estos comandos, pase al método siguiente.
  5. Haga clic en el menú de Inicio y en el Explorador de Windows o en el Explorador de Windows NT.
  6. En el Explorador de Windows, compruebe que el directorio que anotó en el paso 4 es un directorio válido.
Si ejecuta Windows NT, debe comprobar además lo siguiente:


  1. Haga clic en Inicio, seleccione Configuración y, a continuación, haga clic en Panel de control.
  2. En el Panel de control, haga clic en Sistema y, a continuación, haga clic en la ficha Entorno.
  3. En la ficha Entorno, compruebe los valores de TEMP y TMP en Variables de usuario. Esos valores son rutas de acceso a un directorio. Tome nota del directorio indicado.
  4. En el Explorador de Windows NT, compruebe que el directorio que anotó en el paso 3 es un directorio válido. Si en la variable TMP se usan caracteres comodín (signos %), cree un directorio denominado TMP en estas dos ubicaciones: C:\tmp y C:\winnt\Tmp.


    NOTA: Si ejecuta Windows NT versión 4.0, asegúrese de que está instalado el Service Pack 3 (SP3). Este SP soluciona un problema que hace que la variable de usuario SET TMP cambie de valor de forma accidental.
Para obtener información adicional acerca de la forma de obtener el Service Release 1 (SR-1), haga clic en los números de artículo siguientes para ver los artículos en Microsoft Knowledge Base:

172475 OFF97: How to Obtain and Install MS Office 97 SR-1

Para obtener información adicional, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:

167738 WD97: General Information about Floating Objects

Opciones de soporte de Microsoft

Si no puede solucionar este problema, dispone de varias opciones de soporte que le pueden ayudar.

Encuentre con rapidez respuestas en línea

Use el Soporte técnico en línea de Microsoft para buscar en Microsoft Knowledge Base y en otros recursos de tipo técnico respuestas precisas y rápidas. También puede personalizar el sitio para controlar la búsqueda.

Para comenzar la búsqueda, vaya a la dirección Web siguiente:

Soporte técnico de Microsoft

Póngase en contacto con un profesional del Soporte técnico de Microsoft para que le ayude a solucionar los problemas.

Para obtener más información acerca de cómo obtener ayuda para solucionar problemas de Microsoft Windows, haga clic en Temas de ayuda en el menú Ayuda del Explorador de Windows. En la ficha Contenido, haga doble clic para abrir el libro Solución de problemas. A continuación, haga doble clic para abrir el libro Ponerse en contacto con los servicios de soporte de productos de Microsoft para ver las opciones de soporte disponibles.

Para obtener más información acerca de cómo obtener ayuda para solucionar problemas de Microsoft Word, haga clic en Acerca de Microsoft Word en el menú Ayuda y, a continuación, haga clic en Soporte técnico.

Para obtener información adicional acerca de los servicios de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
102344 Microsoft Product Support Options Q&A

Proveedores de soluciones Microsoft

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Método 3: Comprobar que el archivo de gráficos no está dañado

Si ve que la imagen se comienza a presentar de forma parcial antes de que aparezca la "X" de color rojo, o si el tamaño del gráfico es menor del que espera, puede que el gráfico esté dañado.


Para ver el tamaño del gráfico, siga estos pasos:


  1. Haga clic para seleccionar la imagen.
  2. En el menú Formato, haga clic en Imagen.
  3. En el cuadro de diálogo Formato de imagen, haga clic en la ficha Tamaño.
  4. Compruebe el tamaño de la imagen usando los números que aparecen en Tamaño original, cerca de la parte inferior del cuadro de diálogo.
Si el tamaño que se indica no coincide con el que correspondería a la imagen intacta, puede que el archivo esté dañado. Si el tamaño que se indica es 1 pulgada por 1 pulgada, se trata de un problema distinto y tendrá que buscar otras soluciones.


Para restaurar la imagen, siga estos pasos:


  1. Abra la imagen en un programa de edición de gráficos como Photo Editor.
  2. Guarde el archivo en un formato distinto.
  3. Intente insertar de nuevo el archivo guardado en el documento.
En algunos casos, si aparece una "X" de color rojo en el documento es porque alguna otra parte del documento está dañada. Si al abrir el archivo recibe un mensaje de error del tipo "no se puede abrir el archivo", o un error de página (IPF), puede que se haya dañado alguna otra parte del documento.


Método 4: Comprobar que hay suficiente espacio disponible en el disco duro principal

Siga estos pasos:


  1. Haga doble clic en Mi PC en el escritorio.
  2. Haga clic con el botón secundario del mouse (ratón) en el disco duro principal, por ejemplo el disco C.
  3. Haga clic en Propiedades.
  4. La cantidad de espacio disponible en el disco debe ser de unos 20 MB o más.
No hay definida una cantidad específica de espacio mínimo disponible en el disco para poder ejecutar los programas de Office. Sin embargo, la mayoría de los equipos necesitan una cantidad mínima de espacio disponible en disco (normalmente unos 20 MB) para abrir, cerrar y guardar archivos e imprimir documentos.


Si el disco duro tiene menos de 20 MB de espacio disponible, es aconsejable que quite los archivos de datos, archivos temporales o programas que no utilice. Una vez que tenga disponibles 20 MB o más en el disco duro principal, puede reiniciar Windows y volver a abrir el archivo.


Estado


En la mayoría de los casos este problema se resuelve con la revisión Service Release 1 (SR-1) de Microsoft Word 97 para Windows.


Más información

Recursos adicionales para solucionar problemas de gráficos

Información acerca de los formatos de archivo GIF y JPEG

El formato de intercambio de gráficos (GIF) es el formato de archivo más utilizado para las imágenes en el World Wide Web. El formato que le sigue en popularidad es JPEG (Joint Photographic Experts Group).



GIF:



GIF usa un tipo de datos de trama en dos dimensiones, está codificado en formato binario y usa una compresión denominada LZW (Lempel-Ziv-Welch). Hay dos versiones de este formato, 87a y 89a. La versión 89a permite a los usuarios guardar un archivo GIF con animación, que consiste básicamente en una corta secuencia de imágenes dentro de un único archivo GIF. En el formato 89a se pueden guardar también imágenes entrelazadas.



JPEG:



Básicamente hay dos tipos de JPEG: progresivo y sencillo. Un archivo sencillo JPEG, o "línea de base", es el resultado de una digitalización de la imagen realizada de arriba abajo. El tipo progresivo de JPEG divide el archivo en una serie de digitalizaciones de forma que la calidad de la imagen aumenta cada vez que se carga una nueva digitalización.



Este sistema aporta ventajas evidentes en el caso de imágenes que se descargan a través de conexiones con poco ancho de banda. (Básicamente, el tipo progresivo de JPEG no es más que el resultado de ordenar nuevamente el mismo conjunto de datos de una forma más complicada).



Si desea más información acerca de los formatos GIF y JPEG, visite los siguientes sitios en el World Wide Web:

Propiedades

Id. de artículo: 162349 - Última revisión: 01/08/2017 - Revisión: 1

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