WD: Troubleshooting Damaged Documents in Word for Windows

SUMMARY

Damaged document files can cause any program to exhibit unusual behavior.
Such behavior occurs because the program attempts to make decisions about
what to do based on incorrect information in the file.


The best way to protect yourself against document corruption is to keep
backup copies of your documents. In the event that you don't have a backup
copy of your document, this article provides troubleshooting procedures you
can use to identify and recover corrupted Microsoft Word for Windows
documents.

MORE INFORMATION

NOTE: Because there are several versions of Windows, the following steps
may be different on your computer. If they are, please consult your product
documentation to complete these steps.

Identifying a Damaged Document

Damaged documents often exhibit behavior that is not part of the program's
design (for example, infinite repagination, incorrect document layout and
formatting, unreadable characters on the screen, error messages during
processing, system hangs or crashes when you load or view the file, or any
other unusual behavior that cannot be attributed to the normal operation of
the program). This behavior can be caused by factors other than document
corruption. To rule out other factors, use the following troubleshooting
steps:


  • Check for similar behavior in other documents.
  • Check for similar behavior in other programs.
  • Take the file in question to another computer and attempt to duplicate
    the behavior.
  • Use a different printer driver and attempt to duplicate the behavior.
  • Rename any templates attached to the document and attempt to duplicate
    the behavior.
  • Change other system components (such as video drivers or fonts) and
    attempt to duplicate the behavior. For example, if you are using an OEM
    version of a video driver, switch to a Microsoft Windows video driver
    using the Windows Setup program.
  • Disable any third-party programs that are running (such as terminate-
    and-stay-resident programs [TSRs], font managers, screen savers, and
    system shells), and then attempt to duplicate the behavior.
If the problem occurs only with a single document after you perform these
steps, your document has probably been damaged.

Things to Try If the Document Will Open But Exhibits Unexpected behavior

Method 1: Convert the File to Another Format, Then Convert It Back to Word:


This is the easiest and most complete document recovery method; always try
it first. Save the file in RTF file format; this format preserves the
formatting in your Microsoft Word for Windows document. After you save the
file in RTF format, re-open the document in Word for Windows, and convert
it from RTF. If this method succeeds, the file corruption is removed during
conversion. If the corruption persists after you save the file in RTF file
format, try saving the file in the following file formats:

Other word processing formats
Text Only
NOTE: Saving files in Text Only format frequently corrects the document
corruption problem; however, all document formatting is lost. This method
requires more reformatting; therefore, use it only after other file formats
fail to correct the problem.


Method 2: Copy Everything Except the Last Paragraph Mark to a New Document:


Word for Windows associates a wide variety of formatting with the last
paragraph mark, especially section and style formatting. If you copy
everything except the last paragraph mark to a new document, the corruption
may be left behind in the original document. In the new document, reapply
the section or style formatting.


NOTE: You can select everything except the last paragraph mark by pressing
CTRL+END, and then CTRL+SHIFT+HOME.


Method 3: Copy the Undamaged Portions of the Document to a New Document:


Sometimes you can determine the location of file corruption in your
document. In such cases, copy everything except the damaged portion to a
new file, and then use the following steps to reconstruct your document:


  1. After you copy the undamaged portions of your document to a new file,
    save a copy of the damaged document in Text Only format.
  2. Open the Text Only file. Copy the text from this file and paste it into
    the file that contains the undamaged portion of your document.
  3. Reformat the sections you pasted in step 2, and then save the recovered
    document.

Things to Try If the Document Will Not Open

There are several techniques you can use to try to open a document that
will not open. Which method you use depends on the nature and severity of
the damage to your document and the nature of the behavior exhibited.
Although many of these methods succeed regularly, not every damaged
document can be recovered.


Method 1: Open the Damaged Word Document in Draft Mode:


Sometimes you can open a document successfully in draft mode when it will
not open in other views. Once you open the file, you may be able to recover
or repair the file.


To switch to draft mode in Word, use either of the following procedures:


  • On the View menu, click Normal. On the Tools menu, click Options, select
    the View tab, and select the Draft Font option.


    -or-
  • For Word 6.x and 7.x, run the following macro to turn off screen
    updating, open your damaged document, switch to draft mode, and then
    reactivate screen updating:

          Sub Main         ScreenUpdating 0         FileOpen .Name = "<path>\Filename.doc"   ' include the path and                                                  ' substitute your file                                                  ' name         ToolsOptionsView .DraftFont = 1         ScreenUpdating      End Sub
    NOTE: In this macro, substitute the name of your damaged document
    for the "Filename.doc" argument text.


    Using this macro may enable you to open documents that you cannot
    otherwise open due to damage that affects printer setup, page layout, or
    screen updates in Word. For example, if a general protection (GP) fault
    occurs in Word before the document is opened, you may be able to avoid
    the GP fault by opening the document using the above macro.


    WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT YOUR
    OWN RISK. Microsoft provides this macro code "as is" without warranty of
    any kind, either express or implied, including but not limited to the
    implied warranties of merchantability and/or fitness for a particular
    purpose.
Method 2: Insert the Document as a File in a New Document:


The final paragraph mark in a Word document contains information about the
document. If the document is damaged, you may be able to retrieve the text
of the document if you can omit this final paragraph mark.


To access a document but leave its final paragraph mark behind, use the
following steps:


  1. Create a new blank document.
  2. On the Insert menu, click File.
  3. In the Insert File dialog box, locate and select the damaged document,
    and click OK.
You may need to reapply some section formatting to the last section of the
document.


Method 3: Open the File by Linking to It:


This method works for Word 2.x and 7.x (not 6.x) For more information see
the note at the bottom of this method.


If the "Insert the Document as a File in a New Document" (Method 2) doesn't
work, try this method. This method allows you to access the document
without bringing over the final paragraph mark. In addition, when you
create a link, part of the header information is not read.


This method allows you to open the file if this part of the header or if
the final paragraph mark is in the damaged area of the document.


Use the following steps to link to a "good: file (a file that has not been
corrupted) and then change the link to point to the damaged file:


  1. Create a new document. In the new document, type "This is a Test."
    Save the document.
  2. Select the text and click Copy on the Edit menu.
  3. Click New on the File menu. In the new document, click Paste Special on
    the Edit menu.
  4. Select either Unformatted or Formatted text, and click Paste Link.
    Press OK.
  5. On the Edit menu, click Links.


    The Links dialog box is displayed.
  6. Select the file name of the first linked document and click Change
    Source (in Word 2.x, click Change Link).


    The Open dialog box appears and asks which document you want to change
    the link to.
  7. Select the document you can no longer open and click Open.
  8. Click OK in the Links dialog box (in Word 2.x, enter the path and
    file name).


    The data/text from the damaged Document will appear (provided there
    was any recoverable data/text).
  9. On the Edit menu, click Links, and click Break Links (Cancel Links in
    Word 2.x).
You can now reformat and save the recovered text.


NOTE: If you are using Word 6.x, try the following steps:


  1. Create a new document. In the new document, type This is a test.


    Save the document.
  2. Select the text and click Copy on the Edit menu.
  3. Press the right arrow on the keyboard to deselect the text.


    This will put your insertion point on the next line.
  4. On the Edit menu, click Paste Special.
  5. Select either Unformatted or Formatted text, and click Paste Link.

    Click OK.
  6. To display the field codes, press Alt+F9.


    The field code will resemble the following:
           {LINK Word.Document.6 "C:\\MYDOCS\\TEST.DOC" "DDE_LINK3" \a \r \*           MERGEFORMAT}
  7. Modify the path to the document in the field code to be the path to
    the corrupted document.
  8. Delete the "DDE_LINK#" from the field code (include the quotation
    marks).
  9. Position insertion point inside the LINK field.
  10. Press F9 to update the field.
  11. Press ALT+F9 to view the results of the field.
  12. To unlink the field and to convert the field to text, press
    CTRL+SHIFT+F9.
Method 4: Open the File in WordPad or Microsoft Write:


When you cannot open a damaged document in Word for Windows (usually
because of corruption in the file header), you can strip out the file
header and open the file as Text Only. When you strip the header
information, all formatting is lost. This method strips out the file header
information.


  1. Start Microsoft WordPad or Write. (In Windows 95 click Run on the Start
    menu, type WordPad, and click OK; in
    Windows 3.x, from Microsoft Windows Program Manager, click Run on the
    File menu, type write, and click OK).
  2. In WordPad or Write, open the corrupted document.


    A dialog box prompts you to specify how you want to convert the file.


    Click the No Conversion button.
  3. The Word for Windows document is now open as a text file. You may
    see binary (foreign) characters at the beginning and end of the
    document. Delete these characters.


    NOTE: In Windows 95, the file may be opened intact without further
    conversion or cleanup necessary. If this is the case, save the file
    with a new name and open the file in Word 6.x or later.
  4. On the File menu, click Save As. In the File Name box, type a new name
    with a .doc file name extension. Before you click the OK button, note
    the directory where the file is being saved so you can easily find it
    when you restart Word for Windows.
  5. On the File menu, click Exit.
  6. Restart Word for Windows and open the file you saved from WordPad or
    Write (the file will have the name you gave it in step 4). (On the
    File menu, click Open. In the File Name box, type the path and file
    name of the newly created file, and click OK.)
  7. In the Convert File dialog box, Text Only should be selected. Choose
    the OK button to open the text file in Word for Windows.
  8. On the File menu, click Save As, and save the file in Word format.


    NOTE: In Word for Windows version 2.x, select Word Document (*.doc) in
    the Save File As Type box. In Word for Windows version 1.x, choose the
    Options button and select Normal in the File Format box.
  9. In the File Name box, type a new name for the file, and
    click OK.
The file is now in Word for Windows format. You can reopen it and replace
any necessary graphics, fields, and formatting.


NOTE on Tables: Microsoft WordPad 1.0 can read and write Word 6/7 file
format, automatically converting the file and retaining such formatting as
WordPad itself supports. A Word 6 or 7 document that cannot be opened will
often open in WordPad. Tables will e converted to tab-delimited text but
will retain the basic tabular structure of the table; this is often the
only way to recover a corrupted table.


Method 5: Strip Out the File Header Information:


NOTE: This method works with MS-DOS versions 3.0 to 6.2 only.


Use this method only if all other methods fail. When you cannot open a
damaged document in Word for Windows (usually because of corruption in
the file header), you can strip out the file header and open the file as
Text Only. When you strip the header information, all formatting is lost.


  1. At an MS-DOS prompt, type the following, then press ENTER

    copy con+FILE NAME.DOC NEWNAME.DOC
    where "FILE NAME" is the name of the Damaged file, and "NEWNAME" is
    the name of the new file. (This causes the word "CON" to appear and
    the insertion point to blink on a blank line.)
  2. Press the SPACEBAR twelve times.
  3. Press F6, and then press ENTER.
  4. Start Word for Windows and open the new file.
  5. Delete the odd characters at the beginning and end of the file. The
    text of the file is usually intact in the middle of the file.
  6. Reformat the document and save it in Word for Windows format.


    NOTE: If the file was saved in Word for Windows with the Allow Fast
    Saves check box selected, the text may appear in noncontiguous blocks.
    The Fast Save feature keeps track of the changes that you make by
    appending the changes to the end of your document and remembering where
    these changes go. At regular intervals, Fast Save updates the document
    with these changes (this method is faster and takes less memory than
    saving the entire document). If your document becomes damaged before
    Fast Save has a chance to build a complete, updated copy of your
    document, you may need to re-order the text (move the appended text to
    its appropriate place in the document) and then reformat it.


    For information about how to turn off the Fast Save feature, please see
    the following article in the Microsoft Knowledge Base:
    71999 Disabling the Fast Save Feature in Word for Windows

REFERENCES

"Microsoft MS-DOS User's Guide and Reference," version 5.0, page 391
"Microsoft Word for Windows User's Guide," version 2.0, page 676
Propiedades

Id. de artículo: 187309 - Última revisión: 02/14/2017 - Revisión: 1

Microsoft Word 1.1 Standard Edition, Microsoft Word 1.1 Standard Edition, Microsoft Word 1.1 Standard Edition, Microsoft Word 1.1 Standard Edition, Microsoft Word 2.0 Standard Edition, Microsoft Word 2.0a, Microsoft Word 2.0a, Microsoft Word 2.0a, Microsoft Word 2.0a, Microsoft Word 2.0c, Microsoft Word 6.0 Standard Edition, Microsoft Word 6.0 Standard Edition, Microsoft Word 6.0a, Microsoft Word 6.0c, Microsoft Word 6.0 Standard Edition, Microsoft Word 6.0 Standard Edition, Microsoft Word 95a, Microsoft Word 95a, Microsoft Word 95a, Microsoft Word 95a

Comentarios