Síntomas
Imagine el siguiente escenario:
- Crear un montón de colecciones dinámicas en un servidor de sitio de System Center configuración Manager Service Pack 2 (SP2) utilizando las reglas basadas en la consulta. Por ejemplo, crear varios miles de estas colecciones.
- En la consola de Configuration Manager, hacer clic en Actualizar para ver los miembros más recientes en una colección dinámica.
Causa
Este problema se produce porque el evaluador de la colección mantiene una cola, primero en salir (FIFO) para controlar las solicitudes de evaluación de la colección.
Al hacer clic en Actualizar para ver la pertenencia de una colección más reciente, esta solicitud se coloca al final de una cola FIFO. Si el número de solicitudes anteriores es muy grande, el evaluador de la colección requiere mucho tiempo en completar las solicitudes anteriores. Por lo tanto, se produce un retraso largo antes de ver los resultados actualizados en la consola de Configuration Manager.
Al hacer clic en Actualizar para ver la pertenencia de una colección más reciente, esta solicitud se coloca al final de una cola FIFO. Si el número de solicitudes anteriores es muy grande, el evaluador de la colección requiere mucho tiempo en completar las solicitudes anteriores. Por lo tanto, se produce un retraso largo antes de ver los resultados actualizados en la consola de Configuration Manager.
Solución
Después de instalar este hotfix, evaluador de colección da prioridad a la cola para dar cualquier solicitud de la interfaz de usuario (IU) una prioridad alta. Por lo tanto, una solicitud de interfaz de usuario se controla de forma oportuna incluso si hay muchas solicitudes de back-end en la cola.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener instalado System Center Configuration Manager 2007 Service Pack 2 (SP2).Instrucciones de instalación
Nota: El paquete de hotfix siguiente puede instalarse en un servidor de sitio de System Center Configuration Manager 2007 Service Pack 2 que está ejecutando una versión basada en x86 de un sistema operativo o una versión basada en x64 de un sistema operativo:SCCM2007-SP2-KB982400-ENU.msi
Requisito de reinicio
No es necesario que reinicie el equipo después de aplicar este hotfix.Información de reemplazo de revisión
Esta revisión no sustituye a ninguna revisión publicada previamente.Información de archivo
La versión en inglés (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.Notas de información de archivo de System Center Configuration Manager 2007
Nombre del archivo | Versión del archivo | Tamaño de archivo | Fecha | Hora | Plataforma |
---|---|---|---|---|---|
Colleval.dll | 4.0.6487.2135 | 102,248 | 01-Feb-2010 | 11:50 | x86 |
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft