Se produce un error al cerrar oportunidades en Microsoft Dynamics CRM

Se aplica a: Dynamics CRM 4.0

Síntomas


Al cerrar una oportunidad en Microsoft Dynamics CRM, puede aparecer uno de los siguientes errores:

1. "se ha producido un error"

O

2. «autorización de usuario no válido"



Seguimiento con DevErrors puede mostrar lo siguiente:

Información de seguimiento de pila: [NullReferenceException: referencia a objeto no establecida a una instancia de un objeto.]
en Microsoft.Crm.Dialogs.CloseOppPage.ConfigureForm()
en Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender (EventArgs e)
en System.Web.UI.Control.PreRenderRecursiveInternal()
en System.Web.UI.Page.ProcessRequestMain (Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Causa


No se rellena el campo tema. Esto es un campo obligatorio para el cierre de la oportunidad.

Solución


Introducir datos en el campo Asunto de la oportunidad.

Compruebe si se ha rellenado el campo tema con los pasos siguientes:


En Microsoft Dynamics CRM 4.0:

1. Haga clic en configuración, haga clic en personalización, haga clic en Personalizar entidades

2. Abra la entidad oportunidad

3. Haga clic en atributos

4. en la columna nombre, buscar el nombre

5. Esto puede hacerse un campo obligatorio si este atributo se abre y se selecciona requerido de la lista desplegable de nivel de requisito por la empresa.