Recibir correo electrónico con formato incorrecto que liberación mensajes si utiliza una versión específica de 7 del archivo Microsoft.Navision.Mail.dll en Microsoft Dynamics NAV 2009

Se aplica a: Dynamics NAV 2009

En este artículo se aplica a Microsoft Dynamics NAV 2009 para todos los países y todas las configuraciones regionales.

Síntomas


Suponga que utilice una versión específica 7 del archivo Microsoft.Navision.Mail.dll en Microsoft Dynamics NAV 2009, como la generación de número que es mayor que 7.2 en Microsoft Dynamics NAV 2009. En esta situación, si los mensajes de correo electrónico contienen caracteres no ASCII, la funcionalidad de AppendBody no genera mensajes de correo electrónico correctamente. Por lo tanto, recibirá mensajes de correo electrónico con formato incorrecto. Este problema se produce en los siguientes productos:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1
  • Microsoft Dynamics NAV 2009

Causa


Este problema se produce debido a una codificación diferente para los mensajes de correo electrónico.

Solución


Información de la revisión

Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio Web de Microsoft:También puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft:

Asociados de negociosClientesEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos

Después de solicitar una revisión de Microsoft Dynamics NAV, se le enviará un hipervínculo en un mensaje de correo.


El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.


Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.


Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.


Si hace clic en Cancelar, se detiene el proceso de descarga.


Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización

Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos.

Información de archivo

La versión global de esta revisión tiene los atributos de archivo (o atributos de último archivo) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Microsoft.navision.mail.dll7.3.0.126,48001-Mar-201116:15x86
Microsoft.navision.mail.tlbNo aplicable3,64801-Mar-201109:53No aplicable
Para aplicar este hotfix, siga estos pasos:
  1. Copie los archivos que extrajo los archivos de la revisión a la carpeta siguiente:
    %ProgramFiles%\Common Files\Microsoft Dynamics NAV\Mail
  2. Registrar el ensamblado de Microsoft.Navision.Mail.dll de nuevo a través de la herramienta Registro de ensamblados (Regasm.exe) mediante el comando siguiente:
    regasm / codebase /tlb:Microsoft.Navision.Mail.tlb Microsoft.Navision.Mail.dll

    Por ejemplo, puede asegurarse de que el archivo Regasm.exe está en la carpeta de correo que se menciona en el paso 1, abra el símbolo del sistema, cambie el directorio a "C:\Program Files (x86) \Common NAV\Mail Dynamics" y, a continuación, ejecute el siguiente comando para registrar el ensamblado de Microsoft.Navision.Mail.dll:
    RegAsm.exe /codebase /tlb:Microsoft.Navision.Mail.tlb Microsoft.Navision.Mail.dll

Requisitos previos

Debe tener uno de los siguientes productos instalados para aplicar esta revisión:
  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1

Estado


Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

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