Cómo utilizar el Bloc de notas de XML para crear un documento XML


Resumen


El Bloc de notas XML de Microsoft es una aplicación que le permite crear y editar documentos XML de forma rápida y sencilla. Con esta herramienta, la estructura de los datos XML se muestra gráficamente en una estructura de árbol. La interfaz presenta dos paneles: uno para la estructura y otro para los valores. Puede agregar elementos, atributos, comentarios y texto al documento XML mediante la creación de la estructura de árbol en el panel izquierdo e introduzca los valores en los cuadros de texto correspondientes del panel derecho.

Más información


Para crear un documento XML con el Bloc de notas XML, siga estos pasos:
  1. Para abrir el Bloc de notas de XML, haga clic en Inicio, seleccione programas, seleccione Microsoft XML Notepad y, a continuación, haga clic en Bloc de notas de Microsoft XML. La interfaz muestra dos paneles. El panel Estructura de la izquierda presenta el principio de una estructura de árbol XML, con un Root_Element y Child_Element ya creado. Cuadros de texto vacíos en el panel de valores aceptan valores correspondientes.
  2. Cambiar Root_Element para catálogo y Child_Element al libro y agregar un atributo y tres elementos secundarios al elemento secundario Book. Nota: al insertar los siguientes valores, no incluya apóstrofos. El Bloc de notas XML inserta automáticamente como el documento XML requiere.


    1. Para insertar un atributo para el libro, haga clic en libro, elija Insertary haga clic en el atributo. Junto al icono de cubo, escriba ID. Para insertar un valor para este atributo, resalte ID y escriba Bk101 en el cuadro de texto correspondiente en el panel de valores.
    2. Para insertar un elemento secundario para el libro, haga clic en el icono de carpeta junto al libro, elija Insertary haga clic en el Elemento secundario. Aparecerá un icono de hoja. Escriba autor al lado de este icono y escriba Gambardella, Matthew en el cuadro de texto correspondiente en el panel de valores.
    3. Agregar dos elementos secundarios más: título y género. Escriba la Guía del desarrollador de XML y
      Cuadros de equipo en el texto correspondiente en el panel de valores.
  3. Para agregar otro elemento secundario de libro al nodo raíz, haga clic en un elemento de libro existente y haga clic en Duplicar. Rellene los valores según sea necesario.
  4. Para agregar texto a los elementos existentes, resalte el nodo para el que desea agregar un nodo de texto. En el menú Insertar , haga clic en texto.
  5. Para agregar comentarios a los elementos existentes, resalte el nodo tras el cual o en que desea insertar el comentario. En el menú Insertar , haga clic en comentario. Si se expande el nodo resaltado, el comentario se inserta en el nodo resaltado. Si el nodo resaltado está contraído, el comentario se inserta después del nodo resaltado.
  6. Para cambiar el tipo de un nodo, resalte el nodo que desee cambiar. En el menú Herramientas , elija Cambiar a y haga clic en el tipo adecuado.

    Nota: no se puede cambiar el tipo del nodo raíz o de nodos con elementos secundarios.
  7. Para ver el XML de origen del documento, en el menú Ver , haga clic en Origen. El resultado de ejemplo es similar a la siguiente:
    <catalog>
    <book id="bk101">
    <author>Gambardella, Matthew</author>
    <title>XML Developer's Guide</title>
    <genre>Computer</genre>
    text1
    </book>
    <!--Comment1-->
    <book id="bk102">
    <!--Comment2-->
    <author>Ralls, Kim</author>
    <title>Midnight Rain</title>
    <genre>Fantasy</genre>
    </book>
    </catalog>
    Tenga en cuenta el siguiente mensaje en la parte inferior de la ventana de la vista:

    The current XML definition is well formed.
    Además, observe que las instrucciones de declaración o de procesamiento de XML deben agregarse a un editor externo, como el Bloc de notas.

  8. Para guardar el documento XML, en el menú archivo , haga clic en Guardar. Para salir del Bloc de notas XML, en el menú archivo , haga clic en Salir.

Referencias


Para obtener más información, consulte los siguientes sitios Web:
Microsoft Online XML Developer Center
http://msdn.microsoft.com/xml

World Wide Web Consortium
http://www.w3.org