Cómo: Crear una consulta de tabla de referencias cruzadas de Microsoft Access 2000

Principiante: Se requieren conocimientos de la interfaz de usuario en equipos de usuario único.


En este artículo sólo se aplica a una base de datos de Microsoft Access (.mdb).


Para obtener una versión de Microsoft Access 2002 de este artículo, consulte 304349 .

EN ESTA TAREA

Resumen

Mediante consultas de tabla de referencias cruzadas, puede crear vistas de resumen de los datos para facilitar su análisis. En este artículo se muestra cómo crear una consulta de tabla de referencias cruzadas de Microsoft Access con y sin utilizar a un asistente.

Precaución: Si sigue los pasos de este ejemplo, modificará la base de datos de ejemplo Neptuno.mdb. Puede que desee hacer copia de seguridad del archivo Neptuno.mdb y seguir estos pasos en una copia de la base de datos.

Crear una consulta de tabla de referencias cruzadas mediante el Asistente para consultas de referencias cruzadas

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Neptuno.mdb.
  2. En el menú Ver , seleccione Objetos de base de datosy, a continuación, haga clic en consultas.
  3. En el menú Insertar , haga clic en consulta.
  4. En el cuadro de diálogo Nueva consulta , haga clic en Asistente para consultas de referencias cruzadasy, a continuación, haga clic en Aceptar.
  5. En la primera página del Asistente para la consulta de tabla de referencias cruzadas, haga clic en pedidos de la lista de tablas y, a continuación, haga clic en siguiente.
  6. Haga doble clic en EmployeeID de la lista de Campos disponibles para agregarlo a la lista de Campos seleccionadosy, a continuación, haga clic en siguiente. Esto crea una consulta con un registro por empleado.
  7. Haga clic en OrderDate en la lista de campos y, a continuación, haga clic en siguiente.
  8. Haga clic en año para el intervalo de fechas y, a continuación, haga clic en siguiente. Esto crea una consulta con una columna por año para las fechas de pedido.
  9. Haga clic en OrderID en la lista de campos, haga clic en contar en la lista de funcionesy, a continuación, haga clic en siguiente.
  10. En la última página del asistente, haga clic en Finalizar . Tenga en cuenta que se crea una consulta que muestra un recuento de pedidos por empleado por año.

Crear una consulta de tabla de referencias cruzadas sin utilizar un asistente

  1. Inicie Microsoft Access y, a continuación, abra la base de datos de ejemplo Neptuno.mdb.
  2. En el menú Ver , seleccione Objetos de base de datosy, a continuación, haga clic en consultas.
  3. En el menú Insertar , haga clic en consulta.
  4. En el cuadro de diálogo Nueva consulta , haga clic en Vista Diseñoy, a continuación, haga clic en Aceptar.
  5. En el cuadro de diálogo Mostrar tabla , haga clic en la tabla pedidos , haga clic en Agregary, a continuación, haga clic en Cerrar.
  6. En la lista de campos de la tabla pedidos en la mitad superior de la cuadrícula de diseño de la consulta, haga doble clic en los siguientes campos para agregarlos a la cuadrícula de diseño de consulta: PaísDestinatario, CiudadDestinatario, FormaEnvíoy transporte.
  7. En el menú consulta , haga clic en Consulta de referencias cruzadas. Observe que se agrega una fila a la cuadrícula de diseño de consulta con el nombre de tabla de referencias cruzadas.
  8. Haga clic en la celda de la fila tabla de referencias cruzadas en la columna PaísDeEnvío , haga clic en la flecha que aparece y, a continuación, haga clic en Encabezado de fila.
  9. Haga clic en la celda de la fila tabla de referencias cruzadas en la columna CiudadDestinatario , haga clic en la flecha que aparece y, a continuación, haga clic en Encabezado de fila.
  10. Haga clic en la celda de la fila tabla de referencias cruzadas en la columna de forma de envío , haga clic en la flecha que aparece y, a continuación, haga clic en el Encabezado de columna.
  11. Haga clic en la celda de la fila tabla de referencias cruzadas en la columna transporte , haga clic en la flecha que aparece y, a continuación, haga clic en valor. Tenga en cuenta que sólo un campo puede establecerse a valor.
  12. Haga clic en la celda de la fila Total bajo la columna transporte , haga clic en la flecha que aparece y, a continuación, haga clic en suma.
  13. En el menú consulta , haga clic en Ejecutar para ver los resultados de la consulta de tabla de referencias cruzadas.



Referencias

Para obtener más información acerca de cómo crear consultas de referencias cruzadas, haga clic en Ayuda de Microsoft Access en el
Menú Ayuda , escriba crear una consulta de tabla de referencias cruzadas en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver los temas devueltos.

También puede ver esta información del World Wide Web, haga clic en el tema "Trabajar con consultas" en la página de Ayuda de Microsoft Access 2000 en el siguiente sitio Web de Microsoft:

Para obtener información adicional acerca de cómo crear consultas de referencias cruzadas con varios campos de valor, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

209143 ACC2000: crear una consulta de tabla de referencias cruzadas con varios campos de valor
Para obtener información adicional acerca de cómo crear consultas de selección, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

304361 ACC2000: cómo crear una consulta Select en Microsoft Access
Para obtener información adicional acerca de cómo crear consultas de parámetros, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

304353 ACC2000: cómo crear una consulta de parámetros en Microsoft Access
Para obtener información adicional acerca de cómo convertir una consulta de selección en una consulta de acción, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

304355 ACC2000: cómo convertir una consulta de selección en una consulta de acción
Para obtener información adicional acerca de cómo modificar las propiedades de la consulta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

304357 ACC2000: cómo modificar propiedades de consulta en Microsoft Access
Para descargar una base de datos de Microsoft Access de ejemplo que contiene más de 20 ejemplos de consulta, incluyendo las técnicas descritas en estos artículos, consulte el artículo siguiente en Microsoft Knowledge Base:


207626 access 2000 consultas de ejemplo disponible en el centro de descarga











Propiedades

Id. de artículo: 304348 - Última revisión: 22 ene. 2017 - Revisión: 1

Comentarios