Cómo reducir el tamaño de un archivo de dibujo de Visio en Visio

Para obtener una versión de este artículo para Microsoft Visio 2000, vea
255020 .

Resumen

El artículo contiene información acerca de los métodos que puede usar para reducir el tamaño de archivos de dibujo de Microsoft Visio en Microsoft Office Visio 2007, Microsoft Office Visio 2003 y Microsoft Visio 2002.

INTRODUCCIÓN

Si crea dibujos grandes (archivos .vsd) en Visio, quizás quiera reducir el tamaño de los archivos. El artículo describe los métodos siguientes que puede usar para reducir el tamaño de un archivo .vsd:
  • Quitar las formas no utilizadas de la galería de símbolos local.
  • Configurar Visio para guardar el dibujo sin una vista previa.
  • Reducir el número de formas agrupadas.
  • Convertir las formas duplicadas a una sola forma de patrón.
  • No guardar su diagrama como un dibujo XML para Visio.
Importante: antes de probar cualquiera de los métodos que se analizan en este artículo, le recomendamos que cree una copia de seguridad de su dibujo de Visio.

Quitar las formas no utilizadas desde la galería de símbolos local

La galería de símbolos local almacena formas patrón, incluye formas que eliminó de la página de dibujo. Una forma de patrón no usada puede usar espacio en disco innecesario. Puede reducir el tamaño de su dibujo quitando estas formas de patrón de la galería de símbolos local. Para ello, utilice uno de los métodos siguientes.

Método 1: Descargar y ejecutar la herramienta CleanIt

El siguiente archivo se puede descargar desde el Centro de descarga de Microsoft:
Para obtener más información acerca de cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591 Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft examinó este archivo en busca de virus con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que impiden la realización de cambios no autorizados.

Nota: los Servicios de soporte técnico de Microsoft (PSS) no proporcionan soporte técnico a esta herramienta.

Método 2: Eliminar formas de patrón no utilizadas

  1. Abra el dibujo de Visio, haga clic en
    Formas en el menú Archivo y, a continuación, haga clic en Mostrar galería de símbolos del documento.
  2. Elimine las formas de patrón que la galería de símbolos local no está utilizando.

    Visio le advierte si cualquier forma de patrón está siendo usada por su dibujo. Si recibe esta advertencia, haga clic en Cancelar.
  3. Haga clic en Cerrar para cerrar la galería de símbolos.
  4. Guarde su dibujo.
El tamaño del archivo de dibujo se reduce.

Dividir un dibujo de varias páginas en dibujos independientes

Si tiene que reducir el tamaño del archivo de un dibujo de varias páginas para transferirlo electrónicamente, o si tiene que guardar el dibujo en un disquete, considere la posibilidad de guardar cada página del dibujo de Visio en un dibujo independiente. Use el comando Guardar como para dividir el dibujo de varias páginas en varios archivos. Para ello, siga estos pasos:
  1. Abra el dibujo de Visio.
  2. En el menú Archivo, haga clic en
    Guardar como, escriba un nombre de archivo nuevo y haga clic en Aceptar.

    Por ejemplo, escriba
    nombreArchivo_páginaX.vsd, donde nombreArchivo es el nombre del documento y
    páginaX es el número de la página.
  3. Repita el paso 2 por cada página de su dibujo.

    Por ejemplo, guarde la página 1 como
    nombreArchivo_página1.vsd y guarde la página 2 como
    nombreArchivo_página2.vsd.
  4. Por cada nuevo archivo de dibujo de Visio, elimine las otras páginas que no corresponden con el nombre del archivo. Haga clic con el botón secundario en la ficha Página para la página que quiere eliminar y, después, haga clic en Eliminar página.

    Por ejemplo, si su dibujo tiene cuatro páginas y abre el archivo nombreArchivo_página2.vsd file, elimine las páginas 1, 3 y 4.
  5. En el menú Archivo, haga clic en
    Guardar y repita estos pasos por cada dibujo.
Ya tiene archivos de Visio independientes por cada página de su dibujo.

Configurar Visio para guardar el dibujo sin una vista previa

Puede reducir el tamaño del archivo si configura Visio para guardar el dibujo sin una vista previa. Para ello, siga estos pasos:
  1. En el menú Archivo, haga clic en
    Propiedades.
  2. En el cuadro de diálogo Propiedades, haga clic en la ficha Resumen.
  3. Desactive la casilla Guardar vista previay haga clic en Aceptar.

Reducir el número de formas agrupadas

Si el diagrama de Visio incluye muchas formas agrupadas, el diagrama puede ser muy grande y complejo. Reducir el número de los niveles de agrupamiento puede ayudar a reducir el tamaño y la complejidad de sus archivos. Para reducir los niveles de agrupamiento, siga estos pasos:
  • Use los comandos que se muestran en el submenú
    Operaciones, como el comando Combinar.
  • Convertir la forma agrupada en un metarchivo de Microsoft Windows (WMF).
Para convertir la forma agrupada en un metarchivo de Microsoft Windows (WMF):
  1. En el menú Edición, haga clic en
    Copiar.
  2. En el menú Edición, haga clic en
    Pegado especial. Aparece el cuadro de diálogo Pegado especial.
  3. Haga clic en Imagen y, después, en
    Aceptar.

Convertir las formas duplicadas a una sola forma de patrón.

Si creó formas en su dibujo de Visio, considere la conversión de las formas duplicadas en patrones. Cuando cree una forma de patrón, Visio la almacena en la galería de símbolos local del dibujo. Cuando arrastra una forma a una galería de símbolos, un icono de la forma de patrón basado en la forma aparece en la ventana de la galería de símbolos.

Por ejemplo, en lugar de su dibujo conteniendo 20 copias de una forma, el dibujo puede contener una sola copia de la forma. Es decir, el dibujo puede contener una forma de patrón y las instancias de la forma de patrón como referencias. Las referencias usan menos espacio en disco que las copias duplicadas de la forma.

Para convertir una forma en un patrón, siga estos pasos:
  1. En la ventana Dibujo, muestre la forma que quiere convertir en un patrón o dibuje la forma que quiere convertir.
  2. En el menú Archivo, haga clic en
    Abrir y seleccione el archivo de galería de símbolos (.vss file) donde quiere almacenar el nuevo patrón.
  3. Haga clic en Original o en
    Copia y después haga clic en
    Abrir.
  4. Haga clic en la página del dibujo para activarla y, después, arrastre la forma desde la página de dibujo y colóquela en la galería de símbolos. Puede crear una copia de la forma si mantiene presionada la tecla CTRL mientras arrastra.

    El icono de la forma aparece con una etiqueta "Patrón.X", donde
    X representa el número de formas de la galería de símbolos.
  5. Haga clic en la galería de símbolos para activarla. En el menú Archivo, haga clic en Guardar para guardar los cambios hechos en la galería de símbolos.

No guardar su diagrama como un dibujo XML (archivo .vdx)

Visio le permite guardar su dibujo en formato XML. Cuando guarda un dibujo como un archivo .vdx, el tamaño del archivo se incrementa un 1.000 por cien. Por ejemplo, un dibujo de 500 kilobytes (KB) se incrementa a casi 5 megabytes (MB) cuando se guarda como un dibujo XML. El incremento se debe a que los archivos .vdx son, en términos estrictos, archivos de texto.

Para obtener más información acerca del formato XML para Visio, visite el siguiente sitio web de Microsoft:

Referencias

Para obtener más información acerca de cómo combinar o cómo crear las formas, haga clic en Ayuda de Microsoft Office Visio en el menú Ayuda, escriba
formas en el Ayudante de Office o el Asistente para ayuda y, a continuación, haga clic en Buscar para ver los temas que se encuentran.

Para obtener más información acerca del formato XML para Visio, haga clic en
Ayuda de Microsoft Office Visio en el menú
Ayuda, escriba XML en el Ayudante de Office o el Asistente para ayuda, y después haga clic en
Buscar para ver los temas que se encuentran.
Propiedades

Id. de artículo: 305025 - Última revisión: 11 ago. 2008 - Revisión: 1

Comentarios