Mensaje de error en varias ubicaciones en Microsoft Dynamics SL: "Mensaje de sistema 5045"


Síntomas


Considere los escenarios siguientes en diversas ubicaciones de Microsoft Dynamics SL.
  • Intenta iniciar sesión en Microsoft Dynamics SL. Vea las causas 1, 2 o 3.
  • O bien, realizar cualquier acción que crea un registro de eventos de Microsoft Dynamics SL. Ver todas las causas.
  • O bien, haga clic en Inicio en la pantalla Comprobar integridad de base de datos física (95.500.00) . Ver la causa 5.
En estas situaciones, recibirá el siguiente mensaje de error:

Mensaje de sistema 5045 - error de archivo al intentar abrir el archivo de estado de proceso

Causa


Causa 1:

El identificador de usuario de Windows no tiene permisos suficientes para la operación. Vea la solución 1.

Causa 2:

La unidad lógica asignada a la instalación de Microsoft Dynamics SL es incorrecta. Vea la solución 2.

Causa 3:

Está dañado el archivo Solomon.ini en la estación de trabajo. Vea la solución 3.

Causa 4:

Los archivos de registro de sucesos están dañados. Vea la solución 4.

Causa 5:

La tabla PSTATUS está dañada. Vea la solución 5.

Solución


Solución 1:

Asigne los permisos apropiados a los usuarios de Microsoft Dynamics SL.
  1. Póngase en contacto con el Administrador de red para comprobar que el ID de usuario de Windows tiene permisos suficientes.
  2. Asegúrese de que todos los usuarios de Microsoft Dynamics SL tienen control total sobre el directorio de instalación de Microsoft Dynamics SL. La ubicación predeterminada de la instalación es la siguiente:
    • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \Program Files\Microsoft Dynamics\SL\Applications
    • Microsoft Dynamics SL 6.5 y versiones anteriores: letraDeUnidad: \Program Files\Solomon\

Solución 2:

Compartir y asignar la unidad al correctamente. La ubicación predeterminada de la instalación de Microsoft Dynamics SL es el siguiente:
  • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \Program Files\Microsoft Dynamics\SL\Applications
  • Microsoft Dynamics SL 6.5 y versiones anteriores: letraDeUnidad: \Program Files\Solomon
En este caso, las unidades desde estaciones de trabajo deben asignarse a la raíz del volumen o a una de las siguientes ubicaciones, dependiendo de la versión:
  • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \Program Files\Microsoft Dynamics SL\
  • Microsoft Dynamics SL 6.5 y versiones anteriores: letraDeUnidad: \Program Files\
Esto significa que debe ser compartida la raíz del volumen o una de las ubicaciones que se han explicado. Desde los equipos de estación de trabajo, las propiedades de icono para el programa principal deben ser:
  • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \SL\Applications\MSDynamicsSL.exe o DriveLetter:\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 o versiones anteriores: letraDeUnidad: \Program Files\Solomon\Parent.exe o DriveLetter:\Solomon\Parent.exe
Nota: Las propiedades del icono no deben ser una de las siguientes ubicaciones (que indica la raíz de un mapa):
  • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 y versiones anteriores: letraDeUnidad: \Parent.exe
Las propiedades del icono no deben ser una de las siguientes ubicaciones (lo que indica una ruta de acceso UNC):
  • Microsoft Dynamics SL 7.0 y versiones posteriores: \\Servername\nombre de recurso compartido\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 y versiones anteriores: \\Servername\nombre de recurso compartido\Solomon\Parent.exe
No se admiten rutas de acceso UNC en Microsoft Dynamics SL o Microsoft Business Solutions-Solomon.

Resolución 3:

Cambie el nombre de todos los archivos en el equipo de la estación de trabajo Solomon.ini a Solomon.old. Para obtener más información acerca de cómo cambiar el nombre del archivo Solomon.ini, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Solución de problemas de 2005087 dónde encontrar el archivo Solomon.ini en Microsoft Dynamics SL


Resolución 4:

Elimine todos los archivos de registro de eventos en las siguientes ubicaciones:
  • Microsoft Dynamics SL 7.0 y versiones posteriores: letraDeUnidad: \Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
  • Microsoft Dynamics SL 6.5 y versiones anteriores: letraDeUnidad: \Program Files\Solomon\Eventlog\

Resolución 5:

Elimine los registros dañados en la tabla PSTATUS.

Nota: Antes de seguir las instrucciones de este artículo, asegúrese de que tiene una copia de seguridad completa de la base de datos que pueda restaurar si surge algún problema.
Con SQL Server Management Studio o el analizador de consultas SQL, ejecute la instrucción siguiente contra la base de datos de la aplicación Microsoft Dynamics SL o Microsoft Business Solutions – base de datos de aplicación de Solomon:
Delete from PSTATUS