Los movimientos asociados para una orden de producción terminada no se crean después de que un usuario cambia el estado de una orden de producción lanzada a terminada en Microsoft Dynamics NAV 4.0


En este artículo se aplica a Microsoft Dynamics NAV para todas las regiones.

Síntomas


Imagine el siguiente escenario:
  • Instalar Microsoft Dynamics NAV 4.0 Service Pack 1 o Service Pack 2 de Microsoft Dynamics NAV 4.0.
  • Utilice Microsoft SQL Server 2005.
  • Un usuario de Microsoft Dynamics NAV 4.0 es un miembro de la función de base de datos SQL PUBLIC sólo la base de datos de Microsoft Dynamics NAV 4.0.
En esta situación, este usuario puede cambiar el estado de una orden de producción lanzada a terminada. Sin embargo, no se crean los movimientos asociados a la orden de producción terminada.

Causa


Este problema se produce porque la función Countapprox C/AL no devuelve el número correcto de registros de salida en la función Cambiar estado . La función Countapprox C/AL no devuelve el número correcto de registros de salida porque se conceden los permisos de SQL Server incorrectos al usuario en SQL Server 2005.

Nota: Este problema se produce si se cumple alguna de las condiciones siguientes:
  • El usuario de Microsoft Dynamics NAV 4.0 es miembro de la función de base de datos SQL db_owner para la base de datos de Microsoft Dynamics NAV 4.0.
  • Utilice Microsoft SQL Server 2000 en lugar de SQL Server 2005.

Solución


Información de la revisión

Ahora hay una revisión compatible de Microsoft, pero sólo se diseñó para corregir el problema que se describe en este artículo. Sólo se aplica a sistemas que experimenten este problema específico.

Para resolver este problema inmediatamente, póngase en contacto con Microsoft Business Solutions soporte técnico para obtener la revisión. Puede iniciar sesión en el sitio de soporte técnico de Microsoft Business Solutions y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:También puede ponerse en contacto con soporte técnico de Microsoft Business Solutions llamando por teléfono al (888) 477-7877.

Nota: En casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Business Solutions de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha zona horaria en el elemento de fecha y hora del Panel de Control.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Fin.exe4.0.2.229797,945,08813 de julio de 200611:11x86
Finsql.exe4.0.2.229797,994,24013 de julio de 200611:11x86
Nas.exe4.0.2.229791,403,77613 de julio de 200611:11x86
Nassql.exe4.0.2.229791,452,92813 de julio de 200611:11x86
Ndbcs.dll4.0.2.229791,067,90413 de julio de 200611:11x86

Requisitos previos

Debe tener Microsoft Dynamics NAV 4.0 con Service Pack 2 instalado para aplicar esta revisión.

Instrucciones de instalación

Instale la revisión en todos los equipos cliente que ejecutan Microsoft Dynamics NAV 4.0.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft