El servicio de Host de agente de SMS no se inicia después de reiniciar un equipo cliente de Systems Management Server 2003


Importante: Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de hacer copia de seguridad del registro antes de modificarlo. Asegúrese de que sabe cómo restaurarlo si ocurre algún problema. Para obtener más información acerca de cómo hacer copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

Síntomas


Después de reiniciar un equipo cliente de Microsoft Systems Management Server (SMS) 2003, el servicio de Host de agente de SMS (Ccmexec.exe) no se inicia. Cuando se produce este problema, pueden aparecer las entradas de error similares a los siguientes en el archivo CCMExec.log en el equipo cliente SMS:

Entrada del archivo CCMExec.log 1
Iniciar CCMEXEC servicio... $$ < CcmExec >< 8:13:13.819 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Ejecutando en el equipo nombreDeEquipo como usuario del sistema.
$$ < CcmExec >< 8:13:13.859 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
ERROR!! WBEM no se encuentra en la ruta del sistema. $$ < CcmExec >< 8:13:13.859 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
WBEM se agregó correctamente a la variable de entorno PATH de proceso. $$ < CcmExec >< 8:13:13.859 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Al inicializar COM. $$ < CcmExec >< 8:13:13.859 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Registrar para registrar las notificaciones de cambios. $$ < CcmExec >< 8:13:13.869 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Componente de registro predeterminado para el proceso de configuración. $$ < CcmExec >< 8:13:13.869 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Si estado del servicio en ejecución. $$ < CcmExec >< 8:13:13.869 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Comprobando si se necesita reparar. $$ < CcmExec >< 8:13:13.889 viernes 13 de febrero hora estándar Central 2004 >< subproceso = 1216 (0x4C0) >
Error al abrir el espacio de nombres '\\.\root\ccm' (80004002) $$ < CcmExec >< 8:13:17.224 viernes 13 de febrero hora estándar Central 2004 >< de WMI subproceso = 1216 (0x4C0) >
Entrada del archivo CCMExec.log 2
25/1/2006 9:16:35 PMFailed para abrir el espacio de nombres de WMI '\\.\root\ccm' (8004100a)
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance error (0x8004100a).
25/1/2006 9:16:35 PMFailed para abrir el espacio de nombres de WMI '\\.\root\CCM\Events' (8004100a)
25/1/2006 9:16:35 PMCCMDoCertificateMaintenance() provoca el evento de estado de CCM_ServiceHost_CertificateOperationsFailure.
25/1/2006 9:16:35 PMLoading configuración del servicio.
25/1/2006 9:16:35 PMFailed para abrir el espacio de nombres de WMI '\\.\root\ccm\Policy\Machine' (8004100a)
25/1/2006 9:16:35 PMError cargar la configuración del servicio. Código 0x8004100a
25/1/2006 9:16:35 (0x8004100a) error en la inicialización de PMPhase 0.
25/1/2006 9:16:35 (0x8004100a) error en la inicialización de PMService.
25/1/2006 9:16:35 PMShutting hacia abajo AdditonallyCCMEXEC...
Además, el archivo Wbemcore.log puede contener una entrada de error similar al siguiente:
(13 de febrero del viernes 08:13:13 2004.69289): entrada de registro indica una instalación se está ejecutando
(13 de febrero del viernes 08:14:13 2004.129856): construcción CFactory
(13 de febrero del viernes 08:14:13 2004.129886): CFactory destruct
(13 de febrero del viernes 08:14:13 2004.129896): WINMGMT_ACTIVE crear mutex
(13 de febrero del viernes 08:14:13 2004.129946): leer la información de configuración de registro
(13 de febrero del viernes 08:14:16 2004.132800): preparar una solicitud de init de espacio de nombres para el espacio de nombres activo //./ROOT/ccm/policy
(13 de febrero del viernes 08:14:16 2004.132901): preparar una solicitud de init de espacio de nombres para el espacio de nombres activo //./root/CIMV2
(13 de febrero del viernes 08:14:16 2004.132961): preparar una solicitud de init de espacio de nombres para el espacio de nombres activo //./root/subscription
(13 de febrero del viernes 08:14:16 2004.133021): inicializar el espacio de nombres //./ROOT/ccm/policy
(13 de febrero del viernes 08:14:16 2004.133041): inicializar el espacio de nombres //./root

Causa


Este problema se produce cuando uno o ambas de las condiciones siguientes son verdaderas:
  • La variable de ruta de acceso %SystemRoot%\System32\Wbem no aparece en la ruta del sistema en el equipo cliente.
  • El tipo de la entrada de registro de la ruta de acceso es incorrecto en el equipo cliente SMS.
El problema también puede producirse cuando el servicio Instrumental de administración de Windows (WMI) no se inicia de forma oportuna.

Solución


Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: Asegúrese de que la variable %SystemRoot%\System32\Wbem aparece en la ruta del sistema en el equipo cliente

  1. Haga clic en Inicio, haga clic en Ejecutar, escriba sysdm.cpl y, a continuación, haga clic en Aceptar.
  2. Haga clic en la ficha Opciones avanzadas y, a continuación, haga clic en Variables de entorno.
  3. En variables del sistema, haga clic en rutay, a continuación, haga clic en Editar.
  4. Asegúrese de que ese %SystemRoot%\System32\Wbem aparece en el cuadro valor de Variable . Si no aparece este valor, debe agregarlo. Para ello, siga estos pasos:
    1. En el cuadro de diálogo Modificar la Variable del sistema , haga clic en después del final del texto en el cuadro valor de la Variable y, a continuación, escriba lo siguiente:
      ;%SystemRoot%\System32\Wbem
    2. Haga clic en Aceptar tres veces para guardar los cambios.

Método 2: Defina el tipo de la entrada de ruta de acceso del Registro REG_EXPAND_SZ

Advertencia: pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o mediante cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar que estos problemas puedan resolverse. Modifique el registro bajo su propio riesgo.
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. En el Editor del registro, busque y, a continuación, haga clic en la subclave del registro siguiente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
  3. Asegúrese de que el tipo de la entrada de ruta es REG_EXPAND_SZ y no REG_SZ. Si el tipo de esta entrada es REG_SZ, debe copiar la información de ruta de acceso, elimine la entrada de la ruta de acceso existente y, a continuación, cree una nueva entrada de tipo REG_EXPAND_SZ. Para ello, siga estos pasos:
    1. En el Editor del registro, haga doble clic en el valor de ruta de acceso .
    2. Haga clic en el texto en el cuadro información del valor , haga clic en Copiary, a continuación, haga clic en Cancelar.
    3. Pegue el texto en un documento de Bloc de notas.
    4. En el Editor del registro, haga clic en rutay, a continuación, haga clic en Eliminar.
    5. En la barra de menús, haga clic en Edición, seleccione nuevoy, a continuación, haga clic en Valor de cadena expandible.
    6. Escriba la ruta de accesoy, a continuación, presione ENTRAR.
    7. Haga doble clic en la ruta de acceso.
    8. Haga clic en el cuadro información del valor , haga clic en Pegary, a continuación, haga clic en Aceptar.
    9. Salga del Editor del Registro.

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

886137 se registra el identificador de suceso 10003 y no puede utilizar instalación de software cliente para instalar un cliente avanzado de SMS 2003

Referencias


Para obtener más información acerca de solucionar problemas de instalación de inserción de cliente avanzado, consulte el artículo siguiente en Microsoft Knowledge Base:

928282 cómo solucionar problemas de cliente Push instalación temas avanzados en Systems Management Server 2003 y System Center Configuration Manager 2007