Recibe mensajes de error de tiempo de ejecución de C++ cuando se ejecutan informes clásicos desde el cliente adaptado a roles (RTC) de Microsoft Dynamics NAV 2009

Se aplica a: Dynamics NAV 2009

En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.

Síntomas


Al ejecutar varios informes clásicos que no tienen un diseño especificado desde el cliente adaptado a roles (RTC) de Microsoft Dynamics NAV 2009, recibirá el siguiente mensaje de error varias veces:
Microsoft Visual C++ Runtime Library


---------------------------


¡Error en tiempo de ejecución!
Programa: C:...


Esta aplicación solicitó la finalización de una manera inusual el tiempo de ejecución.


Póngase en contacto con el equipo de soporte de la aplicación para obtener más información.

Causa


Este problema se produce porque Microsoft Dynamics NAV se inicia a un cliente clásico para la duración del informe al ejecutar varios informes clásicos. Cuando finalice el informe y se cierra el cliente clásico, Microsoft Dynamics NAV actualiza el archivo NaviBP.xml existente que se utiliza para almacenar los puntos de interrupción. Si ejecutan varias instancias de cliente clásico en resumen sucesión, cada instancia bloquea la otra instancia de actualizar el archivo NaviBP.xml. Por lo tanto, recibe muchos mensajes de error de tiempo de ejecución de C++. Aunque la NaviBP.xml la actualización es útil cuando el cliente clásico se inicia normalmente, en este caso, cliente clásico sólo se inicia para ejecutar un informe. Por lo que no deben actualizarse este archivo NaviBP.xml.

Solución


Información de la revisión

Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:También puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft:

Asociados de negociosClientesEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.



Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos

Después de solicitar una revisión de Microsoft Dynamics NAV, se le enviará un hipervínculo en un mensaje de correo.


El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.


Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.


Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.


Si hace clic en Cancelar, se detiene el proceso de descarga.



Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización

Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos. Para ello, siga estos pasos:
Nota: Después de aplicar este hotfix, cuando se inicia el cliente clásico sólo para imprimir un informe clásico, Microsoft Dynamics NAV no intentará actualizar el archivo NaviBP.xml cuando se cierra el cliente clásico.

Paso 1: Reemplazar los archivos de la instalación de cliente de Microsoft Dynamics NAV Classic

En la instalación de cliente de Microsoft Dynamics NAV Classic, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Dbm.dll6.0.31361.0427,84818-Jul-201015:24x86
Fin.exe6.0.31361.012,630,85618-Jul-201015:29x86
Finhlink.exe6.0.31361.0452,43218-Jul-201015:29x86
Finsql.exe6.0.31361.012,753,23218-Jul-201015:29x86
Nc_netb.dll6.0.31361.096,59218-Jul-201015:24x86
Nc_tcp.dll6.0.31361.098,64018-Jul-201015:24x86
Nc_tcps.dll6.0.31361.0141,13618-Jul-201015:24x86
Ndbcs.dll6.0.31361.01,350,48018-Jul-201015:24x86
Slave.exe6.0.31361.0152,40018-Jul-201015:24x86
Para reemplazar los archivos existentes de Microsoft Dynamics NAV, siga estos pasos:
  1. Cierre al cliente para Microsoft Dynamics NAV Classic.
  2. Busque el directorio de instalación de cliente de Microsoft Dynamics NAV Classic. El cliente de Microsoft Dynamics NAV Classic normalmente se instala en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\60\Classic
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación de cliente de Microsoft Dynamics NAV Classic.
  5. Haga clic en para sobrescribir los archivos en el directorio.

Paso 2: Reemplace los archivos de la instalación del cliente de Microsoft Dynamics NAV adaptado a roles

En la instalación del cliente adaptado a roles Microsoft Dynamics NAV, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Microsoft.dynamics.framework.patterns.dll1.3.10803.26871,65618-Jul-201006:30x86
Microsoft.dynamics.framework.ui.dll1.3.10803.268698,32818-Jul-201006:30x86
Microsoft.dynamics.framework.ui.mapping.dll1.3.10803.268104,42418-Jul-201006:30x86
Microsoft.dynamics.framework.ui.navigation.dll1.3.10803.26834,80018-Jul-201006:30x86
Microsoft.dynamics.framework.ui.ux2006.dll1.3.10803.26888,04018-Jul-201006:30x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll1.3.10803.26863,48018-Jul-201006:30x86
Microsoft.dynamics.framework.ui.windows.dll1.3.10803.26883,94418-Jul-201006:30x86
Microsoft.dynamics.framework.ui.winforms.controls.dll1.3.10803.2682,115,58418-Jul-201006:30x86
Microsoft.dynamics.framework.ui.winforms.dll1.3.10803.268690,15218-Jul-201006:30x86
Microsoft.dynamics.nav.client.builder.dll6.0.31361.0198,54418-Jul-201015:14x86
Microsoft.dynamics.nav.client.exe6.0.31361.0149,37618-Jul-201015:14x86
Microsoft.dynamics.nav.client.interop.communicator.dll1.0.559.18375,68818-Jul-201015:14x86
Microsoft.dynamics.nav.client.serviceconnection.dll6.0.31361.0104,35218-Jul-201015:14x86
Microsoft.dynamics.nav.client.ui.dll6.0.31361.0509,82418-Jul-201015:14x86
Microsoft.dynamics.nav.client.winforms.dll6.0.31361.0337,80818-Jul-201015:14x86
Microsoft.dynamics.nav.client.winforms.tlbNo aplicable2,64418-Jul-201012:06No aplicable
Microsoft.dynamics.nav.language.dll6.0.31361.01,992,57618-Jul-201015:14x86
Microsoft.dynamics.nav.types.dll6.0.31361.0567,16018-Jul-201015:14x86
Microsoft.dynamics.nav.watson.dll6.0.31361.042,88018-Jul-201015:14x86
Microsoft.office.interop.outlook.dll10.0.4504.0395,13618-Jul-201015:32x86
Para sustituir estos archivos, siga estos pasos:
  1. Cerrar al cliente adaptado a roles Microsoft Dynamics NAV.
  2. Busque el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles. El cliente adaptado a roles Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored cliente
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles.
  5. Haga clic en para sobrescribir los archivos en el directorio.

Paso 3: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Server

En la instalación de Microsoft Dynamics NAV Server, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Httpcfg.exe5.2.3790.022,35218-Jul-201015:32x86
Microsoft.dynamics.nav.language.dll6.0.31361.01,992,57618-Jul-201015:14x86
Microsoft.dynamics.nav.ncl.dll6.0.31361.0608,12018-Jul-201015:14x86
Microsoft.dynamics.nav.server.exe6.0.31361.0141,18418-Jul-201015:14x86
Microsoft.dynamics.nav.service.dll6.0.31361.0145,28018-Jul-201015:14x86
Microsoft.dynamics.nav.service.runtime.dll6.0.31361.075,66418-Jul-201015:14x86
Microsoft.dynamics.nav.service.webservices.dll6.0.31361.0145,30418-Jul-201015:14x86
Microsoft.dynamics.nav.types.dll6.0.31361.0567,16018-Jul-201015:14x86
Microsoft.dynamics.nav.watson.dll6.0.31361.042,88018-Jul-201015:14x86
Nclcsrt.etxNo aplicable89,52518-Jul-201008:30No aplicable
Nclcsrt.stxNo aplicable91,72418-Jul-201008:30No aplicable
Nclcsrts.dll6.0.31361.01,485,13618-Jul-201015:32x86
Ndbcs.dll6.0.31361.01,350,48018-Jul-201015:32x86

Para sustituir estos archivos, siga estos pasos:
  1. Detener el Microsoft Dynamics NAV Server.
  2. Busque el directorio de instalación de Microsoft Dynamics NAV Server. La de Microsoft Dynamics NAV Server normalmente se instala en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\60\Service
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Server.
  5. Haga clic en para sobrescribir los archivos en el directorio.
  6. Iniciar el Microsoft Dynamics NAV Server.

Paso 4: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Application Server

Si tiene instalado Microsoft Dynamics NAV Application Server, sustituya los archivos siguientes de la instalación de Microsoft Dynamics NAV Application Server utilizando la revisión o la actualización de los archivos.
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Dbm.dll6.0.31361.0427,84818-Jul-201015:24x86
Nas.exe6.0.31361.02,271,04818-Jul-201015:32x86
Nassql.exe6.0.31361.02,369,36018-Jul-201015:32x86
Ndbcs.dll6.0.31361.01,350,48018-Jul-201015:31x86
Slave.exe6.0.31361.0152,40018-Jul-201015:24x86
Para reemplazar los archivos, siga estos pasos.
  1. Detener el servidor de aplicaciones Microsoft Dynamics NAV.
  2. Busque el directorio de instalación de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server normalmente se instala en el directorio siguiente:
    C:\Program Files\Microsoft Dynamics NAV\60\Application Server
  3. Copie los archivos que ha descargado.
  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Application Server.
  5. Haga clic en para sobrescribir los archivos en el directorio.
  6. Inicie Microsoft Dynamics NAV Application Server.

Requisitos previos

Debe tener Microsoft Dynamics NAV 2009 Service Pack 1 instalado para aplicar esta revisión.

Estado


Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Nota: Es un artículo "Publicación rápida" creado directamente desde dentro de la organización de soporte técnico de Microsoft. La información contenida en este documento se proporciona como está en respuesta a nuevos problemas. Como consecuencia de la velocidad en la puesta a disposición, los materiales pueden incluir errores tipográficos y podrán revisarse en cualquier momento sin previo aviso. Para obtener información adicional, consulte Condiciones de uso.