Imágenes vinculadas no aparecen cuando una presentación de PowerPoint y las imágenes se mueven a una nueva unidad


Síntomas


Después de mover una presentación de Microsoft PowerPoint y de imágenes que están vinculados a esa presentación a una nueva unidad o ubicación de la carpeta, las imágenes no son visibles. En su lugar, las imágenes se muestran como marcadores de posición, incluso si las imágenes están en la misma carpeta en la misma unidad donde se encuentra la presentación.

Por ejemplo, crear una presentación que contiene muchas imágenes vinculadas y, a continuación, lo escribe en un disco compacto grabable (CD-R). Cuando abre la presentación desde el CD-R en otro equipo, no se muestran las imágenes de la presentación, aunque sean en el CD-R.

Causa


Se ha movido la carpeta que contiene las imágenes. Microsoft Office PowerPoint 2007, PowerPoint 2003 y PowerPoint 2002 usan una ruta absoluta para situar las imágenes vinculadas. Si cambia la letra de unidad o ruta de acceso, las imágenes no aparecen. Esto puede ocurrir cuando una presentación creada en la unidad C se escriben en el directorio raíz de una unidad de CD-R y abrir desde la unidad de CD-ROM, normalmente unidad D. Dado que las rutas de acceso a las imágenes vinculadas comienzan con C, no se encuentran las imágenes cuando se abre la presentación.

Solución alternativa


Para evitar este problema, utilice cualquiera de los métodos siguientes.

Método 1: Utilizar "Empaquetar para CD" o "empaquetar publicaciones y"

Cuando desee ejecutar una presentación en otro equipo, PowerPoint puede crear un paquete que incluye todos los archivos necesarios en una sola carpeta o en un CD. PowerPoint 2002 puede poner todos los archivos necesarios en un archivo único o varios discos. A continuación, desempaquete el Pack de PowerPoint 2002 y el archivo de ir en el recurso compartido de red o el equipo de destino y ejecutar la presentación.

Cuando empaquete una presentación, puede decidir incluir todos los archivos vinculados en la presentación. Al hacerlo, PowerPoint convierte las rutas de acceso absolutas de los vínculos de imagen a las relativas. Es decir, en lugar de la ruta de acceso es "C:\My Documents\My Pictures\image001.jpg", la ruta se convierte en "imagen001.jpg".

Empaquetar una presentación y los archivos asociados

PowerPoint 2010

Para utilizar la característica Empaquetar para CD-ROM de PowerPoint 2007, siga estos pasos:
  1. Abra la presentación que desea empaquetar para CD-ROM.
  2. Haga clic en el Botón de Microsoft OfficeMicrosoft Office Button , elija Publicary, a continuación, haga clic en Empaquetar para CD.
  3. Si se le pide que confirme la conversión a formatos de PowerPoint anteriores, haga clic en Aceptar.
  4. De forma predeterminada, todos los archivos vinculados se incluyen con la presentación empaquetada. Haga clic en Copiar a la carpetao haga clic en Copiar a CD.

    Si hizo clic en Copiar a la carpeta, siga estos pasos:
    1. Escriba un nombre de carpeta en el cuadro Nombre de carpeta y, a continuación, haga clic en Examinar para buscar un destino para esta carpeta.
    2. Haga clic en Seleccionary, a continuación, haga clic en Aceptar.
    3. Haga clic en para incluir los archivos vinculados junto con la presentación.
    Si hizo clic en Copiar a CD, debe tener un CD grabable en blanco listo para insertarse en la unidad de disco CD o DVD. Haga clic en Reintentar. Cuando PowerPoint termine de grabar el CD, haga clic en No cuando se le pida para grabar otro CD.
  5. Haga clic en Cerrar.
Para iniciar la presentación, puede insertar el CD en un equipo y, a continuación, haga doble clic en el icono del CD en el Explorador de Windows, o puede buscar la carpeta que creó en el paso 4 y, a continuación, abra la presentación en PowerPoint 2007.

PowerPoint 2003

Para utilizar la característica Empaquetar para CD-ROM de PowerPoint 2003, siga estos pasos:
  1. Abra la presentación que desea empaquetar para CD-ROM.
  2. En el menú archivo , haga clic en Empaquetar para CD .
  3. De forma predeterminada, todos los archivos vinculados se incluyen con la presentación empaquetada. Haga clic en Copiar a la carpetao haga clic en Copiar a CD.

    Si hizo clic en Copiar a la carpeta, siga estos pasos:
    1. Escriba un nombre de carpeta en el cuadro Nombre de carpeta y, a continuación, haga clic en Examinar para buscar un destino para esta carpeta.
    2. Haga clic en Seleccionary, a continuación, haga clic en Aceptar.
    3. Haga clic en para incluir los archivos vinculados junto con la presentación.
    Si hizo clic en Copiar a CD, debe tener un CD grabable en blanco listo para insertarse en la unidad de disco CD o DVD. Haga clic en Reintentar. Cuando PowerPoint termine de grabar el CD, haga clic en No cuando se le pida para grabar otro CD.
  4. Haga clic en Cerrar.
Para iniciar la presentación, puede insertar el CD en un equipo y, a continuación, haga doble clic en el icono del CD en el Explorador de Windows, o puede buscar la carpeta que creó en el paso 4 y, a continuación, abra la presentación en PowerPoint 2007.

PowerPoint 2002

Utilizar empaquetar publicaciones en una presentación para ejecutarla en otro equipo, siga estos pasos:

  1. Abra la presentación que desea empaquetar.
  2. En el menú archivo , haga clic en Empaquetar publicaciones.
  3. Siga las instrucciones en el Asistente para empaquetar.

    Cuando se le indique para que qué unidad desea copiar a, haga clic en Seleccionar destino y desplácese a una ubicación de archivo temporal. Esto es donde empaquetar la presentación y sus archivos asociados. Haga clic en Siguiente.
  4. Elija esta opción incluir Los archivos vinculados. En este punto, puede elegir incrustar fuentes TrueType con la presentación. Haga clic en Siguiente.
  5. No incluya el Visor. Haga clic en siguientey, a continuación, haga clic en Finalizar.
A continuación, puede copiar el archivo empaquetado y el programa Pngsetup.exe a cualquier recurso compartido de red o la unidad que elija.

Desempaquetar una presentación de PowerPoint 2002

Para ver la presentación, debe ir a la ubicación que ha copiado el archivo del paquete a y desempaquetarla. Para ello, siga estos pasos:

  1. En Microsoft Windows Explorer, desplácese a la ubicación de la presentación empaquetada y haga doble clic en Pngsetup.
  2. Escriba la ubicación donde desee desempaquetar el archivo en.
  3. Haga clic en Aceptar.
La presentación y las imágenes vinculadas se puede desempaquetar en la ubicación que elija.

Utilizando código de Macro para establecer la ruta de acceso relativa

Microsoft proporciona ejemplos de programación únicamente con fines ilustrativos, sin ninguna garantía expresa o implícita. Esto incluye, pero no se limita, a las garantías implícitas de comerciabilidad o idoneidad para un propósito particular. Este artículo asume que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento. Sin embargo, no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos.
Nota: Los siguientes ejemplos de macro sólo funcionan en PowerPoint. Visual Basic para Aplicaciones, Microsoft PowerPoint Viewer no admite macros. Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:

230746 PPT: Viewer: las Macros de presentación no se ejecutan dentro del Visor


También puede utilizar una macro para convertir los vínculos de absoluta a relativa. Esto permitirá que PowerPoint busque las imágenes basadas en la ubicación actual de la presentación, siempre y cuando las imágenes estén en la misma ubicación.

El siguiente es un ejemplo de código muestra una manera en que esto podría automatizarse. Este ejemplo de código se supone que la presentación y las imágenes vinculadas están en la misma ubicación de carpeta. Si no están en la misma ubicación de carpeta, a continuación, ejecutar este código romperá el vínculo a la imagen.

Código de ejemplo

  1. Abra el Editor de Visual Basic:

    PowerPoint 2010
    1. Haga clic en la ficha Ver .
    2. En el grupo de Macros , haga clic en Macros .
    3. Escriba RelPict en el cuadro Nombre de Macro y, a continuación, haga clic en crear.
    PowerPoint 2003 y PowerPoint 2002
    1. En el menú Herramientas , elija Macroy, a continuación, haga clic en seguridad.
    2. Para el nivel de seguridad, haga clic en medio . Haga clic en Aceptar.
    3. En el menú Herramientas , elija Macro y, a continuación, haga clic en Editor de Visual Basic.
    4. En el menú Insertar , haga clic en módulo.
  2. Escriba el código siguiente en el módulo:
    Sub RelPict()
    Dim oSlide As Slide
    Dim oShape As Shape
    Dim lPos As Long
    Dim strLink As String
    '
    ' Loop through the presentation checking each shape
    ' on each slide to see if it is a linked picture.
    '
    For Each oSlide In ActivePresentation.Slides
    For Each oShape In oSlide.Shapes
    If oShape.Type = msoLinkedPicture Then
    With oShape.LinkFormat
    '
    ' Search from the right hand portion of the source
    ' filename and find the first backslash "\" character.
    '
    lPos = InStrRev(.SourceFullName, "\")
    '
    ' Check to see if the link has already been modified.
    '
    If lPos <> Null Then
    '
    ' Determine how long the filename is, by subtracting
    ' the position the "\" character was found at from
    ' the total length of the source file name.
    '
    lPos = Len(.SourceFullName) - lPos
    '
    ' Extract the filename from the source file name, then
    ' assign the filename to the source file name, turning
    ' it into a relative path.
    '
    strLink = Right(.SourceFullName, lPos)
    .SourceFullName = strLink
    End If
    End With
    End If
    Next oShape
    Next oSlide
    End Sub

Estado


Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".