El servicio de Cluster Server puede dejar de responder en un nodo de clúster de Windows Server 2008 cuando una aplicación realiza copia de seguridad VSS de archivos de un volumen


Síntomas


El servicio de Cluster Server puede dejar de responder (se bloquea) en un nodo de clúster de Windows Server 2008 cuando una aplicación realiza backup de Volume Shadow Copy Service (VSS) de archivos de un volumen.

El archivo Cluster.log puede contener información similar a la siguiente:
864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify - Version X-1.4 Component Name Cluster Database864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify - Add Files To File Group target path %WINDIR%\cluster\
864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify Returned true
864:fb0.01/21[03:02:05.792](000000) ERR mscs::ClusterVssWriter::FindClusterComponent: AssertionFailed(668)' because of 'failed assertion'(compCount > 0 is false)

Además, se graban los sucesos siguientes en el registro de aplicación.

Id. de suceso 1000

Id. de suceso 12305

Id. de evento 12290

Id. de suceso 16387

Nota para los desarrolladores Este problema puede producirse si la aplicación de backup prepara la copia de seguridad utilizando un parámetro IVssWriterComponents vacío.

Causa


Una variable de puntero en la función IsClusterWriterPresent del objeto ClusterVssWriter a su vez señala a cada componente en la lista de entrada. Esta variable no se inicializa en NULL. Si la lista de entrada está vacía, esta variable contiene una dirección aleatoria. Por lo tanto, se produce una infracción de acceso cuando el servicio de Cluster Server intenta desasignar la dirección aleatoria.

Solución


Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar el servicio de Cluster Server en el equipo de Windows Server 2008.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Windows Server 2008, versiones basadas en x86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Clussvc.exe6.0.6001.221512,333,18405-Apr-200800:57x86
Windows Server 2008, versiones basadas en Itanium
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Clussvc.exe6.0.6001.221516,458,88005-Apr-200801:12IA-64
Windows Server 2008, versiones basadas en x64
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataforma
Clussvc.exe6.0.6001.221513,857,92005-Apr-200818:29x64

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información


Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft