No ocurre nada al hacer clic en un enlace en Internet Explorer

Se aplica a: Internet Explorer 9

Síntomas


Al hacer clic en un hipervínculo en una página web o en un mensaje de correo electrónico, no ocurre nada. Internet Explorer no abre la página web.
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Nota
Esta información se aplica a Internet Explorer 9, Internet Explorer 8 e Internet Explorer 7.

Causa


Esto puede suceder por una o más de las siguientes razones:
  • La configuración en la que elija qué navegador web desea utilizar está dañada. Esto puede hacer que Windows malinterprete qué navegador está configurado como el navegador predeterminado en su computadora.
  • Después de instalar el software, se cambió la configuración, lo que puede hacer que los enlaces a las páginas web funcionen incorrectamente.
  • Un navegador o complemento instalado previamente podría estar interfiriendo con otro software en su computadora.
  • Las claves del registro se cambiaron o se corrompieron.

Resolución


Esta sección está destinada a un usuario de equipo de inicio a intermedio. Si estos métodos no resuelven el problema, puede probar los métodos en la sección "Solución de problemas avanzada".Para resolver el problema, utilice los métodos siguientes en el orden en que se presentan.Método 1: Compruebe la configuración predeterminada del navegador web 
En Microsoft Windows, puede seleccionar el explorador web que desea usar. Para convertir Internet Explorer en su navegador web predeterminado, siga estos pasos:
  1. Para abrir Internet Explorer, haga clic en Inicioy, a continuación, haga clic en Internet Explorer.
  2. Si se le pide que confirme que desea que Internet Explorer sea el explorador predeterminado, haga clic en .
  3. En el menú Herramientas y, a continuación, haga clic en Opciones de Internet.
  4. Haga clic en la pestaña Programas y, a continuación, haga clic en Hacer predeterminado.
  5. Haga clic en Aceptary, a continuación, cierre Internet Explorer.
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    Nota
    Los cambios surtirán efecto la próxima vez que inicie Internet Explorer.

Compruebe si el problema se ha resuelto. Si se resuelve el problema, ha terminado con este artículo. Si el problema no se resuelve, pruebe el siguiente método.

Método 2: Cambiar los tipos de archivo que se abre Internet Explorer de forma predeterminada

Para Windows 7 y Windows Vista 
  1. Cierre todas las ventanas de Internet Explorer.
  2. Haga clic en Inicio y luego en Panel de control.
  3. Haga clic en Programasy, a continuación, haga clic en Establecer los programas predeterminados.
  4. En el menú Programas , haga clic en Internet Explorery, a continuación, haga clic en Elegir valores predeterminados para este programa.
  5. Asegúrese de que las casillas de verificación de .htm, .seseleccionan html y .url y, a continuación, haga clic en Guardar.
  6. Haga clic en Aceptar.
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    Nota
    Los cambios surtirán efecto la próxima vez que inicie Internet Explorer.
En Windows XP
  1. Para abrir el Explorador de Windows, haga clic con el botón secundario en Inicioy, a continuación, haga clic en Mi PC.
  2. En el menú Herramientas, haga clic en Opciones de carpetay, a continuación, haga clic en la ficha Tipos de archivo.
  3. Busque y seleccione el tipo de archivo HTM.
  4. Asegúrese de que Internet Explorer está seleccionado como el programa Se abre con. Si Internet Explorer no está seleccionado, haga clic en Cambiar, seleccione Internet Explorer como programa recomendado y, a continuación, haga clic en Aceptar.
  5. Repita los pasos 3 y 4 para los siguientes tipos de archivo: Html Su Mht MTHML Xml Xsl

Compruebe si el problema se ha resuelto. Si se resuelve el problema, ha terminado con este artículo. Si el problema no se resuelve, vaya al método siguiente.

Método 3: Utilice el modo Internet Explorer Sin complementos

Aunque los complementos del navegador pueden mejorar su experiencia en línea, ocasionalmente pueden interferir o entrar en conflicto con otro software en su computadora. Sin embargo, tenga en cuenta que es posible que algunas páginas web, o Internet Explorer en sí, no se muestren correctamente si un complemento está deshabilitado. En primer lugar, inicie Internet Explorer con complementos deshabilitados temporalmente para ver si se ha resuelto el problema. (Los complementos se deshabilitarán solo hasta que reinicie Internet Explorer de la manera habitual). Para ello, siga estos pasos:
  • Haga clic en Inicio, escriba Internet Explorer en el cuadro Buscar y, a continuación, haga clic en Internet Explorer (sin complementos).
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    Nota
    En Windows XP, haga clic en Inicio, haga clic con el botón secundario en el icono de Internet Explorer y, a continuación, haga clic en Examinar sin complementos.
Si el modo No hay complementos de Internet Explorer resuelve el problema, siga estos pasos para identificar el complemento del explorador que está causando el problema:
  1. Para iniciar Internet Explorer, haga clic en Inicioy, a continuación, haga clic en Internet Explorer.
  2. Haga clic en el botón Herramientas y, a continuación, haga clic en Administrar complementos.
  3. Haga clic en un complemento de la lista Nombre y, a continuación, haga clic en Deshabilitar. Pruebe Internet Explorer.
  4. Repita el paso 3 hasta que identifique el complemento que está causando el problema.

Compruebe si el problema se ha resuelto. Si se resuelve el problema, ha terminado con este artículo. Si el problema no se resuelve, pruebe el siguiente método.

Método 4: Restablecer la configuración de Internet Explorer

Si el problema se debe a la configuración o complementos de Internet Explorer dañados o incompatibles, normalmente puede resolver el problema restableciendo la configuración de Internet Explorer a la configuración predeterminada. Al restablecer la configuración de Internet Explorer, se pierden todas las configuraciones anteriores y no se pueden recuperar. Al restaurar la configuración predeterminada de Internet Explorer, es posible que algunas páginas web que se basan en cookies almacenadas, datos de formulario, contraseñas o complementos del explorador instalados anteriormente no funcionen correctamente. Sin embargo, restablecer Internet Explorer a la configuración predeterminada no elimina sus favoritos, fuentes y varias otras configuraciones personales. Para restablecer la configuración de Internet Explorer, siga estos pasos:
  1. Cierre todas las ventanas de Internet Explorer.
  2. Haga clic en Inicio, escriba inetcpl.cpl en el cuadro Buscar y, a continuación, haga clic en inetcpl.cpl en la lista Programas. Aparece el cuadro de diálogo Opciones de Internet.
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    Nota
    para Windows XP, haga clic en Inicio, haga clic en Ejecutar, escriba inetcpl.cpl en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  3. Haga clic en la ficha Avanzadas.
  4. En Restablecer configuración de Internet Explorer, haga clic en Restablecer. A continuación, haga clic en Restablecer de nuevo.
  5. Cuando Internet Explorer termine de reiniciar, haga clic en Cerrar en el cuadro de diálogo Restablecer configuración de Internet Explorer.
  6. Inicie Internet Explorer de nuevo. Los cambios surtirán efecto la próxima vez que abra Internet Explorer.
Método 5: Volver a registrar los archivos DLL de Internet Explorer necesarios 
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Nota
Esta información se aplica a Windows XPPara volver a registrar los archivos DLL, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Todos los programas, accesorios , haga clic con el botón derecho en cmd y, a continuación, seleccione Ejecutar como administrador. Si se le solicita una contraseña de administrador o una confirmación, escriba la contraseña o proporcione la confirmación.
  2. Escriba regsvr32 urlmon.dll en el cuadro Abrir y, a continuación, haga clic en Aceptar.
  3. Haga clic en Aceptar cuando reciba la confirmación.
  4. Repita los pasos 2 y 3 para los siguientes comandos: regsvr32 mshtml.dll regsvr32 shdocvw.dll regsvr32 browseui.dll regsvr32 msjava.dll
Compruebe si el problema se ha resuelto. Si se resuelve el problema, ha terminado con este artículo. Si el problema no se soluciona, vaya a la siguiente sección.

Solución de problemas avanzada

Esta sección está destinada a usuarios de computadoras más avanzados.Método 1: Crear una nueva cuenta de usuario 
Para obtener más información acerca de los perfiles de usuario, consulte ¿Qué sonlos perfiles de usuario.Para obtener más información sobre el método, vaya a los siguientes sitios web de Microsoft:
Windows 7: Corregir un perfil de usuario dañado
Windows Vista: corregir un perfil de usuario dañado
Windows XP: Cómo crear y configurar cuentas de usuario en Windows XP

Método 2: Usar Restaurar sistema

Restaurar sistema utiliza "puntos de restauración" para devolver los archivos y la configuración del sistema a un punto anterior en el tiempo sin afectar a sus archivos personales. Los puntos de restauración se crean automáticamente cada semana y justo antes de eventos significativos del sistema, como la instalación de un programa, un dispositivo o un controlador. Antes de iniciar Restaurar sistema, guarde los archivos abiertos y cierre todos los programas. Después de confirmar el punto de restauración, Restaurar sistema reinicia el equipo. Para realizar una restauración del sistema, siga estos pasos:Para Windows 7 y Windows Vista
  1. Haga clic en Inicio, haga clic en Todos los programas, Accesorios , Herramientas delsistema y, a continuación, haga clic en Restaurar sistema. Si se le solicita una contraseña de administrador o una confirmación, escriba la contraseña o proporcione la confirmación.
  2. Haga clic en Siguiente en la página Restaurar sistema.
  3. Seleccione la fecha o descripción de restauración del sistema que desee.
    Icono de información
    Nota
    Si no ve la fecha específica que está buscando, seleccione Mostrar más fechasy, a continuación, seleccione la fecha que desee.
  4. En la ventana de confirmación, haga clic en Finalizar.
El equipo se reiniciará. Cuando se complete el proceso, recibirá un mensaje de confirmación.Para Windows XP 
  1. Inicie sesión en Windows con una cuenta que tenga permisos administrativos.
  2. Haga clic en Inicio, haga clic en Todos los programas, Accesorios , Herramientas delsistema y, a continuación, haga clic en Restaurar sistema.
  3. En la página Bienvenido a Restaurar sistema, seleccione la opción Restaurar mi equipo a una hora anterior y, a continuación, haga clic en Siguiente.
  4. En la página Seleccionar un punto de restauración, haga clic en el punto de restauración del sistema más reciente de la lista En esta lista, haga clic en una lista de puntos de restauración y, a continuación, haga clic en Siguiente.
  5. En la página Confirmar selección de punto de restauración, haga clic en Siguiente. Restaurar sistema restaura la configuración anterior de Windows XP y, a continuación, reinicia el equipo.
  6. Inicie sesión en el equipo como administrador. A continuación, haga clic en Aceptar en la página Restaurar restauración completa del sistema.
El equipo se reiniciará. Cuando se complete el proceso, recibirá un mensaje de confirmación.Si utiliza Restaurar sistema pero el problema persiste u otros problemas se producen, puede deshacer la operación de restauración. Después de deshacer la operación, puede intentar usar un punto de restauración diferente. Para deshacer una operación de restauración del sistema, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Todos los programas, Accesorios , Herramientas delsistema y, a continuación, haga clic en Restaurar sistema.
  2. Haga clic en Deshacer restauración del sistemay, a continuación, haga clic en Siguiente.
  3. Revise sus opciones y, a continuación, haga clic en Finalizar.
El equipo se reiniciará. Una vez completado el proceso, recibirá una confirmación.

Recursos adicionales


Compruebe si el problema se ha resuelto. Si se resuelve el problema, ha terminado con este artículo. Si el problema no se resuelve, también puede usar los servicios de soporte al cliente de Microsoft para encontrar otras soluciones. Los servicios de soporte técnico de Microsoft incluyen lo siguiente:
  • Buscar en Microsoft Knowledge Base:busque información de soporte técnico y herramientas de autoayuda para los productos de Microsoft.
  • Centros de soluciones:vea preguntas específicas del producto, preguntas frecuentes y aspectos destacados de soporte técnico.
  • Comunidad de Microsoft:Póngase en contacto con homólogos, pares y profesionales más valiosos de Microsoft (MVP).
  • Otras opciones de soporte técnico:haga una pregunta, póngase en contacto con los servicios de soporte técnico de Microsoft o proporcione comentarios.
Si sigue teniendo problemas con Internet Explorer o si desea hacer una pregunta, póngase en contacto con el soporte técnico de Microsoft o proporcione comentarios, visite el sitio web de soporte técnico de Microsoft.