Se produce un error de tiempo de espera cuando se ejecuta el proceso de sincronización de Outlook desde Microsoft Office Outlook para sincronizar con Microsoft Dynamics NAV


En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.

Síntomas


Cuando se ejecuta el proceso de sincronización de Outlook desde Microsoft Office Outlook para sincronizar con Microsoft Dynamics NAV 5.0 con el Service Pack 1 (SP1), Microsoft Dynamics NAV 2009 o con Microsoft Dynamics NAV 2009 con SP1, Microsoft Dynamics NAV Application Server (NAS) produce el siguiente mensaje de error:
No se recibió la respuesta de Microsoft Dynamics NAV debido a tiempo de espera de conexión. Compruebe si se está ejecutando el servidor de Microsoft Dynamics NAV e inténtelo de nuevo más tarde. Si el problema persiste, aumente el valor de tiempo de espera en el archivo de configuración.

Este problema se produce si la tabla de Movimientos de cambio (405) contiene un gran número de registros.

Causa


Este problema se produce debido a una de las siguientes razones:
  • El último intento de sincronización no tuvo éxito.
  • Si no ha ejecutado recientemente el proceso de sincronización, se realiza una exploración de tabla completa para comprobar los cambios en la tabla Movimiento del registro de cambios (405). Esto provoca un error de tiempo de espera cuando la tabla Movimiento del registro de cambios contiene un gran número de registros.

Solución


Información de la revisión

Ahora hay una revisión compatible de Microsoft. Sin embargo, sólo se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Esta revisión puede ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere al próximo service pack de Microsoft Dynamics NAV o la siguiente versión que contenga este hotfix.

Nota: En casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.



Información sobre la instalación

Microsoft proporciona ejemplos de programación únicamente con fines ilustrativos, sin ninguna garantía expresa o implícita. Esto incluye, pero no se limita, a las garantías implícitas de comerciabilidad o idoneidad para un propósito particular. Este artículo asume que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos.

Nota: Antes de instalar este hotfix, compruebe que todos los usuarios del cliente Microsoft Navision han salido del sistema. Esto incluye a los usuarios del cliente Microsoft Navision Application Services (NAS). Debe ser el único usuario del cliente conectado cuando implemente este hotfix.

Para implementar esta revisión, debe tener una licencia de desarrollador.

Recomendamos que la cuenta de usuario en la ventana Conexiones Windows o en la ventana Conexiones base de datos se asigne el identificador de rol "SUPER". Si la cuenta de usuario no se puede asignar el identificador de rol "SUPER", debe comprobar que la cuenta de usuario tiene los permisos siguientes:
  • El permiso de modificación para el objeto que se va a cambiar.
  • El permiso de ejecución para el objeto System Object ID 5210 y System Object ID 9015 del objeto.


Nota: No es necesario tener derechos para los almacenes de datos a menos que deba realizar reparaciones de datos.

Cambios de código

Nota: Siempre pruebe correcciones de código en un entorno controlado antes de aplicar las revisiones a los equipos de producción.

Para instalar este hotfix, cambie el código en la función RemoveChangeLogDuplicates de la sinc. NAV Mgt codeunit (5301) como sigue:
Código existente
...ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;

IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;

TempChangeLogEntry.RESET;
...

Código de sustitución
...ChangeLogEntry.SETCURRENTKEY("Table No.","Date and Time");
ChangeLogEntry.SETFILTER("Date and Time" , '>=%1', OSynchUserSetup."Last Synch. Time"); // Add this line.
TempChangeLogEntry.RESET;
TempChangeLogEntry.DELETEALL;

IF ChangeLogEntry.FIND('+') THEN
REPEAT
IF ChangeLogEntry."Primary Key" <>TempChangeLogEntry."Primary Key" THEN BEGIN
TempChangeLogEntry.SETRANGE("Primary Key",ChangeLogEntry."Primary Key");
IF NOT TempChangeLogEntry.FIND('-') THEN BEGIN
TempChangeLogEntry.INIT;
TempChangeLogEntry := ChangeLogEntry;
TempChangeLogEntry.INSERT;
END;
END;
UNTIL ChangeLogEntry.NEXT(-1) = 0;

TempChangeLogEntry.RESET;
...

Requisitos previos

Debe tener uno de los siguientes productos instalados para aplicar esta revisión:
  • Microsoft Dynamics NAV 2009 SP1
  • Microsoft Dynamics NAV 2009
  • Microsoft Dynamics NAV 5.0 SP1

Información de eliminación

No se puede quitar este hotfix.

Estado


Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
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