Cómo minimizar metadatos en Word 2003


Para obtener una versión de Microsoft Word 2002 de este artículo, consulte 290945 .

Resumen


Este artículo describe varios métodos que puede utilizar para minimizar los metadatos en sus documentos de Word.

Al crear, abrir o guardar un documento en Microsoft Office Word 2003, el documento puede contener contenido puede que no desee compartir con otras personas al distribuir el documento electrónicamente. Esta información se conoce como metadatos. Metadatos se utilizan para una variedad de propósitos para mejorar la edición, ver, archivado y recuperación de documentos de Office.

Algunos metadatos están fácilmente accesible a través de la interfaz de usuario de Word. Otros metadatos sólo están accesible a través de medios extraordinarios, como abrir un documento en un editor de archivos binarios de bajo nivel. Los siguientes son algunos ejemplos de metadatos que pueden almacenarse en los documentos:
  • Te llamas
  • Sus iniciales
  • Nombre de su compañía u organización
  • El nombre de su equipo
  • El nombre del servidor de red o disco duro donde guardó el documento
  • Otra información de resumen y propiedades de archivo
  • Porciones no visibles de objetos OLE incrustados
  • Revisiones de documentos
  • Versiones del documento
  • Información de la plantilla
  • Texto oculto
  • Comentarios
Metadatos se crean en una variedad de formas en los documentos de Word. Como resultado, no hay ningún método único para eliminar este contenido de los documentos. Las siguientes secciones describen áreas donde pueden guardarse los metadatos en documentos de Word.

Este artículo describe varios métodos que puede utilizar para minimizar los metadatos en sus documentos de Word.

Microsoft proporciona ejemplos de programación fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, pero no se limita, a las garantías implícitas de comerciabilidad o idoneidad para un propósito particular. Este artículo asume que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos. Para obtener más información acerca de cómo utilizar el código de ejemplo de este artículo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

290140 cómo ejecutar código de ejemplo para los programas de Office XP desde artículos de Knowledge Base

Volver al principio

Cómo quitar automáticamente la información Personal al guardar

Usted puede ahora automáticamente quitar información personal de un documento de Word cuando se guarda el documento. Para activar esta opción, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opciones.
  2. En la ficha seguridad , haga clic en el
    Casilla de verificación Quitar información personal de las propiedades de guardar el archivo en Opciones de privacidady, a continuación, haga clic en
    OK.
Nota: Este es el método preferido para quitar la información personal al guardar un documento de Word.

Volver al principio

Cómo quitar manualmente el nombre de usuario de los documentos

Para ver o cambiar su nombre de usuario, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opcionesy, a continuación, haga clic en la ficha Información del usuario.

    Aparecen los siguientes cuadros de edición:
    Nombre
    Iniciales
    Dirección de correo
  2. Si no desea que esta información aparezca en sus documentos, escriba cadenas no identificadoras o espacios en los correspondientes cuadros de edición y, a continuación, haga clic en Aceptar para aceptar los cambios.
Nota: Todos los documentos nuevos que cree contendrá esta información en lugar de los valores predeterminados que se especifican cuando se instaló Office. Sin embargo, los documentos existentes ya pueden contener esta información.

Volver al principio

Cómo quitar manualmente información de resumen Personal

Cuando crea o guarda un documento en Word, puede guardarse información de resumen en el documento. Hay varios métodos que puede utilizar para tener acceso a esta información:
  • Abra el documento. En el menú archivo , haga clic en
    Propiedades. El Resumen,
    Estadísticas, contenido, y
    Fichas personalizadas pueden contener diversas propiedades como su nombre, el nombre de su administrador y el nombre de su compañía.
  • En Microsoft Windows Explorer, haga clic en el documento y, a continuación, haga clic en Propiedades. Las fichas en el
    Cuadro de diálogo de Propiedades puede contener información.
  • Puede utilizar una de Microsoft Visual Basic para Aplicaciones (VBA) macro o un código de otro programa para leer las propiedades que aparecen en el
    Cuadro de diálogo de Propiedades .
Para borrar la información de resumen de un documento o plantilla existente, siga estos pasos:
  1. Abra el documento o la plantilla.
  2. En el menú archivo , haga clic en
    Propiedades.
  3. Haga clic en la ficha Resumen , desactive el
    Autor, Administrador, compañíay otros cuadros de edición que no desee distribuir.
  4. En la ficha Personalizar , borre cualquier propiedad que contienen información que no desea distribuir.
  5. Haga clic en Aceptar.

    En el
    Menú archivo , haga clic en Guardary, a continuación, haga clic en
    Cerrar.
Después de completar estos pasos, el documento no contiene propiedades de resumen.

Volver al principio

Cómo quitar manualmente información de resumen Personal cuando esté conectado a una red

Si ha iniciado sesión en una red, su nombre de usuario de red puede aparecer en el cuadro autor en la ficha Resumen y en el campo guardado por en la
Ficha estadísticas cuando guarda un documento. Este problema puede producirse incluso si ha quitado todos los otros datos personales de su equipo.

Para quitar información de resumen de un documento cuando está en una red, siga estos pasos:
  1. Si el documento está almacenado en un servidor de red, cópielo al disco duro local.
  2. Inicie el equipo, pero hacerlo no inicie sesión en la red. Cuando vea el cuadro de diálogo de inicio de sesión de red, haga clic en Cancelar o presione ESC.

    Nota: Si no puede iniciar Windows al presionar ESC (por ejemplo, el equipo se ejecuta Microsoft Windows NT), no puede seguir estos pasos.
  3. Abra el documento.
  4. En el menú archivo , haga clic en
    Propiedades.
  5. Haga clic en la ficha Resumen , desactive el
    Autor, Administrador, compañíay otros cuadros de edición que contienen información que no desea distribuir.
  6. En la ficha Personalizar , borre cualquier propiedad que contienen información que no desea distribuir.
  7. Haga clic en Aceptar.

    En el
    Menú archivo , haga clic en Guardary, a continuación, haga clic en
    Cerrar.
Cuando inicie sesión en la red, no abra el archivo. Si lo hace, su nombre de usuario de red puede escribirse en el archivo. Sin embargo, puede utilizar el Explorador de Windows para copiar el archivo a un servidor de red o un disquete.

Volver al principio

Cómo eliminar manualmente comentarios en documentos

Word ofrece la capacidad de agregar comentarios a documentos. Normalmente, los comentarios contienen el nombre de la persona que los creó, por lo que puede saber quién los escribió.

Los comentarios suelen aparecer como una sección resaltada de texto; puede (ratón) en el comentario y, a continuación, haga clic en Eliminar comentario.

Cualquier nuevo comentario que cree no contendrá el nombre de usuario ya se ha eliminado del cuadro de diálogo Opciones , como se describe en la sección "Cómo a manualmente quitar su nombre de su documentos de usuario" de este artículo.

Volver al principio

Cómo quitar manualmente los encabezados y pies de página de documentos

Encabezados y pies de página en documentos pueden contener información de identificación. Para quitar información de encabezados y pies de página, siga estos pasos:
  1. En el menú Ver , haga clic en Encabezado y pie de página.
  2. El encabezado y el pie de página aparecen en la parte superior e inferior de cada página del documento.

    Realice los cambios que desee.
  3. Haga clic en Cerrar en la barra de herramientas encabezado y pie de página .
Volver al principio

Cómo quitar manualmente las marcas de revisión

Los documentos pueden contener marcas de revisión. Puede determinar quién realiza cambios específicos en un documento con marcas de revisión. Al aceptar o rechazar las marcas de revisión, el texto revisado se guarda en el documento y se quitan las marcas de revisión.

Para aceptar o rechazar las revisiones, siga estos pasos:
  1. En el menú Herramientas , haga clic en Control de cambios para habilitarla.
  2. En la barra de herramientas revisión , haga clic en anterior o siguiente para buscar y seleccionar las revisiones específicas. A continuación, haga clic en Aceptar cambio o en Rechazar cambiar o eliminar comentario para aceptar o rechazar la revisión seleccionada.
  3. Cuando haya terminado, haga clic en
    Cerrar.
Nota: Si cambia la configuración de "Ver" en la barra de herramientas revisión, no se quita la información de revisión. volver al principio

Cómo desactivar guardar rápidamente

La característica guardado rápido acelera el proceso de guardar un documento guardando únicamente los cambios realizados en un documento.

Debido al diseño de la característica guardado rápido, el texto que elimina de un documento puede permanecer en el documento incluso después de guardar el documento. Si le preocupa el texto eliminado permanezca en el documento, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opciones.
  2. Seleccione la ficha Guardar .
  3. Haga clic para desactivar la casilla de verificación Permitir guardar rápidamente y, a continuación, haga clic en Aceptar.
Para obtener más información acerca de la característica Guardar rápidamente, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

291181 preguntas más frecuentes acerca de "Permitir guardar rápidamente" en Word 2002

Volver al principio

Cómo buscar y quitar texto con formato como oculto

En documentos de Word, puede aplicar el formato de texto oculto. Como texto oculto puede contener información que no desea distribuir, que puede que desee mostrarlo y quitarlo. Para quitar todo el texto en un documento con formato de oculto, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opcionesy, a continuación, haga clic en la ficha Ver.
  2. Haga clic para activar la casilla de verificación texto oculto y, a continuación, haga clic en Aceptar.
  3. En el menú Edición , haga clic en
    Reemplazar.
  4. Haga clic en más para expandir el cuadro de diálogo.
  5. Haga clic en la casilla situada junto a Buscar.
  6. Haga clic en el botón formato y, a continuación, haga clic en
    Fuente.

    Haga clic para activar la casilla de verificación ocultoy, a continuación, haga clic en Aceptar.
  7. Haga clic en Reemplazar todo.
Todo el texto oculto se elimina del documento. Para desactivar la presentación del texto oculto, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opcionesy, a continuación, haga clic en la ficha Ver.
  2. Haga clic para desactivar la casilla de verificación texto oculto y, a continuación, haga clic en Aceptar.
Volver al principio

Cómo quitar los hipervínculos de documentos

Los documentos pueden contener hipervínculos a otros documentos o páginas Web en una intranet o en Internet. Los hipervínculos suelen aparecerán como cadenas de texto azul subrayado.

Para eliminar manualmente un solo hipervínculo de un documento, haga clic en el hipervínculo, elija hipervínculoy, a continuación, haga clic en
Quitar hipervínculo.

Si desea eliminar todos los hipervínculos de un documento, puede utilizar una macro de VBA para ello. La siguiente macro VBA de ejemplo quita todos los hipervínculos de un documento.

Nota: En la siguiente macro de ejemplo, se quita sólo el vínculo. El texto del hipervínculo permanece en el documento.

Importante: Antes de utilizar la siguiente macro de ejemplo, revise la renuncia anteriormente en este artículo.
Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Delete
Next
Next

End Sub
Para quitar todos los rastros del hipervínculo y el texto del hipervínculo del documento, puede utilizar la siguiente macro de ejemplo en su lugar.
Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Range.Delete
Next
Next

End Sub
Volver al principio

Cómo quitar estilos de documentos

Los documentos pueden incluir estilos que contienen metadatos. Puede quitar estos estilos o cambiarles el nombre. Para ello, siga estos pasos:
  1. Abra el documento que contiene los estilos.
  2. En el menú formato , haga clic en
    Estilo.
  3. Seleccione el estilo que desea eliminar o cambiar el nombre.


    Haga clic en Eliminar para eliminar el estilo, o haga clic en
    Modificar para cambiarle el nombre.
Volver al principio

Cómo quitar las versiones anteriores de archivos de documentos

Word incluye una característica de versión de archivo que le permite guardar múltiples versiones del mismo documento en el mismo archivo. Es aconsejable eliminar las versiones anteriores del documento antes de compartirlo con otros usuarios.

Para eliminar una o más versiones de un documento, siga estos pasos:
  1. En el menú archivo , haga clic en
    Versiones.
  2. Seleccione la versión del documento que desea eliminar.

    Puede seleccionar más de una versión presionando CTRL mientras selecciona las versiones.
  3. Haga clic en Eliminar.
  4. Cuando haya terminado de eliminar las versiones anteriores del documento, haga clic en Guardar en el menú archivo.
Volver al principio

Cómo quitar los vínculos de los códigos de campo

Imágenes vinculadas y otros objetos en documentos de Word pueden contener información de vinculación, como la ruta de acceso de la imagen u objeto vinculado. Puede quitar información sobre vínculos del documento mediante la modificación de los códigos de campo.

Para mostrar códigos de campo, siga estos pasos:
  1. En el menú Herramientas , haga clic en
    Opcionesy, a continuación, haga clic en la ficha Ver.
  2. Haga clic para activar la casilla de verificación códigos de campo y, a continuación, haga clic en Aceptar.
Después de que los códigos de campo están visibles, puede comprobar para ver si alguno de ellos contiene información de identificación.

Para quitar la información de vinculación de una imagen vinculada u otro objeto, siga estos pasos:
  1. Seleccione la imagen u objeto vinculado, o seleccione el código de campo para la imagen o el objeto si están visibles los códigos de campo.
  2. Presione CTRL + MAYÚS + F9.
La imagen u objeto ha quedado desvinculado. Cuando se vincula una imagen u objeto, no podrá modificarla.

Volver al principio

Cómo quitar el nombre de la plantilla y la ubicación

Todos los documentos creados en Word se basan en una plantilla. De forma predeterminada, éste es el archivo de plantilla Normal.dot, situado en la carpeta Plantillas. Sin embargo, puede crear un documento basado en una plantilla diferente en otra ubicación. La ruta de acceso y el nombre de esta plantilla se almacenan en las propiedades del documento.

Para ver el nombre de la plantilla y la ubicación, haga clic en Propiedades en el menú archivo y, a continuación, haga clic en la ficha Resumen .

Aunque no envíe la plantilla con el documento, el documento conserva el nombre y la ubicación de la plantilla. Para cambiar el nombre de la plantilla y la ubicación para no identificadora valores, siga estos pasos:
  1. En el menú Herramientas , haga clic en plantillas y complementos.
  2. Haga clic en adjuntar.
  3. Seleccione una plantilla que tiene un nombre y una ubicación que no sean sensibles ni únicos.

    Por ejemplo, porque cada equipo que tenga instalado Word incluye Normal.dot, puede desee seleccionar Normal.dot.
  4. Haga clic en Abriry, a continuación, haga clic en
    OK.
Nota: La plantilla puede contener macros, entradas de Autotexto, estilos personalizados y barras de herramientas personalizadas. Cambiando las plantillas, puede realizar algunos de estos elementos de carácter a su documento.

Volver al principio

Cómo quitar información lista de distribución

Si envía un documento por correo electrónico utilizando una lista de distribución, información de enrutamiento puede adjuntarse al documento. Para quitar esta información del documento, debe guardar el documento en un formato que no retenga información lista de distribución.

En Word, guarde el documento en formato HTML o formato de texto enriquecido (RTF). Cierre el documento y, a continuación, vuelva a abrir el nuevo archivo. Dado que la información de la lista de distribución ya no está presente, ahora puede guardar el documento en el formato de Word.

También puede seguir estos pasos:
  1. Desactive Permitir guardar rápidamente siguiendo las instrucciones anteriormente en este artículo.
  2. En el menú archivo , elija Enviar ay, a continuación, haga clic en Otro destinatario de distribución.
  3. Haga clic en Borrar para quitar de la lista de distribución y, a continuación, haga clic en Aceptar.
  4. En el menú archivo , haga clic en
    Guardar.
El documento se guarda sin ninguna información de la lista de distribución.

Volver al principio

Cómo quitar el nombre de código de Visual Basic

Importante: Antes de utilizar la siguiente macro de ejemplo, revise la renuncia anteriormente en este artículo.

Cuando grabe una macro de VBA de Word, la macro grabada empieza con un encabezado similar al siguiente:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
Para quitar el nombre de las macros que haya grabado, siga estos pasos:
  1. Abra el documento que contiene las macros.
  2. En el menú Herramientas , elija
    Macroy, a continuación, haga clic en Editor de Visual Basic. O bien, presione ALT+F11.
  3. En la ventana proyecto, haga doble clic en el módulo que contiene las macros.
  4. Quitar su nombre de código de la macro grabada.
Cuando haya terminado de quitar su nombre, presione ALT+Q para regresar al programa y, a continuación, haga clic en Guardar en el
Menú archivo .

Volver al principio

Cómo quitar las referencias de Visual Basic a otros archivos

En el Editor de Visual Basic, puede crear una referencia a otro archivo. Si un usuario abre un documento que contiene referencias a otros archivos, el usuario puede ver los nombres de los archivos que se hace referencia.

Para quitar estas referencias, siga estos pasos:
  1. Abra el documento que contiene las referencias.
  2. En el menú Herramientas , elija
    Macroy, a continuación, haga clic en Editor de Visual Basic o presione ALT + F11.
  3. En el menú Herramientas , haga clic en
    Referencias.
  4. Haga clic para desactivar la casilla de verificación situada junto al archivo o archivos.

    Cuando haya terminado, haga clic en Aceptar.
  5. Presione ALT+Q.
  6. En el menú archivo , haga clic en
    Guardar.
Nota: Si quita las referencias a otros archivos, esto puede afectar negativamente la capacidad de macros en el documento para funcionar correctamente.

Volver al principio

Cómo quitar la información de disco duro o red

Cuando guarda un documento en el disco duro local o a un servidor de red, información que identifica el disco duro local o servidor de red puede escribirse en el documento.

Para quitar esta información del documento, siga estos pasos:
  1. Abra el documento.
  2. En el menú Archivo, haga clic en Guardar como.

    Guarde el documento en la unidad de disquete (normalmente la unidad A).
  3. En el menú archivo , haga clic en
    Cerrar.
  4. Quite el disquete de la unidad de disco.
Ahora puede utilizar el Explorador de Windows para copiar el documento del disquete a cualquier disco duro o servidor de red.

Nota: Debido a la limitación de espacio de un disquete (normalmente 1,44 megabytes [MB]), este método no puede utilizarse si el tamaño de archivo del documento supera el espacio libre en el disco.

Volver al principio

Los objetos incrustados en documentos pueden contener metadatos

Si incrusta un objeto en un documento, el objeto retiene sus propias propiedades, independientemente de lo que haga con el documento. Por ejemplo, si incrusta un libro de Microsoft Excel en una palabra documento, el documento y el libro cada uno tiene sus propias propiedades.

Para quitar los metadatos de un objeto incrustado, activar el objeto, quitar los metadatos como se describe en las secciones anteriores, reactivar el documento contenedor y, a continuación, guarde el documento contenedor.

Nota: Cuando se activa un objeto incrustado en un documento, sólo una parte del objeto incrustado se muestra en el documento; el objeto puede contener información adicional que no aparece. Si desea que un documento contenga únicamente un procesamiento del objeto incrustado y no el contenido real, utilice el
Comando Cortar del menú Edición para eliminar el objeto y, a continuación, utilice el comando Pegado especial para pegar el objeto en el documento utilizando un formato de metarchivo. Después de hacer esto, ya no puede modificar el objeto incrustado; Sin embargo no contendrá ningún metadato.

Volver al principio

Las Variables de documento pueden contener metadatos

Importante: Antes de utilizar la siguiente macro de ejemplo, revise la renuncia anteriormente en este artículo.

Para eliminar las variables que figuran en el documento de Word, utilice la siguiente macro de ejemplo:
Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

For Each myVar In ActiveDocument.Variables
Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
"Value: " & myVar.Value & vbCr & vbCr & _
"Do you want to delete the variable from this document?", vbYesNo)

If Response = "6" Then
' Delete the variable.
myVar.Delete
Else
End
End If
Next myVar

MsgBox "There are no variables in the document."

End Sub
Para obtener más información acerca de las variables, en el Editor de Visual Basic, haga clic en Ayuda de Microsoft Visual Basic en el menú Ayuda , escriba Propiedad Variables en el Ayudante de Office o el Asistente para Ayuda y, a continuación, haga clic en Buscar para ver el tema.


Volver al principio

Sugerencias generales acerca de la seguridad

Éstas son algunas sugerencias generales que puede utilizar para ayudar a aumentar el nivel de seguridad en su entorno informático:
  • Siempre que no esté en su equipo, ayudan a protegerlo mediante un protector de pantalla protegido por contraseña, contraseña de encendido o la característica de bloqueo de Windows NT.
  • Si su equipo posee carpetas compartidas, asegúrese de aplicar contraseñas a ellos para que sólo los usuarios autorizados pueden tener acceso a los recursos compartidos. Para más seguridad, utilice control de acceso de nivel de usuario para que pueda controlar exactamente quién puede tener acceso a recursos compartidos de su equipo.
  • Cuando se elimina un archivo, vacíe la Papelera de reciclaje inmediatamente. Desea instalar una herramienta que borre por completo o sobrescriba los archivos cuando se eliminan.
  • Realizar una copia de los datos, almacene las copias en una ubicación segura, como una caja fuerte, una caja de seguridad o un archivador cerrado con llave.
  • Asegúrese de que los documentos importantes se-protección por contraseña para que sólo los usuarios autorizados pueden abrirlos. Almacenar las contraseñas en una ubicación segura y distinta. Si no recuerda una contraseña, no hay ninguna forma de recuperar el contenido de un documento protegido con contraseña.
  • No distribuya documentos de forma electrónica. En lugar de ello, imprímalos. No utilice elementos de identificación como fuentes distintivas, marcas de agua, logotipos o papel especial, a menos que deba (por ejemplo, para una presentación).
  • Es correo electrónico no anónimo. No enviar por correo electrónico un documento si le preocupa que su identidad pueda relacionarse de alguna manera con el documento.
  • No envíe un documento a través de Internet utilizando el protocolo HTTP o de protocolo de transferencia de archivos (FTP). Información enviada a través de estos protocolos se envía en "texto claro", esto significa que es técnicamente posible (aunque poco probable) que se intercepte.
Volver al principio