Mensajes de error cuando intenta imprimir o vista previa de un informe personalizado en Microsoft Dynamics SL: "Error 536 de motor de impresión de Crystal" o "Messaage de sistema 7014"


Síntomas


Al imprimir un informe personalizado u obtener una vista previa de un informe personalizado antes de imprimirlo en Microsoft Dynamics SL, recibe los mensajes de error siguientes:
Error del motor de impresión de Crystal: 536-Error en el archivo. No se puede conectar: parámetros de inicio de sesión incorrecto.
Mensaje de sistema 7014: Error de ejecución de informe con error 536.
.

Causa


Causa 1

El parámetro de Conexión de confianza en el archivo de informe se establece en 1. Vea la solución 1.

Causa 2

La conexión de Open Database Connectivity (ODBC) en la estación de trabajo está dañada. Vea la solución 2.

Causa 3

El informe señala a dos bases de datos diferentes. Vea la solución 3.

Causa 4

La cuenta de inicio de sesión E7F575915A2E4897A517779C0DD7CE de SQL Server 2005 o en SQL Server 2008 está deshabilitada o tiene una contraseña incorrecta. Vea la solución 4.

Solución


Resolución 1

Para resolver este problema, establezca el parámetro de Conexión de confianza en el archivo de informe en 0 (cero). Para ello, siga estos pasos:

  1. Inicie Crystal Reports 10 for Solomon.
  2. Haga clic en Abrir, seleccione el informe personalizado y, a continuación, haga clic en Abrir.
  3. En el menú base de datos , haga clic en Establecer ubicación del origen de datos.
  4. En el cuadro de diálogo Establecer ubicación del origen de datos , expanda Current Data Source: propiedades de.
  5. Bajo Current Data Source: propiedades de, busque la Trusted Connection: 1 parámetro.
    Nota: Si no aparece el parámetro de Conexión de confianza , no se seleccionó la opción de Conexión de confianza cuando se creó el informe, y ésta no es la causa del error.
  6. Haga Trusted Connection: 1y, a continuación, haga clic en Editar.
  7. Escriba 0.
  8. Haga clic en Cerrar.
  9. Haga clic en Guardar.

Resolución 2

Para resolver este problema, elimine las conexiones ODBC de Microsoft Dynamics SL. Después, deje que Microsoft Dynamics SL vuelva a crearlas. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Panel de Control, haga clic en Herramientas administrativasy, a continuación, haga clic en Orígenes de datos (ODBC).
  2. En la ficha DSN de usuario , quite los elementos que señalen a sus bases de datos de la aplicación Microsoft Dynamics SL.
  3. En la ficha DSN de sistema , quite los elementos que señalen a sus bases de datos de la aplicación Microsoft Dynamics SL.
  4. Vuelva a ejecutar el informe en Microsoft Dynamics SL. Las conexiones ODBC automáticamente se vuelven a crear cuando se ejecuta un informe en Microsoft Dynamics SL.

Resolución 3

Para resolver este problema, restablezca el origen de datos en Crystal Reports. Para ello, siga estos pasos:
  1. Inicie Crystal Reports 10 for Solomon.
  2. Haga clic en Abrir, seleccione el informe personalizado y, a continuación, haga clic en Abrir.
  3. En el menú base de datos , haga clic en Establecer ubicación del origen de datos.
  4. En el cuadro Reemplazar con , expanda Crear una conexión nuevay, a continuación, expanda ODBC (RDO).
  5. Haga clic en la base de datos de Microsoft Dynamics SL y, a continuación, haga clic en siguiente.
  6. Introduzca su información de inicio de sesión. No seleccione la casilla de verificación Conexión de confianza .
  7. Haga clic en Finalizar.
  8. Haga clic en la base de datos en el cuadro Reemplazar con . A continuación, haga clic en la base de datos en el cuadro Origen de datos actual .
  9. Haga clic en Actualizar.
  10. Si tiene varias bases de datos en el cuadro Origen de datos actual , repita los pasos 8 y 9 para cada base de datos.
  11. Haga clic en Guardary salga de Crystal Reports.

Resolución 4

Para resolver este problema, habilite la cuenta de inicio de sesión E7F575915A2E4897A517779C0DD7CE de SQL Server 2005 o en SQL Server 2008 y, a continuación, ejecutar el escenario de actualización Synchronize All Ownership & Security en la pantalla de Mantenimiento de bases de datos (98.290.00) en Microsoft Dynamics SL. Para ello, siga estos pasos:
  1. Inicie SQL Server Management Studio y, a continuación, conectar con el servidor que hospeda las bases de datos de Microsoft Dynamics SL.
  2. En el panel Explorador de objetos , expanda seguridady, a continuación, expanda inicios de sesión.
  3. En los inicios de sesión, haga E7F575915A2E4897A517779C0DD7CEy, a continuación, haga clic en Propiedades.
  4. En el panel Seleccionar una página , haga clic en estadoy, a continuación, haga clic en habilitado en el Inicio de sesión.
  5. Haga clic en Aceptary, a continuación, cierre SQL Server Management Studio.
  6. En el Panel de Control, haga clic en Herramientas administrativasy, a continuación, haga clic en Mantenimiento de bases de datos de Microsoft Dynamics SL.
  7. Conectarse a la instancia de SQL Server que hospeda las bases de datos de Microsoft Dynamics SL.
  8. Haga clic en la ficha Actualizar base de datos .
  9. En la lista de Escenarios de actualización , haga clic en Synchronize All Ownership & Securityy, a continuación, haga clic en Actualizar base de datos.
  10. En la parte inferior de la pantalla de Mantenimiento de bases de datos (98.290.00) , confirme que la barra de progreso ha terminado y, a continuación, haga clic en Cerrar.