Cómo ejecutar código de ejemplo de artículos de Knowledge Base en Office 2000


Para obtener una versión de Microsoft Office XP de este artículo, consulte
290140 .
Para una versión de Microsoft Office 97 de este artículo, consulte
173707 .
Para un Microsoft Office 2001 para Mac versión de este artículo, consulte
274703 .
Para obtener una versión de Microsoft Office 98 Macintosh Edition de este artículo, consulte
181058 .

Resumen


Microsoft Knowledge Base contiene varios artículos que incluyen código de ejemplo de Visual Basic para Aplicaciones macros. Muchas de estas macros muestran conceptos básicos de programación en Visual Basic para las distintas aplicaciones de Office 2000. Este artículo contiene instrucciones sobre cómo utilizar el código de ejemplo para crear una nueva macro y cómo ejecutar dicha macro.

Más información


Microsoft proporciona ejemplos de programación fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, pero no se limita, a las garantías implícitas de comerciabilidad o idoneidad para un propósito particular. Este artículo asume que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos. Para utilizar el código de ejemplo de un artículo de Knowledge Base, debe agregar una nueva macro de Visual Basic (o seleccionar una macro existente). Después puede copiar y pegar o escribir el código de ejemplo en esta macro utilizando cualquiera de los métodos siguientes:

Para crear una nueva Macro

  1. Abra o cree una plantilla en la aplicación de Office que está utilizando.
  2. En el menú Herramientas, señale Macro y, a continuación, haga clic en Macros.
  3. En la lista Macros en , seleccione la plantilla de Word o el documento donde desee guardar la macro.
  4. En el cuadro Nombre de Macro , escriba un nombre para la macro.
  5. Haga clic en crear para abrir el Editor de Visual Basic.
  6. Siga uno de estos procedimientos:

  • Escriba el código de macro entre la línea Sub Macroname() y la línea End Sub.
Sub macroname()
Type your macro code here
End Sub

- o -

  • Copie y pegue el código de ejemplo para la macro siguiendo estos pasos:
Sub macroname()

End Sub

  1. Cambie al programa que está utilizando para ver el artículo de Knowledge Base de Microsoft, como Microsoft Internet Explorer.
  2. Para seleccionar el código de ejemplo, mantenga presionada la tecla CTRL y, a continuación, haga clic el código.
  3. En el menú Edición, haga clic en Copiar.
  4. Cambie al Editor de Visual Basic.
  5. En el Editor de Visual Basic, seleccione el texto de código existente de Sub nombredelamacro() End Sub de la macro.
  6. En el menú Edición, haga clic en Pegar.

    Nota: Al pegar, se reemplazará el texto de código existente con el código que copió desde el artículo de Knowledge Base.
Después de escribir o pegar el código de la macro en el menú archivo , haga clic en Cerrar y volver a Microsoft < aplicación >

donde < aplicación > es la aplicación de Microsoft Office 2000 que esté utilizando. Nota: Utilice la tecla TAB para aplicar sangría al texto. Las líneas que comienzan con un apóstrofo (') son comentarios y no son necesarios para ejecutar la macro. Sin embargo, es aconsejable escribirlos para facilitar la comprensión de la macro.

Para agregar el código de ejemplo a un módulo

Para agregar código a un módulo, debe tener un módulo existente o cree un nuevo módulo. Para ello, siga estos pasos:
  1. Abra o cree una plantilla en la aplicación de Office que está utilizando.
  2. En el menú Herramientas , elija Macro y, a continuación, haga clic en Editor de Visual Basic.
  3. En la ventana proyecto del Editor de Visual Basic (de forma predeterminada en la esquina superior izquierda), haga clic en el icono de proyecto con el mismo nombre que la plantilla o el documento. Si aún no ha guardado la plantilla o el documento, el nombre del proyecto será similar a (Documento1) o TemplateProject(Template1).

    Nota para usuarios de WORD: Si desea almacenar la macro en la plantilla global predeterminada, Normal.dot, haga doble clic en el proyecto Normal .
  4. Si el proyecto que seleccionó no contiene una carpeta llamada módulos, haga clic en módulo en el menú Insertar .
  5. Haga clic en la ventana de código del módulo que desea crear. La ventana de código normalmente está en la esquina superior derecha del Editor de Visual Basic.
  6. Escriba o pegue el código exactamente como aparece en el artículo de Knowledge Base, incluyendo las líneas Sub Macroname() y End Sub.

    Nota: Para obtener más información sobre cómo escribir o pegar el código de macro, consulte la sección "Para crear una Macro nueva" de este artículo.
Después de escribir o pegar el código de la macro en el menú archivo , haga clic en Cerrar y volver a Microsoft < aplicación >

donde < aplicación > es la aplicación de Microsoft Office 2000 que esté utilizando.

Para ejecutar la Macro

  1. En el menú Herramientas , elija Macro y, a continuación, haga clic en Macros.
  2. Seleccione el nombre de la macro en la lista Nombre de Macro y, a continuación, haga clic en Ejecutar.

Referencias


Microsoft Help para cada programa de Office contiene numerosos temas acerca de cómo trabajar con macros. Ayuda de Visual Basic contiene amplia información acerca de cómo escribir su propio código.

Para obtener información adicional acerca de cómo obtener ayuda con Visual Basic para Aplicaciones, consulte el artículo siguiente en Microsoft Knowledge Base:
226118 OFF2000: recursos de programación para Visual Basic para Aplicaciones