.NET Frameworki versiooni ja platvorm tugiteenuste vaheleht tõrked

NB! Artikkel on tõlgitud Microsofti masintõlketarkvaraga ja seda saab parandada Kogukonnapõhise tõlkeraamistiku (CTF) tehnoloogiaga. Microsoft pakub masintõlgitud, kogukonna järeltöödeldud ja inimtõlgitud artikleid, et anda mitmekeelne juurdepääs kõigile meie teabebaasi artiklitele. Masintõlgitud ja järeltöödeldud artiklites võib olla sõnavara-, süntaksi- ja/või grammatikavigu. Microsoft ei vastuta mingite ebatäpsuste, tõrgete ega kahjude eest, mis on tulenenud sisu valest tõlkest või selle kasutamisest meie klientide poolt. Lisateavet CTF-i kohta leiate aadressilt http://support.microsoft.com/gp/machine-translation-corrections/et.

Artikli ingliskeelse versiooni kuvamiseks klõpsake siin: 2715633
Märkus. Selles artiklis tutvustatakse vaheleht tõrketeated. Kui olete lõppkasutaja, proovige lahenduse Kui teil ilmneb vaheleht error "Peate lubama .NET Frameworki dialoogiboksis Windowsi funktsioonid." Mis tahes muud vaheleht tõrked, sisu sihtgrupp on rakenduse tarnija või arendaja, on teil ühendust rakenduse tarnijaga, et anda neile teada, et on probleeme selle rakenduse.
Tõrge: "peate lubama .NET Frameworki Windows funktsioonid dialoogiboksis"
Tõrketeade
See rakendus ei saa käivitada. Peate lubama .NET Frameworki Windows funktsioonid dialoogiboksis (juhtpaneeli kaudu, valige programmid, Windowsi funktsioonide sisse- või väljalülitamine).
Põhjus
See probleem ilmneb seetõttu, et rakendus on konfigureeritud nii, et võimaldab määrata .NET Frameworki sobiv versioon. Vastav vaheleht kood on SHIM_GOTO_CONTROLPANEL.
Lahendus
Seda lahendada, lubage .NET Framework 3.5, mis on operatsioonisüsteemi Windows 7 ja Windows 8.

Windows 8

Vaikimisi keelatud .NET Framework 3.5 Windows 8. Selle lubamiseks toimige järgmiselt.
  1. Tippige avakuval paar esimest tähteJuhtpaneel, ja seejärel valigeJuhtpaneelrakenduste loendist.
  2. KlõpsakeJuhtpaneel, valigeProgrammid. (Või valigeProgrammid ja funktsioonidkui te ei kasuta vaikimisi kategooriavaadet.)
  3. KlõpsakeProgrammid ja funktsioonid, valigeWindowsi funktsioonide sisse- või väljalülitamineavamiseks ningWindowsi funktsiooniddialoogiboks.
  4. KlõpsakeWindowsi funktsioonid, valige see.NET framework 3.5 (sisaldab .NET 2.0 ja 3.0)Märkige ruut ja valige seejärelVajutage OK.

Windows 7

Vaikimisi lubatakse .NET Framework 3.5 Windows 7 nii, et see tõrge ilmneb ainult siis, kui funktsioon varem keelatud. .NET Framework 3.5 uuesti lubamiseks toimige järgmiselt.
  1. Valige menüüst StartJuhtpaneel.
  2. KlõpsakeJuhtpaneel, valigeProgrammid. (Või valigeProgrammid ja funktsioonidkui te ei kasuta vaikimisi kategooriavaadet.)
  3. KlõpsakeProgrammid ja funktsioonid, valigeWindowsi funktsioonide sisse- või väljalülitamineavamiseks ningWindowsi funktsiooniddialoogiboks.
  4. KlõpsakeWindowsi funktsioonid, valige seeMicrosoft .NET Framework 3.5.1Märkige ruut ja valige seejärelVajutage OK.

Muu tootja lahenduse Lahtiütlemine

Teave ja lahendus selles dokumendis esindavad praeguse vaate Microsoft Corporationi avaldamisest alates nende probleemide kohta. See lahendus on saadaval Microsofti või mõne muu pakkuja kaudu. Me konkreetselt soovitada muu pakkuja või kolmanda osapoole lahendus, mis võib selles artiklis kirjeldatakse. Võib ka leiduda muid tootjaid ja muude tootjate lahendusi, mida käesolevas artiklis ei kirjeldata. Kuna me peab reageerima turuolukord, seda teavet ei tuleks tõlgendada nagu kohustus Microsoft. Me ei saa tagada või toetada täpsuse mingi teabe ega lahenduse, mida Microsoft või mõni mainitud muu pakkuja.

Microsoft ei anna mingit garantiid ning välistab otseseid, kaudseid või seaduslikke lubadusi, garantiisid ega tingimusi. Need hõlmavad, kuid ei piirdu lubadusi, garantiisid ega tingimusi pealkiri, MITTERIKKUMISE, rahuldava seisukorra, kaubastatavuse ja kindlaks otstarbeks Sobivuse, mis tahes teenuse, lahendus, toote, või muude materjalide või teavet. Ei vastuta Microsoft on käesolevas artiklis mainitud muu tootja lahenduse eest.

Tõrge: "See rakendus ei saa käivitada"
Tõrketeade
See rakendus ei saa käivitada.
Põhjus
Rakendus ei ole konfigureeritud nii, et võimaldab määrata .NET raamistiku sobiv versioon. Vastav vaheleht kood on SHIM_NOVERSION_FOUND.
Lahendus
Te ei saa konfiguratsiooni probleemi ise lahendada. Pöörduge rakenduse tarnija poole, et probleemi lahendada.
Tõrge: "see sõltub .NET Frameworki versiooni ei toetata selle seadme"
Tõrketeade
See rakendus ei saa käivitada. See sõltub .NET Frameworki versiooni ei toetata selle seadme.
Põhjus
See probleem ilmneb, sest rakendus on ehitatud käivitamiseks see seade. Näiteks võib olla proovite käivitada rakenduse, mis on ehitatud seadmes, mis on ARM protsessor on Inteli protsessor. Vastav vaheleht kood on SHIM_UNSUPPORTED_PLATFORM.
Lahendus
Te ei saa konfiguratsiooni probleemi ise lahendada. Pöörduge rakenduse tarnija poole, et installida rakenduse sobiv versioon.
Vaheleht tõrketeadete kohta
Microsoft .NET Frameworki rakenduse käivitamisel vaheleht programm määrab common language runtime (CLR) versiooni laadimine, laadib see ja käivitab rakenduse. Kui see vaheleht tekib tõrge (näiteks, kui see ei leia .NET Frameworki ühilduva arvuti), kuvatakse veateade juhiseid. Selles artiklis kirjeldatakse tõrkekoodid SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELja SHIM_UNSUPPORTED_PLATFORM.

.NET Frameworki lähtestamine tõrgete kohta lisateabe saamiseks minge ja vaadake järgmist MSDN-i veebilehte:

Hoiatus. See artikkel on masintõlgitud.

Atribuudid

Artikli ID: 2715633 – viimati läbi vaadatud: 01/02/2016 06:39:00 – redaktsioon: 7.0

Microsoft .NET Framework 4.5

  • kbquadranttechsupp kbconsumer kbsurveynew kbtshoot kbexpertiseinter kbmt KB2715633 KbMtet
Tagasiside