Users are unable to access Enterprise portal

This article provides a resolution for the issue that users can't access Enterprise portal as system admins after you upgrade to cumulative update 2 for Microsoft Dynamics AX 2012.

Applies to:   Microsoft Dynamics AX 2012
Original KB number:   2675637

Symptoms

Assume that you upgrade to cumulative update 2 for Microsoft Dynamics AX 2012. When you add users via the Microsoft Dynamics AX client as system admins, users aren't able to access Enterprise portal. Domain admins who were added to the same way are able to access Enterprise portal. In addition, you receive this error message:

You cannot view data on this page because you are not a registered user in Microsoft Dynamics AX. Contact your Microsoft Dynamics AX administrator.

Cause

AOS service account and Microsoft Dynamics AX Business Connector account do not have sufficient to Active Directory (AD).

Resolution

Grant the Microsoft Dynamics AX Business Connector and AOS service account permission to view all AD objects.

  • On a Windows Server, go to Control Panel > Administrative Tasks.
  • Go to Active Directory Users and Computers > Highlight Builtin.
  • Add AOS Service account and Business Connector Proxy Service account to the group called Windows Authorization Access Group (WAA).