The Microsoft Dynamics CRM E-mail Router incoming profile experiences the following error during Test Access (The server to which the application is connected cannot impersonate the requested user due to insufficient permission)

This article helps you resolve the problem that occurs when you test access on the accounts listed the incoming profile.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2834481

Symptoms

The Microsoft Dynamics CRM E-mail Router experiences the following error when testing access on the accounts listed the incoming profile:

The server to which the application is connected cannot impersonate the requested user due to insufficient permission

This error may also appear in the Application Event Log after the e-mail router has been deployed.

Cause

Exchange Server impersonation access rights are not granted or applied correctly to the incoming profile service account. When this occurs, the e-mail router incoming profile service account cannot access the specified mailboxes to check for incoming e-mail to be processed as Microsoft Dynamics CRM e-mail activity records.

Resolution

To resolve the issue, apply the appropriate impersonation rights based on the version of Exchange specified in the incoming profile.

For Exchange 2007, please see the following Exchange 2007 MSDN article:

Exchange Online and Exchange development

Note

Impersonation access must be setup on the Client Access Server as noted in the procedure To configure Exchange Impersonation on a server for a user.

For Exchange 2010, please see the following Exchange 2010 MSDN article:

Exchange Online and Exchange development